]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blame_incremental - python-sqlalchemy.spec
- updated to 1.2.7
[packages/python-sqlalchemy.git] / python-sqlalchemy.spec
... / ...
CommitLineData
1#
2%bcond_without python2 # CPython 2.x module
3%bcond_without python3 # CPython 3.x module
4%bcond_without tests # unit tests
5
6%define module sqlalchemy
7Summary: Database Abstraction Library for Python 2
8Summary(pl.UTF-8): Biblioteka abstrakcji baz danych dla Pythona 2
9Name: python-%{module}
10Version: 1.2.7
11Release: 1
12License: MIT
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/sqlalchemy/
15Source0: https://files.pythonhosted.org/packages/source/S/SQLAlchemy/SQLAlchemy-%{version}.tar.gz
16# Source0-md5: d228d11a6f41b94cb3a3789b5cdbd111
17Patch0: %{name}-tests.patch
18URL: http://www.sqlalchemy.org/
19BuildRequires: rpm-pythonprov
20BuildRequires: rpmbuild(macros) >= 1.714
21%if %{with python2}
22BuildRequires: python-devel >= 1:2.7
23BuildRequires: python-modules >= 1:2.7
24BuildRequires: python-setuptools >= 0.6-0.a9.1
25%if %{with tests}
26BuildRequires: python-mock
27BuildRequires: python-pytest >= 2.5.2
28BuildRequires: python-pytest-xdist
29%endif
30%endif
31%if %{with python3}
32BuildRequires: python3-devel >= 1:3.2
33BuildRequires: python3-modules >= 1:3.2
34BuildRequires: python3-setuptools >= 0.6-0.a9.1
35%if %{with tests}
36BuildRequires: python3-pytest >= 2.5.2
37BuildRequires: python3-pytest-xdist
38%endif
39%endif
40Requires: python-modules
41Provides: python-SQLAlchemy = %{version}-%{release}
42Obsoletes: python-SQLAlchemy < 0.9.8
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45%description
46The Python SQL toolkit and Object Relational Mapper that gives
47application developers the full power and flexibility of SQL.
48SQLAlchemy provides a full suite of well known enterprise-level
49persistence patterns, designed for efficient and high-performing
50database access, adapted into a simple and Pythonic domain language.
51
52Python 2.x version.
53
54%description -l pl.UTF-8
55Zestaw narzędzi SQL oraz odwzorowań obiektowo-relacyjnych dla Pythona,
56dający programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
57udostępnia pełny zbiór dobrze znanych wzorców trwałości,
58zaprojektowanych z myślą o efektywny i wydajnym dostępem do baz
59danych, zaadaptowanych do prostego, pythonowego języka.
60
61Wersja dla pythona 2.x.
62
63%package -n python3-%{module}
64Summary: Database Abstraction Library for Python 3
65Summary(pl.UTF-8): Biblioteka abstrakcji baz danych dla Pythona 3
66Group: Libraries/Python
67Provides: python3-SQLAlchemy = %{version}-%{release}
68Obsoletes: python3-SQLAlchemy < 0.9.8
69
70%description -n python3-%{module}
71The Python SQL toolkit and Object Relational Mapper that gives
72application developers the full power and flexibility of SQL.
73SQLAlchemy provides a full suite of well known enterprise-level
74persistence patterns, designed for efficient and high-performing
75database access, adapted into a simple and Pythonic domain language.
76
77Python 3.x version.
78
79%description -n python3-%{module} -l pl.UTF-8
80Zestaw narzędzi SQL oraz odwzorowań obiektowo-relacyjnych dla Pythona,
81dający programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
82udostępnia pełny zbiór dobrze znanych wzorców trwałości,
83zaprojektowanych z myślą o efektywny i wydajnym dostępem do baz
84danych, zaadaptowanych do prostego, pythonowego języka.
85
86Wersja dla Pythona 3.x.
87
88%package apidocs
89Summary: API documentation for Python SQLAlchemy module
90Summary(pl.UTF-8): Dokumentacja API modułu Pythona SQLAlchemy
91Group: Documentation
92%if "%{_rpmversion}" >= "5"
93BuildArch: noarch
94%endif
95
96%description apidocs
97API documentation for Python SQLAlchemy module.
98
99%description apidocs -l pl.UTF-8
100Dokumentacja API modułu Pythona SQLAlchemy.
101
102%package examples
103Summary: Examples for Python SQLAlchemy module
104Summary(pl.UTF-8): Przykłady do modułu Pythona SQLAlchemy
105Group: Documentation
106%if "%{_rpmversion}" >= "5"
107BuildArch: noarch
108%endif
109
110%description examples
111Examples for Python SQLAlchemy module.
112
113%description examples -l pl.UTF-8
114Przykłady do modułu Pythona SQLAlchemy.
115
116%prep
117%setup -q -n SQLAlchemy-%{version}
118%patch0 -p1
119
120%build
121%if %{with python2}
122%py_build %{?with_tests:test}
123%endif
124
125%if %{with python3}
126%py3_build %{?with_tests:test}
127%endif
128
129%install
130rm -rf $RPM_BUILD_ROOT
131%if %{with python2}
132%py_install
133
134%py_postclean
135%endif
136
137%if %{with python3}
138%py3_install
139%endif
140
141install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
142cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%files
148%defattr(644,root,root,755)
149%doc AUTHORS CHANGES LICENSE README.rst
150%dir %{py_sitedir}/sqlalchemy
151%{py_sitedir}/sqlalchemy/connectors
152%{py_sitedir}/sqlalchemy/databases
153%{py_sitedir}/sqlalchemy/dialects
154%{py_sitedir}/sqlalchemy/engine
155%{py_sitedir}/sqlalchemy/event
156%{py_sitedir}/sqlalchemy/ext
157%{py_sitedir}/sqlalchemy/orm
158%{py_sitedir}/sqlalchemy/sql
159%{py_sitedir}/sqlalchemy/testing
160%{py_sitedir}/sqlalchemy/util
161%attr(755,root,root) %{py_sitedir}/sqlalchemy/cprocessors.so
162%attr(755,root,root) %{py_sitedir}/sqlalchemy/cresultproxy.so
163%attr(755,root,root) %{py_sitedir}/sqlalchemy/cutils.so
164%{py_sitedir}/sqlalchemy/*.py[co]
165%{py_sitedir}/SQLAlchemy-%{version}-py*.egg-info
166
167%if %{with python3}
168%files -n python3-%{module}
169%defattr(644,root,root,755)
170%doc AUTHORS CHANGES LICENSE README.rst
171%dir %{py3_sitedir}/sqlalchemy
172%{py3_sitedir}/sqlalchemy/connectors
173%{py3_sitedir}/sqlalchemy/databases
174%{py3_sitedir}/sqlalchemy/dialects
175%{py3_sitedir}/sqlalchemy/engine
176%{py3_sitedir}/sqlalchemy/event
177%{py3_sitedir}/sqlalchemy/ext
178%{py3_sitedir}/sqlalchemy/orm
179%{py3_sitedir}/sqlalchemy/sql
180%{py3_sitedir}/sqlalchemy/testing
181%{py3_sitedir}/sqlalchemy/util
182%attr(755,root,root) %{py3_sitedir}/sqlalchemy/cprocessors.cpython-*.so
183%attr(755,root,root) %{py3_sitedir}/sqlalchemy/cresultproxy.cpython-*.so
184%attr(755,root,root) %{py3_sitedir}/sqlalchemy/cutils.cpython-*.so
185%{py3_sitedir}/sqlalchemy/*.py
186%{py3_sitedir}/sqlalchemy/__pycache__
187%{py3_sitedir}/SQLAlchemy-%{version}-py*.egg-info
188%endif
189
190%files apidocs
191%defattr(644,root,root,755)
192%doc doc/{_images,_modules,_static,changelog,core,dialects,faq,orm,*.html,*.js}
193
194%files examples
195%defattr(644,root,root,755)
196%{_examplesdir}/%{name}-%{version}
This page took 0.029507 seconds and 4 git commands to generate.