]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blame_incremental - python-SQLAlchemy.spec
- 0.6.5
[packages/python-sqlalchemy.git] / python-SQLAlchemy.spec
... / ...
CommitLineData
1# TODO:
2# - examples and docs for python3
3# - builds, but got syntax errors when buildings
4#
5%bcond_without python3
6%bcond_without python2
7%define module SQLAlchemy
8#
9Summary: Database Abstraction Library
10Summary(pl.UTF-8): Biblioteka abstrakcji baz danych
11Name: python-%{module}
12Version: 0.6.5
13Release: 0.1
14License: MIT
15Group: Libraries/Python
16Source0: http://downloads.sourceforge.net/sqlalchemy/%{module}-%{version}.tar.gz
17# Source0-md5: 0152094452e7e94b6505190db6c8ede8
18URL: http://www.sqlalchemy.org/
19%if %{with python2}
20BuildRequires: python-devel >= 1:2.4
21BuildRequires: python-distribute
22BuildRequires: python-setuptools >= 0.6-0.a9.1
23%endif
24%if %{with python3}
25BuildRequires: python3-2to3
26BuildRequires: python3-devel
27BuildRequires: python3-modules
28%endif
29BuildRequires: rpm-pythonprov
30BuildRequires: rpmbuild(macros) >= 1.219
31%if %{with python2}
32%pyrequires_eq python-modules
33%endif
34BuildArch: noarch
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38The Python SQL toolkit and Object Relational Mapper that gives
39application developers the full power and flexibility of SQL.
40SQLAlchemy provides a full suite of well known enterprise-level
41persistence patterns, designed for efficient and high-performing
42database access, adapted into a simple and Pythonic domain language.
43
44Python 2.x version.
45
46%description -l pl.UTF-8
47Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
48dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
49udostępnia pełny zbiór dobrze znanych wzorców trwałości,
50zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
51prostej, pythonowej domeny językowej.
52
53Wersja dla pythona 2.x.
54
55%package -n python3-%{module}
56Summary: Database Abstraction Library
57Summary(pl.UTF-8): Biblioteka abstrakcji baz danych
58Group: Libraries/Python
59
60%description -n python3-%{module}
61The Python SQL toolkit and Object Relational Mapper that gives
62application developers the full power and flexibility of SQL.
63SQLAlchemy provides a full suite of well known enterprise-level
64persistence patterns, designed for efficient and high-performing
65database access, adapted into a simple and Pythonic domain language.
66
67Python 3.x version.
68
69%description -n python3-%{module} -l pl.UTF-8
70Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
71dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
72udostępnia pełny zbiór dobrze znanych wzorców trwałości,
73zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
74prostej, pythonowej domeny językowej.
75
76Wersja dla Pythona 3.x.
77
78%prep
79%setup -q -n %{module}-%{version}
80
81%build
82%if %{with python2}
83%{__python} setup.py build -b build-2
84%endif
85%if %{with python3}
86%{__python3} setup.py build -b build-3
87%endif
88
89%install
90rm -rf $RPM_BUILD_ROOT
91%if %{with python2}
92%{__python} setup.py build -b build-2 \
93 install \
94 --single-version-externally-managed \
95 --optimize=2 \
96 --root=$RPM_BUILD_ROOT
97
98%py_postclean
99%endif
100
101%if %{with python3}
102%{__python3} setup.py build -b build-3 \
103 install \
104 --root=$RPM_BUILD_ROOT \
105 --optimize=2
106
107%py3_postclean
108%endif
109
110install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
111cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%files
117%defattr(644,root,root,755)
118%doc CHANGES README* doc/*.html
119%{py_sitescriptdir}/SQLAlchemy*
120%{py_sitescriptdir}/sqlalchemy*
121%{_examplesdir}/%{name}-%{version}
122
123%if %{with python3}
124%files -n python3-%{module}
125%defattr(644,root,root,755)
126%{py3_sitescriptdir}/SQLAlchemy*
127%{py3_sitescriptdir}/sqlalchemy*
128%endif
This page took 0.028669 seconds and 4 git commands to generate.