]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blame_incremental - python-SQLAlchemy.spec
- BR 2to3
[packages/python-sqlalchemy.git] / python-SQLAlchemy.spec
... / ...
CommitLineData
1# TODO:
2# - examples and docs for python3
3#
4%bcond_without python3
5%bcond_without python2
6%define module SQLAlchemy
7#
8Summary: Database Abstraction Library
9Summary(pl.UTF-8): Biblioteka abstrakcji baz danych
10Name: python-SQLAlchemy
11Version: 0.6.0
12Release: 1
13License: MIT
14Group: Libraries/Python
15Source0: http://downloads.sourceforge.net/sqlalchemy/%{module}-%{version}.tar.gz
16# Source0-md5: 575c2ca742e9ab3c08c384dbc4861f86
17URL: http://www.sqlalchemy.org/
18%if %{with python2}
19BuildRequires: python-devel >= 1:2.4
20BuildRequires: python-setuptools >= 0.6-0.a9.1
21%endif
22%if %{with python3}
23BuildRequires: python3-devel
24BuildRequires: python3-distribute
25BuildRequires: python3-2to3
26%endif
27BuildRequires: rpm-pythonprov
28BuildRequires: rpmbuild(macros) >= 1.219
29%if %{with python2}
30%pyrequires_eq python-modules
31%endif
32BuildArch: noarch
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36The Python SQL toolkit and Object Relational Mapper that gives
37application developers the full power and flexibility of SQL.
38SQLAlchemy provides a full suite of well known enterprise-level
39persistence patterns, designed for efficient and high-performing
40database access, adapted into a simple and Pythonic domain language.
41
42Python 2.x version.
43
44%description -l pl.UTF-8
45Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
46dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
47udostępnia pełny zbiór dobrze znanych wzorców trwałości,
48zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
49prostej, pythonowej domeny językowej.
50
51Wersja dla pythona 2.x.
52
53%package -n python3-%{module}
54Summary: Database Abstraction Library
55Summary(pl.UTF-8): Biblioteka abstrakcji baz danych
56Group: Libraries/Python
57
58%description -n python3-%{module}
59The Python SQL toolkit and Object Relational Mapper that gives
60application developers the full power and flexibility of SQL.
61SQLAlchemy provides a full suite of well known enterprise-level
62persistence patterns, designed for efficient and high-performing
63database access, adapted into a simple and Pythonic domain language.
64
65Python 3.x version.
66
67%description -l pl.UTF-8 -n python3-%{module}
68Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
69dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
70udostępnia pełny zbiór dobrze znanych wzorców trwałości,
71zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
72prostej, pythonowej domeny językowej.
73
74Wersja dla Pythona 3.x.
75
76%prep
77%setup -q -n %{module}-%{version}
78
79%build
80%if %{with python2}
81%{__python} setup.py build -b build-2
82%endif
83%if %{with python3}
84%{__python3} setup.py build -b build-3
85%endif
86
87%install
88rm -rf $RPM_BUILD_ROOT
89%if %{with python2}
90%{__python} setup.py build -b build-2 \
91 install \
92 --single-version-externally-managed \
93 --optimize=2 \
94 --root=$RPM_BUILD_ROOT
95
96%py_postclean
97%endif
98
99%if %{with python3}
100%{__python3} setup.py build -b build-3 \
101 install \
102 --single-version-externally-managed \
103 --root=$RPM_BUILD_ROOT \
104 --optimize=2
105
106%py3_postclean
107%endif
108
109install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
110cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%files
116%defattr(644,root,root,755)
117%doc CHANGES README* doc/*.html
118%{py_sitescriptdir}/SQLAlchemy*
119%{py_sitescriptdir}/sqlalchemy*
120%{_examplesdir}/%{name}-%{version}
121
122%files -n python3-%{module}
123%defattr(644,root,root,755)
124%{py3_sitescriptdir}/SQLAlchemy*
125%{py3_sitescriptdir}/sqlalchemy*
This page took 1.059378 seconds and 4 git commands to generate.