]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blame - python-sqlalchemy.spec
- up to 1.3.23
[packages/python-sqlalchemy.git] / python-sqlalchemy.spec
CommitLineData
0f266947 1#
be381d2c 2# Conditional build:
54e13700
ER
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
0b211bb2 5%bcond_without tests # unit tests
54e13700 6
aabbbe81 7%define module sqlalchemy
0b211bb2
JB
8Summary: Database Abstraction Library for Python 2
9Summary(pl.UTF-8): Biblioteka abstrakcji baz danych dla Pythona 2
1ce1e260 10Name: python-%{module}
b148bdf9 11Version: 1.3.23
be381d2c 12Release: 1
666da082 13License: MIT
4fc44ee0 14Group: Libraries/Python
0b211bb2
JB
15#Source0Download: https://pypi.org/simple/sqlalchemy/
16Source0: https://files.pythonhosted.org/packages/source/S/SQLAlchemy/SQLAlchemy-%{version}.tar.gz
b148bdf9 17# Source0-md5: 179d25a8fea451f06539c12bb0a00081
0b211bb2 18Patch0: %{name}-tests.patch
11c82359 19URL: https://www.sqlalchemy.org/
a5d67c27 20BuildRequires: rpm-pythonprov
0b211bb2 21BuildRequires: rpmbuild(macros) >= 1.714
0f266947 22%if %{with python2}
0b211bb2
JB
23BuildRequires: python-devel >= 1:2.7
24BuildRequires: python-modules >= 1:2.7
666da082 25BuildRequires: python-setuptools >= 0.6-0.a9.1
0b211bb2
JB
26%if %{with tests}
27BuildRequires: python-mock
28BuildRequires: python-pytest >= 2.5.2
29BuildRequires: python-pytest-xdist
30%endif
0f266947
AF
31%endif
32%if %{with python3}
be381d2c
JB
33BuildRequires: python3-devel >= 1:3.4
34BuildRequires: python3-modules >= 1:3.4
0b211bb2
JB
35BuildRequires: python3-setuptools >= 0.6-0.a9.1
36%if %{with tests}
37BuildRequires: python3-pytest >= 2.5.2
38BuildRequires: python3-pytest-xdist
0f266947 39%endif
0f266947 40%endif
0b211bb2 41Requires: python-modules
aabbbe81 42Provides: python-SQLAlchemy = %{version}-%{release}
2427a309 43Obsoletes: python-SQLAlchemy < 0.9.8
666da082 44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
bbaffef6
ER
47The Python SQL toolkit and Object Relational Mapper that gives
48application developers the full power and flexibility of SQL.
49SQLAlchemy provides a full suite of well known enterprise-level
50persistence patterns, designed for efficient and high-performing
51database access, adapted into a simple and Pythonic domain language.
666da082 52
0f266947
AF
53Python 2.x version.
54
2aabef56 55%description -l pl.UTF-8
0b211bb2
JB
56Zestaw narzędzi SQL oraz odwzorowań obiektowo-relacyjnych dla Pythona,
57dający programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
2aea6699 58udostępnia pełny zbiór dobrze znanych wzorców trwałości,
0b211bb2
JB
59zaprojektowanych z myślą o efektywny i wydajnym dostępem do baz
60danych, zaadaptowanych do prostego, pythonowego języka.
f3fd8b7b 61
0f266947
AF
62Wersja dla pythona 2.x.
63
64%package -n python3-%{module}
0b211bb2
JB
65Summary: Database Abstraction Library for Python 3
66Summary(pl.UTF-8): Biblioteka abstrakcji baz danych dla Pythona 3
0f266947 67Group: Libraries/Python
aabbbe81 68Provides: python3-SQLAlchemy = %{version}-%{release}
2427a309 69Obsoletes: python3-SQLAlchemy < 0.9.8
0f266947
AF
70
71%description -n python3-%{module}
72The Python SQL toolkit and Object Relational Mapper that gives
73application developers the full power and flexibility of SQL.
74SQLAlchemy provides a full suite of well known enterprise-level
75persistence patterns, designed for efficient and high-performing
76database access, adapted into a simple and Pythonic domain language.
77
78Python 3.x version.
79
1ce1e260 80%description -n python3-%{module} -l pl.UTF-8
0b211bb2
JB
81Zestaw narzędzi SQL oraz odwzorowań obiektowo-relacyjnych dla Pythona,
82dający programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
0f266947 83udostępnia pełny zbiór dobrze znanych wzorców trwałości,
0b211bb2
JB
84zaprojektowanych z myślą o efektywny i wydajnym dostępem do baz
85danych, zaadaptowanych do prostego, pythonowego języka.
0f266947
AF
86
87Wersja dla Pythona 3.x.
88
0b211bb2
JB
89%package apidocs
90Summary: API documentation for Python SQLAlchemy module
91Summary(pl.UTF-8): Dokumentacja API modułu Pythona SQLAlchemy
92Group: Documentation
be381d2c 93%if "%{_rpmversion}" >= "4.6"
0b211bb2
JB
94BuildArch: noarch
95%endif
96
97%description apidocs
98API documentation for Python SQLAlchemy module.
99
100%description apidocs -l pl.UTF-8
101Dokumentacja API modułu Pythona SQLAlchemy.
102
103%package examples
104Summary: Examples for Python SQLAlchemy module
105Summary(pl.UTF-8): Przykłady do modułu Pythona SQLAlchemy
106Group: Documentation
be381d2c 107%if "%{_rpmversion}" >= "4.6"
0b211bb2
JB
108BuildArch: noarch
109%endif
110
111%description examples
112Examples for Python SQLAlchemy module.
113
114%description examples -l pl.UTF-8
115Przykłady do modułu Pythona SQLAlchemy.
116
666da082 117%prep
aabbbe81 118%setup -q -n SQLAlchemy-%{version}
0b211bb2 119%patch0 -p1
666da082 120
121%build
0f266947 122%if %{with python2}
be381d2c
JB
123%py_build
124
125%if %{with tests}
126%{__python} -m pytest test
127%endif
0f266947 128%endif
0b211bb2 129
0f266947 130%if %{with python3}
be381d2c
JB
131%py3_build
132
133%if %{with tests}
134%{__python3} -m pytest test
135%endif
0f266947 136%endif
666da082 137
138%install
139rm -rf $RPM_BUILD_ROOT
0f266947 140%if %{with python2}
0b211bb2 141%py_install
def14030 142
0f266947
AF
143%py_postclean
144%endif
145
146%if %{with python3}
96131776 147%py3_install
0f266947
AF
148%endif
149
3e5d0494 150install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
0b211bb2 151cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
666da082 152
666da082 153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%files
157%defattr(644,root,root,755)
0b211bb2
JB
158%doc AUTHORS CHANGES LICENSE README.rst
159%dir %{py_sitedir}/sqlalchemy
160%{py_sitedir}/sqlalchemy/connectors
161%{py_sitedir}/sqlalchemy/databases
162%{py_sitedir}/sqlalchemy/dialects
163%{py_sitedir}/sqlalchemy/engine
164%{py_sitedir}/sqlalchemy/event
165%{py_sitedir}/sqlalchemy/ext
166%{py_sitedir}/sqlalchemy/orm
be381d2c 167%{py_sitedir}/sqlalchemy/pool
0b211bb2
JB
168%{py_sitedir}/sqlalchemy/sql
169%{py_sitedir}/sqlalchemy/testing
170%{py_sitedir}/sqlalchemy/util
171%attr(755,root,root) %{py_sitedir}/sqlalchemy/cprocessors.so
172%attr(755,root,root) %{py_sitedir}/sqlalchemy/cresultproxy.so
173%attr(755,root,root) %{py_sitedir}/sqlalchemy/cutils.so
174%{py_sitedir}/sqlalchemy/*.py[co]
aabbbe81 175%{py_sitedir}/SQLAlchemy-%{version}-py*.egg-info
0f266947 176
bcebf730 177%if %{with python3}
0f266947
AF
178%files -n python3-%{module}
179%defattr(644,root,root,755)
0b211bb2
JB
180%doc AUTHORS CHANGES LICENSE README.rst
181%dir %{py3_sitedir}/sqlalchemy
182%{py3_sitedir}/sqlalchemy/connectors
183%{py3_sitedir}/sqlalchemy/databases
184%{py3_sitedir}/sqlalchemy/dialects
185%{py3_sitedir}/sqlalchemy/engine
186%{py3_sitedir}/sqlalchemy/event
187%{py3_sitedir}/sqlalchemy/ext
188%{py3_sitedir}/sqlalchemy/orm
be381d2c 189%{py3_sitedir}/sqlalchemy/pool
0b211bb2
JB
190%{py3_sitedir}/sqlalchemy/sql
191%{py3_sitedir}/sqlalchemy/testing
192%{py3_sitedir}/sqlalchemy/util
193%attr(755,root,root) %{py3_sitedir}/sqlalchemy/cprocessors.cpython-*.so
194%attr(755,root,root) %{py3_sitedir}/sqlalchemy/cresultproxy.cpython-*.so
195%attr(755,root,root) %{py3_sitedir}/sqlalchemy/cutils.cpython-*.so
196%{py3_sitedir}/sqlalchemy/*.py
197%{py3_sitedir}/sqlalchemy/__pycache__
aabbbe81 198%{py3_sitedir}/SQLAlchemy-%{version}-py*.egg-info
bcebf730 199%endif
0b211bb2
JB
200
201%files apidocs
202%defattr(644,root,root,755)
203%doc doc/{_images,_modules,_static,changelog,core,dialects,faq,orm,*.html,*.js}
204
205%files examples
206%defattr(644,root,root,755)
207%{_examplesdir}/%{name}-%{version}
This page took 0.069126 seconds and 4 git commands to generate.