]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blame - python-SQLAlchemy.spec
- release 2 (by relup.sh)
[packages/python-sqlalchemy.git] / python-SQLAlchemy.spec
CommitLineData
0f266947
AF
1# TODO:
2# - examples and docs for python3
a563aeca 3# - builds, but got syntax errors when buildings
0f266947
AF
4#
5%bcond_without python3
6%bcond_without python2
176bba03 7%define module SQLAlchemy
0f266947 8#
666da082 9Summary: Database Abstraction Library
40827375 10Summary(pl.UTF-8): Biblioteka abstrakcji baz danych
1ce1e260 11Name: python-%{module}
b08e6397 12Version: 0.6.8
6f58c771 13Release: 2
666da082 14License: MIT
4fc44ee0 15Group: Libraries/Python
af4c7ed3 16Source0: http://downloads.sourceforge.net/sqlalchemy/%{module}-%{version}.tar.gz
b08e6397 17# Source0-md5: af56550a6eb8b7a8874b02c97407d73c
666da082 18URL: http://www.sqlalchemy.org/
0f266947 19%if %{with python2}
d05dd446 20BuildRequires: python-devel >= 1:2.4
a563aeca 21BuildRequires: python-distribute
666da082 22BuildRequires: python-setuptools >= 0.6-0.a9.1
0f266947
AF
23%endif
24%if %{with python3}
cf2a3598 25BuildRequires: python3-2to3
0f266947 26BuildRequires: python3-devel
cf2a3598 27BuildRequires: python3-modules
0f266947 28%endif
eff90088 29BuildRequires: rpm-pythonprov
bbaffef6 30BuildRequires: rpmbuild(macros) >= 1.219
0f266947 31%if %{with python2}
666da082 32%pyrequires_eq python-modules
0f266947 33%endif
666da082 34BuildArch: noarch
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
bbaffef6
ER
38The Python SQL toolkit and Object Relational Mapper that gives
39application developers the full power and flexibility of SQL.
40SQLAlchemy provides a full suite of well known enterprise-level
41persistence patterns, designed for efficient and high-performing
42database access, adapted into a simple and Pythonic domain language.
666da082 43
0f266947
AF
44Python 2.x version.
45
2aabef56 46%description -l pl.UTF-8
2aea6699
JB
47Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
48dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
49udostępnia pełny zbiór dobrze znanych wzorców trwałości,
50zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
51prostej, pythonowej domeny językowej.
f3fd8b7b 52
0f266947
AF
53Wersja dla pythona 2.x.
54
55%package -n python3-%{module}
56Summary: Database Abstraction Library
57Summary(pl.UTF-8): Biblioteka abstrakcji baz danych
58Group: Libraries/Python
59
60%description -n python3-%{module}
61The Python SQL toolkit and Object Relational Mapper that gives
62application developers the full power and flexibility of SQL.
63SQLAlchemy provides a full suite of well known enterprise-level
64persistence patterns, designed for efficient and high-performing
65database access, adapted into a simple and Pythonic domain language.
66
67Python 3.x version.
68
1ce1e260 69%description -n python3-%{module} -l pl.UTF-8
0f266947
AF
70Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
71dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
72udostępnia pełny zbiór dobrze znanych wzorców trwałości,
73zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
74prostej, pythonowej domeny językowej.
75
76Wersja dla Pythona 3.x.
77
666da082 78%prep
176bba03 79%setup -q -n %{module}-%{version}
666da082 80
81%build
0f266947
AF
82%if %{with python2}
83%{__python} setup.py build -b build-2
84%endif
85%if %{with python3}
86%{__python3} setup.py build -b build-3
87%endif
666da082 88
89%install
90rm -rf $RPM_BUILD_ROOT
0f266947
AF
91%if %{with python2}
92%{__python} setup.py build -b build-2 \
93 install \
666da082 94 --single-version-externally-managed \
95 --optimize=2 \
96 --root=$RPM_BUILD_ROOT
def14030 97
0f266947
AF
98%py_postclean
99%endif
100
101%if %{with python3}
102%{__python3} setup.py build -b build-3 \
103 install \
0f266947
AF
104 --root=$RPM_BUILD_ROOT \
105 --optimize=2
0f266947
AF
106%endif
107
3e5d0494 108install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
109cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
666da082 110
666da082 111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%files
115%defattr(644,root,root,755)
def14030 116%doc CHANGES README* doc/*.html
666da082 117%{py_sitescriptdir}/SQLAlchemy*
118%{py_sitescriptdir}/sqlalchemy*
2aea6699 119%{_examplesdir}/%{name}-%{version}
0f266947 120
bcebf730 121%if %{with python3}
0f266947
AF
122%files -n python3-%{module}
123%defattr(644,root,root,755)
124%{py3_sitescriptdir}/SQLAlchemy*
125%{py3_sitescriptdir}/sqlalchemy*
bcebf730 126%endif
This page took 0.058333 seconds and 4 git commands to generate.