]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blame - python-SQLAlchemy.spec
- 0.6.1
[packages/python-sqlalchemy.git] / python-SQLAlchemy.spec
CommitLineData
0f266947
AF
1# TODO:
2# - examples and docs for python3
3#
4%bcond_without python3
5%bcond_without python2
176bba03 6%define module SQLAlchemy
0f266947 7#
666da082 8Summary: Database Abstraction Library
40827375 9Summary(pl.UTF-8): Biblioteka abstrakcji baz danych
1ce1e260 10Name: python-%{module}
11Version: 0.6.1
12Release: 1
666da082 13License: MIT
4fc44ee0 14Group: Libraries/Python
af4c7ed3 15Source0: http://downloads.sourceforge.net/sqlalchemy/%{module}-%{version}.tar.gz
1ce1e260 16# Source0-md5: 8b25a820a81469b54b05426705108061
666da082 17URL: http://www.sqlalchemy.org/
0f266947 18%if %{with python2}
d05dd446 19BuildRequires: python-devel >= 1:2.4
666da082 20BuildRequires: python-setuptools >= 0.6-0.a9.1
0f266947
AF
21%endif
22%if %{with python3}
cf2a3598 23BuildRequires: python3-2to3
0f266947
AF
24BuildRequires: python3-devel
25BuildRequires: python3-distribute
cf2a3598 26BuildRequires: python3-modules
0f266947 27%endif
eff90088 28BuildRequires: rpm-pythonprov
bbaffef6 29BuildRequires: rpmbuild(macros) >= 1.219
0f266947 30%if %{with python2}
666da082 31%pyrequires_eq python-modules
0f266947 32%endif
666da082 33BuildArch: noarch
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
bbaffef6
ER
37The Python SQL toolkit and Object Relational Mapper that gives
38application developers the full power and flexibility of SQL.
39SQLAlchemy provides a full suite of well known enterprise-level
40persistence patterns, designed for efficient and high-performing
41database access, adapted into a simple and Pythonic domain language.
666da082 42
0f266947
AF
43Python 2.x version.
44
2aabef56 45%description -l pl.UTF-8
2aea6699
JB
46Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
47dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
48udostępnia pełny zbiór dobrze znanych wzorców trwałości,
49zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
50prostej, pythonowej domeny językowej.
f3fd8b7b 51
0f266947
AF
52Wersja dla pythona 2.x.
53
54%package -n python3-%{module}
55Summary: Database Abstraction Library
56Summary(pl.UTF-8): Biblioteka abstrakcji baz danych
57Group: Libraries/Python
58
59%description -n python3-%{module}
60The Python SQL toolkit and Object Relational Mapper that gives
61application developers the full power and flexibility of SQL.
62SQLAlchemy provides a full suite of well known enterprise-level
63persistence patterns, designed for efficient and high-performing
64database access, adapted into a simple and Pythonic domain language.
65
66Python 3.x version.
67
1ce1e260 68%description -n python3-%{module} -l pl.UTF-8
0f266947
AF
69Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
70dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
71udostępnia pełny zbiór dobrze znanych wzorców trwałości,
72zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
73prostej, pythonowej domeny językowej.
74
75Wersja dla Pythona 3.x.
76
666da082 77%prep
176bba03 78%setup -q -n %{module}-%{version}
666da082 79
80%build
0f266947
AF
81%if %{with python2}
82%{__python} setup.py build -b build-2
83%endif
84%if %{with python3}
85%{__python3} setup.py build -b build-3
86%endif
666da082 87
88%install
89rm -rf $RPM_BUILD_ROOT
0f266947
AF
90%if %{with python2}
91%{__python} setup.py build -b build-2 \
92 install \
666da082 93 --single-version-externally-managed \
94 --optimize=2 \
95 --root=$RPM_BUILD_ROOT
def14030 96
0f266947
AF
97%py_postclean
98%endif
99
100%if %{with python3}
101%{__python3} setup.py build -b build-3 \
102 install \
103 --single-version-externally-managed \
104 --root=$RPM_BUILD_ROOT \
105 --optimize=2
106
107%py3_postclean
108%endif
109
3e5d0494 110install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
111cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
666da082 112
666da082 113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%files
117%defattr(644,root,root,755)
def14030 118%doc CHANGES README* doc/*.html
666da082 119%{py_sitescriptdir}/SQLAlchemy*
120%{py_sitescriptdir}/sqlalchemy*
2aea6699 121%{_examplesdir}/%{name}-%{version}
0f266947
AF
122
123%files -n python3-%{module}
124%defattr(644,root,root,755)
125%{py3_sitescriptdir}/SQLAlchemy*
126%{py3_sitescriptdir}/sqlalchemy*
This page took 0.080672 seconds and 4 git commands to generate.