]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blame - python-SQLAlchemy.spec
- BR 2to3
[packages/python-sqlalchemy.git] / python-SQLAlchemy.spec
CommitLineData
0f266947
AF
1# TODO:
2# - examples and docs for python3
3#
4%bcond_without python3
5%bcond_without python2
176bba03 6%define module SQLAlchemy
0f266947 7#
666da082 8Summary: Database Abstraction Library
40827375 9Summary(pl.UTF-8): Biblioteka abstrakcji baz danych
666da082 10Name: python-SQLAlchemy
c7fa20e4 11Version: 0.6.0
f8e5d67d 12Release: 1
666da082 13License: MIT
4fc44ee0 14Group: Libraries/Python
af4c7ed3 15Source0: http://downloads.sourceforge.net/sqlalchemy/%{module}-%{version}.tar.gz
c7fa20e4 16# Source0-md5: 575c2ca742e9ab3c08c384dbc4861f86
666da082 17URL: http://www.sqlalchemy.org/
0f266947 18%if %{with python2}
d05dd446 19BuildRequires: python-devel >= 1:2.4
666da082 20BuildRequires: python-setuptools >= 0.6-0.a9.1
0f266947
AF
21%endif
22%if %{with python3}
23BuildRequires: python3-devel
24BuildRequires: python3-distribute
8a7fe970 25BuildRequires: python3-2to3
0f266947 26%endif
eff90088 27BuildRequires: rpm-pythonprov
bbaffef6 28BuildRequires: rpmbuild(macros) >= 1.219
0f266947 29%if %{with python2}
666da082 30%pyrequires_eq python-modules
0f266947 31%endif
666da082 32BuildArch: noarch
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
bbaffef6
ER
36The Python SQL toolkit and Object Relational Mapper that gives
37application developers the full power and flexibility of SQL.
38SQLAlchemy provides a full suite of well known enterprise-level
39persistence patterns, designed for efficient and high-performing
40database access, adapted into a simple and Pythonic domain language.
666da082 41
0f266947
AF
42Python 2.x version.
43
2aabef56 44%description -l pl.UTF-8
2aea6699
JB
45Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
46dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
47udostępnia pełny zbiór dobrze znanych wzorców trwałości,
48zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
49prostej, pythonowej domeny językowej.
f3fd8b7b 50
0f266947
AF
51Wersja dla pythona 2.x.
52
53%package -n python3-%{module}
54Summary: Database Abstraction Library
55Summary(pl.UTF-8): Biblioteka abstrakcji baz danych
56Group: Libraries/Python
57
58%description -n python3-%{module}
59The Python SQL toolkit and Object Relational Mapper that gives
60application developers the full power and flexibility of SQL.
61SQLAlchemy provides a full suite of well known enterprise-level
62persistence patterns, designed for efficient and high-performing
63database access, adapted into a simple and Pythonic domain language.
64
65Python 3.x version.
66
67%description -l pl.UTF-8 -n python3-%{module}
68Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
69dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
70udostępnia pełny zbiór dobrze znanych wzorców trwałości,
71zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
72prostej, pythonowej domeny językowej.
73
74Wersja dla Pythona 3.x.
75
666da082 76%prep
176bba03 77%setup -q -n %{module}-%{version}
666da082 78
79%build
0f266947
AF
80%if %{with python2}
81%{__python} setup.py build -b build-2
82%endif
83%if %{with python3}
84%{__python3} setup.py build -b build-3
85%endif
666da082 86
87%install
88rm -rf $RPM_BUILD_ROOT
0f266947
AF
89%if %{with python2}
90%{__python} setup.py build -b build-2 \
91 install \
666da082 92 --single-version-externally-managed \
93 --optimize=2 \
94 --root=$RPM_BUILD_ROOT
def14030 95
0f266947
AF
96%py_postclean
97%endif
98
99%if %{with python3}
100%{__python3} setup.py build -b build-3 \
101 install \
102 --single-version-externally-managed \
103 --root=$RPM_BUILD_ROOT \
104 --optimize=2
105
106%py3_postclean
107%endif
108
3e5d0494 109install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
110cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
666da082 111
666da082 112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%files
116%defattr(644,root,root,755)
def14030 117%doc CHANGES README* doc/*.html
666da082 118%{py_sitescriptdir}/SQLAlchemy*
119%{py_sitescriptdir}/sqlalchemy*
2aea6699 120%{_examplesdir}/%{name}-%{version}
0f266947
AF
121
122%files -n python3-%{module}
123%defattr(644,root,root,755)
124%{py3_sitescriptdir}/SQLAlchemy*
125%{py3_sitescriptdir}/sqlalchemy*
This page took 0.113977 seconds and 4 git commands to generate.