]> git.pld-linux.org Git - packages/python-setuptools.git/blame - python-setuptools.spec
- updated to 19.4
[packages/python-setuptools.git] / python-setuptools.spec
CommitLineData
2f649423
MK
1#
2# Conditional build:
c034c756
JB
3%bcond_without apidocs # sphinx based documentation
4%bcond_with tests # "test" action (fails?)
2f649423
MK
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
25fb9ea9
JK
7%bcond_without python3_default # Use Python 3.x for easy_install executable
8
9%if %{without python3}
10%undefine python3_default
11%endif
2f649423 12
cb552c1a 13%define module setuptools
b79e62bc 14Summary: A collection of enhancements to the Python distutils
e4a6c4e2 15Summary(pl.UTF-8): Zestaw rozszerzeń dla pythonowych distutils
b79e62bc 16Name: python-setuptools
dfd639a7
JB
17Version: 19.4
18Release: 1
67093d8e 19Epoch: 1
2f649423 20License: PSF or ZPL
b79e62bc 21Group: Development/Languages/Python
5c02125b 22#Source0Download: https://pypi.python.org/pypi/setuptools
15009e3d 23Source0: https://pypi.python.org/packages/source/s/setuptools/setuptools-%{version}.tar.gz
dfd639a7 24# Source0-md5: c5a7d90c1e0acf8c4ec5c2bf31bc25b5
2f649423 25URL: https://bitbucket.org/pypa/setuptools
c034c756
JB
26%if %(locale -a | grep -q '^en_US.UTF-8$'; echo $?)
27BuildRequires: glibc-localedb-all
28%endif
2f649423 29%if %{with python2}
c034c756 30BuildRequires: python-modules >= 1:2.6
b6cbc91d 31BuildConflicts: python-distribute < 0.7
2f649423
MK
32%endif
33%if %{with python3}
c034c756 34BuildRequires: python3-modules >= 1:3.2
b6cbc91d 35BuildConflicts: python3-distribute < 0.7
2f649423 36%endif
5c02125b 37%if %{with apidocs}
96995d3d
JK
38BuildRequires: python3-rst.linker
39BuildRequires: sphinx-pdg-3
5c02125b 40%endif
c034c756 41BuildRequires: rpm-pythonprov
b6cbc91d 42BuildRequires: rpmbuild(macros) >= 1.710
c034c756 43Requires: python-modules >= 1:2.6
64c5aa5e 44Obsoletes: python-distribute < 0.7
c034c756 45Obsoletes: python-setuptools-devel
b79e62bc
AM
46BuildArch: noarch
47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49%description
50setuptools is a collection of enhancements to the Python distutils
c034c756
JB
51that allow you to more easily build and distribute Python 2.x
52packages, especially ones that have dependencies on other packages.
b79e62bc 53
1c17442b 54%description -l pl.UTF-8
d539774b 55setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
c034c756
JB
56łatwiejsze budowanie i rozprowadzanie pakietów Pythona 2.x,
57szczególnie tych mających zależności od innych pakietów.
d539774b
JB
58
59Ten pakiet zawiera składniki uruchomieniowe setuptools, potrzebne do
c034c756
JB
60uruchamiania kodu wymagającego pkg_resources.py, przeznaczone dla
61Pythona 2.x.
eadb908c 62
2f649423 63%package -n python3-%{module}
c034c756
JB
64Summary: A collection of enhancements to the Python distutils
65Summary(pl.UTF-8): Zestaw rozszerzeń dla pythonowych distutils
2f649423 66Group: Libraries/Python
c034c756 67Requires: python3-modules >= 1:3.2
ff466203 68Obsoletes: python3-distribute < 0.7
2f649423
MK
69
70%description -n python3-%{module}
c034c756
JB
71setuptools is a collection of enhancements to the Python distutils
72that allow you to more easily build and distribute Python 3.x
73packages, especially ones that have dependencies on other packages.
2f649423
MK
74
75%description -n python3-%{module} -l pl.UTF-8
c034c756
JB
76setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
77łatwiejsze budowanie i rozprowadzanie pakietów Pythona 3.x,
78szczególnie tych mających zależności od innych pakietów.
2f649423 79
25fb9ea9
JK
80%package -n easy_install
81Summary: Python software installer
82Summary(pl.UTF-8): Instalator oprogramowania napisanego w Pythonie
83Group: Libraries/Python
84%if %{with python3_default}
85Requires: python3-%{module} = %{epoch}:%{version}-%{release}
86%else
87Requires: python-%{module} = %{epoch}:%{version}-%{release}
88%endif
b6cbc91d 89Conflicts: python-setuptools < 1:18.6.1-2
25fb9ea9
JK
90
91%description -n easy_install
92Python software installer.
93
94%description -n easy_install
95Instalator oprogramowania napisanego w Pythonie.
96
2f649423
MK
97%package apidocs
98Summary: %{module} API documentation
99Summary(pl.UTF-8): Dokumentacja API %{module}
100Group: Documentation
101
102%description apidocs
103API documentation for %{module}.
104
105%description apidocs -l pl.UTF-8
106Dokumentacja API %{module}.
107
b79e62bc 108%prep
2f649423 109%setup -q -n %{module}-%{version}
b79e62bc
AM
110
111%build
2f649423 112%if %{with python2}
c034c756 113LC_ALL=en_US.UTF-8 \
a21b5be7 114%py_build %{?with_tests:test}
2f649423
MK
115%endif
116
117%if %{with python3}
c034c756 118LC_ALL=en_US.UTF-8 \
a21b5be7 119%py3_build %{?with_tests:test}
2f649423 120%endif
b79e62bc 121
c034c756 122%if %{with apidocs}
5c02125b
JB
123#%{__make} -C docs html
124# rst.linker needs sphinx-build to be run from directory containing "CHANGES.txt"
96995d3d 125sphinx-build-3 -b html -d build/doctrees -D latex_paper_size=a4 docs build/html
c034c756
JB
126%endif
127
b79e62bc
AM
128%install
129rm -rf $RPM_BUILD_ROOT
130
c034c756 131%if %{with python3}
a21b5be7 132%py3_install
2f649423 133%endif
991fba2b 134
c034c756 135%if %{with python2}
a21b5be7 136%py_install
c034c756
JB
137
138%py_postclean
2f649423 139%endif
b79e62bc 140
25fb9ea9 141%if %{with python3_default}
b6cbc91d 142ln -sf easy_install-%{py3_ver} $RPM_BUILD_ROOT%{_bindir}/easy_install
25fb9ea9 143%else
b6cbc91d 144ln -sf easy_install-%{py_ver} $RPM_BUILD_ROOT%{_bindir}/easy_install
25fb9ea9
JK
145%endif
146
b79e62bc
AM
147%clean
148rm -rf $RPM_BUILD_ROOT
149
2f649423 150%if %{with python2}
b79e62bc
AM
151%files
152%defattr(644,root,root,755)
54dda11e 153%doc README.txt
25fb9ea9 154%attr(755,root,root) %{_bindir}/easy_install-%{py_ver}
5c02125b
JB
155%{py_sitescriptdir}/pkg_resources
156%{py_sitescriptdir}/setuptools
2f649423
MK
157%{py_sitescriptdir}/_markerlib
158%{py_sitescriptdir}/easy_install.py[co]
2f649423
MK
159%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
160%endif
2f649423
MK
161
162%if %{with python3}
163%files -n python3-%{module}
f4841952 164%defattr(644,root,root,755)
54dda11e 165%doc README.txt
25fb9ea9 166%attr(755,root,root) %{_bindir}/easy_install-%{py3_ver}
c034c756 167%{py3_sitescriptdir}/__pycache__/easy_install.*.py[co]
5c02125b
JB
168%{py3_sitescriptdir}/pkg_resources
169%{py3_sitescriptdir}/setuptools
2f649423
MK
170%{py3_sitescriptdir}/_markerlib
171%{py3_sitescriptdir}/easy_install.py
2f649423
MK
172%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
173%endif
174
25fb9ea9
JK
175%files -n easy_install
176%defattr(644,root,root,755)
177%attr(755,root,root) %{_bindir}/easy_install
178
c034c756 179%if %{with apidocs}
2f649423
MK
180%files apidocs
181%defattr(644,root,root,755)
5c02125b 182%doc build/html/*
2f649423 183%endif
This page took 0.095772 seconds and 4 git commands to generate.