]> git.pld-linux.org Git - packages/python-secretstorage.git/blob - python-secretstorage.spec
- updated to 2.3.1
[packages/python-secretstorage.git] / python-secretstorage.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_with     tests   # unit tests [require dbus and some Secret Service daemon running]
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 Summary:        Python 2 bindings to Freedesktop.org Secret Service API
9 Summary(pl.UTF-8):      Wiązania Pythona 2 do API Secret Service z Freedesktop.org
10 Name:           python-secretstorage
11 Version:        2.3.1
12 Release:        1
13 License:        BSD
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.python.org/simple/secretstorage
16 Source0:        https://pypi.python.org/packages/a5/a5/0830cfe34a4cfd0d1c3c8b614ede1edb2aaf999091ac8548dd19cb352e79/SecretStorage-%{version}.tar.gz
17 # Source0-md5:  3b9465831b069e2622973afb7deb7bc2
18 URL:            https://github.com/mitya57/secretstorage
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.7
21 BuildRequires:  python-setuptools
22 %if %{with tests}
23 BuildRequires:  python-cryptography
24 BuildRequires:  python-dbus
25 %endif
26 %endif
27 %if %{with python3}
28 BuildRequires:  python3-modules >= 1:3.3
29 BuildRequires:  python3-setuptools
30 %if %{with doc}
31 BuildRequires:  python3-Sphinx
32 %endif
33 %if %{with tests}
34 BuildRequires:  python3-cryptography
35 BuildRequires:  python3-dbus
36 %endif
37 %endif
38 BuildRequires:  rpm-pythonprov
39 BuildRequires:  rpmbuild(macros) >= 1.714
40 Requires:       python-modules >= 1:2.7
41 BuildArch:      noarch
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 This module provides a way for securely storing passwords and other
46 secrets.
47
48 It uses D-Bus Secret Service API that is supported by GNOME Keyring
49 (since version 2.30) and KSecretsService.
50
51 %description -l pl.UTF-8
52 Ten moduł udostępnia sposób bezpiecznego przechowywania haseł i innych
53 tajnych danych.
54
55 Wykorzystuje API D-Bus Secret Service, obsługiwane przez GNOME Keyring
56 (od wersji 2.30) oraz KSecretsService.
57
58 %package -n python3-secretstorage
59 Summary:        Python 3 bindings to Freedesktop.org Secret Service API
60 Summary(pl.UTF-8):      Wiązania Pythona 3 do API Secret Service z Freedesktop.org
61 Group:          Libraries/Python
62 Requires:       python3-modules >= 1:3.3
63
64 %description -n python3-secretstorage
65 This module provides a way for securely storing passwords and other
66 secrets.
67
68 It uses D-Bus Secret Service API that is supported by GNOME Keyring
69 (since version 2.30) and KSecretsService.
70
71 %description -n python3-secretstorage -l pl.UTF-8
72 Ten moduł udostępnia sposób bezpiecznego przechowywania haseł i innych
73 tajnych danych.
74
75 Wykorzystuje API D-Bus Secret Service, obsługiwane przez GNOME Keyring
76 (od wersji 2.30) oraz KSecretsService.
77
78 %package apidocs
79 Summary:        secretstorage API documentation
80 Summary(pl.UTF-8):      Dokumentacja API secretstorage
81 Group:          Documentation
82
83 %description apidocs
84 API documentation for secretstorage.
85
86 %description apidocs -l pl.UTF-8
87 Dokumentacja API secretstorage.
88
89 %prep
90 %setup -q -n SecretStorage-%{version}
91
92 %build
93 %if %{with python2}
94 %py_build %{?with_tests:test}
95
96 %if %{with tests}
97 %{__python} -m unittest discover -s tests
98 %endif
99 %endif
100
101 %if %{with python3}
102 %py3_build %{?with_tests:test} %{?with_doc:build_sphinx}
103
104 %if %{with tests}
105 %{__python3} -m unittest discover -s tests
106 %endif
107 %endif
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %if %{with python2}
113 %py_install
114
115 %py_postclean
116 %endif
117
118 %if %{with python3}
119 %py3_install
120 %endif
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %if %{with python2}
126 %files
127 %defattr(644,root,root,755)
128 %doc LICENSE README.rst changelog
129 %{py_sitescriptdir}/secretstorage
130 %{py_sitescriptdir}/SecretStorage-%{version}-py*.egg-info
131 %endif
132
133 %if %{with python3}
134 %files -n python3-secretstorage
135 %defattr(644,root,root,755)
136 %doc LICENSE README.rst changelog
137 %{py3_sitescriptdir}/secretstorage
138 %{py3_sitescriptdir}/SecretStorage-%{version}-py*.egg-info
139 %endif
140
141 %if %{with doc}
142 %files apidocs
143 %defattr(644,root,root,755)
144 %doc build-3/sphinx/html/{_static,*.html,*.js}
145 %endif
This page took 0.087655 seconds and 3 git commands to generate.