]> git.pld-linux.org Git - packages/python-secretstorage.git/blame - python-secretstorage.spec
- release 4 (by relup.sh)
[packages/python-secretstorage.git] / python-secretstorage.spec
CommitLineData
34470ae5
JB
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
4%bcond_with tests # unit tests [require dbus and some Secret Service daemon running]
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8Summary: Python 2 bindings to Freedesktop.org Secret Service API
9Summary(pl.UTF-8): Wiązania Pythona 2 do API Secret Service z Freedesktop.org
10Name: python-secretstorage
2bddc255 11Version: 2.3.1
af9cb24b 12Release: 4
34470ae5
JB
13License: BSD
14Group: Libraries/Python
11be43ee
JB
15#Source0Download: https://pypi.org/simple/secretstorage/
16Source0: https://files.pythonhosted.org/packages/source/S/SecretStorage/SecretStorage-%{version}.tar.gz
2bddc255 17# Source0-md5: 3b9465831b069e2622973afb7deb7bc2
34470ae5 18URL: https://github.com/mitya57/secretstorage
34470ae5
JB
19%if %{with python2}
20BuildRequires: python-modules >= 1:2.7
21BuildRequires: python-setuptools
7aa2864c 22%if %{with tests}
2bddc255
JB
23BuildRequires: python-cryptography
24BuildRequires: python-dbus
7aa2864c 25%endif
34470ae5
JB
26%endif
27%if %{with python3}
2bddc255 28BuildRequires: python3-modules >= 1:3.3
34470ae5
JB
29BuildRequires: python3-setuptools
30%if %{with doc}
31BuildRequires: python3-Sphinx
32%endif
7aa2864c 33%if %{with tests}
2bddc255
JB
34BuildRequires: python3-cryptography
35BuildRequires: python3-dbus
7aa2864c 36%endif
34470ae5 37%endif
2bddc255
JB
38BuildRequires: rpm-pythonprov
39BuildRequires: rpmbuild(macros) >= 1.714
34470ae5
JB
40Requires: python-modules >= 1:2.7
41BuildArch: noarch
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45This module provides a way for securely storing passwords and other
46secrets.
47
48It uses D-Bus Secret Service API that is supported by GNOME Keyring
49(since version 2.30) and KSecretsService.
50
51%description -l pl.UTF-8
52Ten moduł udostępnia sposób bezpiecznego przechowywania haseł i innych
53tajnych danych.
54
55Wykorzystuje API D-Bus Secret Service, obsługiwane przez GNOME Keyring
56(od wersji 2.30) oraz KSecretsService.
57
58%package -n python3-secretstorage
59Summary: Python 3 bindings to Freedesktop.org Secret Service API
60Summary(pl.UTF-8): Wiązania Pythona 3 do API Secret Service z Freedesktop.org
61Group: Libraries/Python
2bddc255 62Requires: python3-modules >= 1:3.3
34470ae5
JB
63
64%description -n python3-secretstorage
65This module provides a way for securely storing passwords and other
66secrets.
67
68It uses D-Bus Secret Service API that is supported by GNOME Keyring
69(since version 2.30) and KSecretsService.
70
71%description -n python3-secretstorage -l pl.UTF-8
72Ten moduł udostępnia sposób bezpiecznego przechowywania haseł i innych
73tajnych danych.
74
75Wykorzystuje API D-Bus Secret Service, obsługiwane przez GNOME Keyring
76(od wersji 2.30) oraz KSecretsService.
77
78%package apidocs
79Summary: secretstorage API documentation
80Summary(pl.UTF-8): Dokumentacja API secretstorage
81Group: Documentation
82
83%description apidocs
84API documentation for secretstorage.
85
86%description apidocs -l pl.UTF-8
87Dokumentacja API secretstorage.
88
89%prep
90%setup -q -n SecretStorage-%{version}
91
92%build
93%if %{with python2}
94%py_build %{?with_tests:test}
95
96%if %{with tests}
97%{__python} -m unittest discover -s tests
98%endif
99%endif
100
101%if %{with python3}
102%py3_build %{?with_tests:test} %{?with_doc:build_sphinx}
103
104%if %{with tests}
105%{__python3} -m unittest discover -s tests
106%endif
107%endif
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112%if %{with python2}
113%py_install
114
115%py_postclean
116%endif
117
118%if %{with python3}
119%py3_install
120%endif
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%if %{with python2}
126%files
127%defattr(644,root,root,755)
128%doc LICENSE README.rst changelog
129%{py_sitescriptdir}/secretstorage
130%{py_sitescriptdir}/SecretStorage-%{version}-py*.egg-info
131%endif
132
133%if %{with python3}
134%files -n python3-secretstorage
135%defattr(644,root,root,755)
136%doc LICENSE README.rst changelog
137%{py3_sitescriptdir}/secretstorage
138%{py3_sitescriptdir}/SecretStorage-%{version}-py*.egg-info
139%endif
140
141%if %{with doc}
142%files apidocs
143%defattr(644,root,root,755)
2bddc255 144%doc build-3/sphinx/html/{_static,*.html,*.js}
34470ae5 145%endif
This page took 0.136304 seconds and 4 git commands to generate.