]> git.pld-linux.org Git - packages/python-secretstorage.git/blame - python-secretstorage.spec
- tests require python*-discover
[packages/python-secretstorage.git] / python-secretstorage.spec
CommitLineData
34470ae5
JB
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
4%bcond_with tests # unit tests [require dbus and some Secret Service daemon running]
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8Summary: Python 2 bindings to Freedesktop.org Secret Service API
9Summary(pl.UTF-8): Wiązania Pythona 2 do API Secret Service z Freedesktop.org
10Name: python-secretstorage
11Version: 2.1.4
12Release: 1
13License: BSD
14Group: Libraries/Python
15#Source0Download: https://pypi.python.org/simple/secretstorage
16Source0: https://pypi.python.org/packages/c9/b0/833d13a07319ff9b9815d1683c5ece719f6e467b8217c1c6a42bc37a3aa9/SecretStorage-%{version}.tar.gz
17# Source0-md5: 80ca4a4a0614daf45ee3d0fb17eb41cd
18URL: https://github.com/mitya57/secretstorage
19BuildRequires: rpm-pythonprov
20# for the py_build, py_install macros
21BuildRequires: rpmbuild(macros) >= 1.714
22%if %{with python2}
23BuildRequires: python-modules >= 1:2.7
24BuildRequires: python-setuptools
7aa2864c
JB
25%if %{with tests}
26BuildRequires: python-discover
27%endif
34470ae5
JB
28%endif
29%if %{with python3}
30BuildRequires: python3-modules >= 1:3.2
31BuildRequires: python3-setuptools
32%if %{with doc}
33BuildRequires: python3-Sphinx
34%endif
7aa2864c
JB
35%if %{with tests}
36BuildRequires: python3-discover
37%endif
34470ae5
JB
38%endif
39Requires: python-modules >= 1:2.7
40BuildArch: noarch
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
44This module provides a way for securely storing passwords and other
45secrets.
46
47It uses D-Bus Secret Service API that is supported by GNOME Keyring
48(since version 2.30) and KSecretsService.
49
50%description -l pl.UTF-8
51Ten moduł udostępnia sposób bezpiecznego przechowywania haseł i innych
52tajnych danych.
53
54Wykorzystuje API D-Bus Secret Service, obsługiwane przez GNOME Keyring
55(od wersji 2.30) oraz KSecretsService.
56
57%package -n python3-secretstorage
58Summary: Python 3 bindings to Freedesktop.org Secret Service API
59Summary(pl.UTF-8): Wiązania Pythona 3 do API Secret Service z Freedesktop.org
60Group: Libraries/Python
61Requires: python3-modules >= 1:3.2
62
63%description -n python3-secretstorage
64This module provides a way for securely storing passwords and other
65secrets.
66
67It uses D-Bus Secret Service API that is supported by GNOME Keyring
68(since version 2.30) and KSecretsService.
69
70%description -n python3-secretstorage -l pl.UTF-8
71Ten moduł udostępnia sposób bezpiecznego przechowywania haseł i innych
72tajnych danych.
73
74Wykorzystuje API D-Bus Secret Service, obsługiwane przez GNOME Keyring
75(od wersji 2.30) oraz KSecretsService.
76
77%package apidocs
78Summary: secretstorage API documentation
79Summary(pl.UTF-8): Dokumentacja API secretstorage
80Group: Documentation
81
82%description apidocs
83API documentation for secretstorage.
84
85%description apidocs -l pl.UTF-8
86Dokumentacja API secretstorage.
87
88%prep
89%setup -q -n SecretStorage-%{version}
90
91%build
92%if %{with python2}
93%py_build %{?with_tests:test}
94
95%if %{with tests}
96%{__python} -m unittest discover -s tests
97%endif
98%endif
99
100%if %{with python3}
101%py3_build %{?with_tests:test} %{?with_doc:build_sphinx}
102
103%if %{with tests}
104%{__python3} -m unittest discover -s tests
105%endif
106%endif
107
108%install
109rm -rf $RPM_BUILD_ROOT
110
111%if %{with python2}
112%py_install
113
114%py_postclean
115%endif
116
117%if %{with python3}
118%py3_install
119%endif
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%if %{with python2}
125%files
126%defattr(644,root,root,755)
127%doc LICENSE README.rst changelog
128%{py_sitescriptdir}/secretstorage
129%{py_sitescriptdir}/SecretStorage-%{version}-py*.egg-info
130%endif
131
132%if %{with python3}
133%files -n python3-secretstorage
134%defattr(644,root,root,755)
135%doc LICENSE README.rst changelog
136%{py3_sitescriptdir}/secretstorage
137%{py3_sitescriptdir}/SecretStorage-%{version}-py*.egg-info
138%endif
139
140%if %{with doc}
141%files apidocs
142%defattr(644,root,root,755)
143%doc build-3/sphinx/html/{_modules,_static,*.html,*.js}
144%endif
This page took 0.085059 seconds and 4 git commands to generate.