]> git.pld-linux.org Git - packages/python-scikit-umfpack.git/blobdiff - python-scikit-umfpack.spec
Release 5 (by relup.sh)
[packages/python-scikit-umfpack.git] / python-scikit-umfpack.spec
index 5f40459d1aa7a2b9f40b30dbad1d303a89770ee1..9a0a65557cc8bafad461ee6d62f443f69541c706 100644 (file)
@@ -2,13 +2,13 @@
 # Conditional build:
 %bcond_without tests   # unit tests
 %bcond_without python2 # CPython 2.x module
-%bcond_without python3 # CPython 3.x module
+%bcond_with    python3 # CPython 3.x module
 
 Summary:       Wrapper of UMFPACK sparse direct solver to SciPy
 Summary(pl.UTF-8):     Obudowanie procedur UMFPACK do rozwiązywania problemów na macierzach rzadkich dla SciPy
 Name:          python-scikit-umfpack
 Version:       0.3.2
-Release:       1
+Release:       5
 License:       BSD
 Group:         Libraries/Python
 #Source0Download: https://pypi.org/simple/scikit-umfpack/
@@ -18,6 +18,7 @@ URL:          https://pypi.org/project/scikit-umfpack/
 BuildRequires: AMD-devel
 BuildRequires: UMFPACK-devel
 BuildRequires: blas-devel
+BuildRequires: cblas-devel
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
 BuildRequires: swig-python >= 2.0.4
@@ -26,6 +27,7 @@ BuildRequires:        python-devel >= 1:2.5
 BuildRequires: python-numpy-devel
 BuildRequires: python-setuptools
 %if %{with tests}
+BuildRequires: python-nose
 BuildRequires: python-scipy >= 1.0.0
 %endif
 %endif
@@ -34,6 +36,7 @@ BuildRequires:        python3-devel >= 1:3.2
 BuildRequires: python3-numpy-devel
 BuildRequires: python3-setuptools
 %if %{with tests}
+BuildRequires: python3-nose
 BuildRequires: python3-scipy >= 1.0.0
 %endif
 %endif
@@ -68,21 +71,23 @@ problemów na macierzach rzadkich dla SciPy.
 %build
 export BLAS=%{_libdir}
 export UMFPACK=%{_libdir}
+export CFLAGS="%{rpmcflags} -I/usr/include/umfpack"
 
 %if %{with python2}
-%py_build %{?with_tests:test}
+%py_build
 
 %if %{with tests}
-PYTHONPATH=$(readlink -f build-2/lib.*) \
+PYTHONPATH=$(readlink -f build-2/lib.*)/scikits/umfpack \
 nosetests-%{py_ver} scikits
 %endif
+find scikits -name '*.pyc' -exec rm -f {} \;
 %endif
 
 %if %{with python3}
-%py3_build %{?with_tests:test}
+%py3_build
 
 %if %{with tests}
-PYTHONPATH=$(readlink -f build-3/lib.*) \
+PYTHONPATH=$(readlink -f build-3/lib.*)/scikits/umfpack \
 nosetests-%{py3_ver} scikits
 %endif
 %endif
@@ -90,6 +95,9 @@ nosetests-%{py3_ver} scikits
 %install
 rm -rf $RPM_BUILD_ROOT
 
+export BLAS=%{_libdir}
+export UMFPACK=%{_libdir}
+
 %if %{with python2}
 %py_install
 # ensure scikits/__init__.py is compiled
This page took 0.108459 seconds and 4 git commands to generate.