]> git.pld-linux.org Git - packages/python-ruamel.yaml.git/blame - python-ruamel.yaml.spec
not noarch; rel 3
[packages/python-ruamel.yaml.git] / python-ruamel.yaml.spec
CommitLineData
1b5f8cc0
JP
1# Conditional build:
2%bcond_with tests # unit tests
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module ruamel.yaml
7Summary: YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style and map key order
8Name: python-%{module}
9Version: 0.16.6
59ffb74c 10Release: 3
1b5f8cc0
JP
11License: MIT
12Group: Libraries/Python
13#Source0Download: https://pypi.org/simple/ruamel.yaml/
14Source0: https://files.pythonhosted.org/packages/source/r/ruamel.yaml/%{module}-%{version}.tar.gz
15# Source0-md5: 6a0b7fe48578cf8e4a77d788ac4fe58b
16URL: https://pypi.org/project/ruamel.yaml/
17BuildRequires: rpm-pythonprov
18BuildRequires: rpmbuild(macros) >= 1.714
19%if %{with python2}
20BuildRequires: python-modules
21BuildRequires: python-setuptools
22%endif
23%if %{with python3}
24BuildRequires: python3-modules
25BuildRequires: python3-setuptools
26%endif
27Requires: python-modules
1b5f8cc0
JP
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31YAML parser/emitter that supports roundtrip preservation of comments,
32seq/map flow style and map key order.
33
34%package -n python3-%{module}
35Summary: YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style and map key order
36Group: Libraries/Python
37Requires: python3-modules
38
39%description -n python3-%{module}
40YAML parser/emitter that supports roundtrip preservation of comments,
41seq/map flow style and map key order.
42
43%prep
44%setup -q -n %{module}-%{version}
45
46%build
47%if %{with python2}
48%py_build %{?with_tests:test}
49%endif
50
51%if %{with python3}
52%py3_build %{?with_tests:test}
53%endif
54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58%if %{with python2}
d3e485aa
JP
59install -d $RPM_BUILD_ROOT%{py_sitedir}/ruamel/yaml
60
1b5f8cc0
JP
61%py_install
62
63%py_postclean
64%endif
65
66%if %{with python3}
d3e485aa
JP
67install -d $RPM_BUILD_ROOT%{py3_sitedir}/ruamel/yaml
68
1b5f8cc0
JP
69%py3_install
70%endif
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%if %{with python2}
76%files
77%defattr(644,root,root,755)
78%doc CHANGES README.rst
d3e485aa 79%{py_sitescriptdir}/ruamel/yaml
1b5f8cc0
JP
80%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
81%{py_sitescriptdir}/%{module}-%{version}-py*-nspkg.pth
d3e485aa 82%dir %{py_sitedir}/ruamel/yaml
1b5f8cc0
JP
83%endif
84
85%if %{with python3}
86%files -n python3-%{module}
87%defattr(644,root,root,755)
88%doc CHANGES README.rst
d3e485aa 89%{py3_sitescriptdir}/ruamel/yaml
1b5f8cc0
JP
90%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
91%{py3_sitescriptdir}/%{module}-%{version}-py*-nspkg.pth
d3e485aa 92%dir %{py3_sitedir}/ruamel/yaml
1b5f8cc0 93%endif
This page took 0.085067 seconds and 4 git commands to generate.