]> git.pld-linux.org Git - packages/python-requests.git/blobdiff - python-requests.spec
- updated to 2.11.1
[packages/python-requests.git] / python-requests.spec
index 1ffd4dc91310cb1e6c131fd5fb23353df2402032..57cd3ddbc7592ae926f437f939fffe58651ba648 100644 (file)
@@ -1,20 +1,21 @@
 #
 # Conditional build:
-%bcond_without tests   # do not perform "make test"
+%bcond_with    tests   # perform "make test"
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
-%bcond_without bundled # Bundle Libraries
+%bcond_without bundled # bundled libraries
 #
+%define                urllib3ver      1.13
 %define        module  requests
 Summary:       HTTP library for Python 2
 Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona 2
 Name:          python-%{module}
-Version:       2.5.0
+Version:       2.11.1
 Release:       1
 License:       Apache2
 Group:         Development/Languages/Python
-Source0:       https://pypi.python.org/packages/source/r/requests/%{module}-%{version}.tar.gz
-# Source0-md5: b8bf3ddca75e7ecf1b6776da1e6e3385
+Source0:       https://pypi.python.org/packages/2e/ad/e627446492cc374c284e82381215dcd9a0a87c4f6e90e9789afefe6da0ad/%{module}-%{version}.tar.gz
+# Source0-md5: ad5f9c47b5c5dfdb28363ad7546b0763
 URL:           http://python-requests.org
 # find . -name '*.py' -exec sed -i -e 's#requests\.packages\.urllib3#urllib3#g' "{}" ";"
 # find . -name '*.py' -exec sed -i -e 's#\.packages\.urllib3#urllib3#g' "{}" ";"
@@ -22,30 +23,29 @@ URL:                http://python-requests.org
 # + manual removal from setup.py
 Patch0:                system-charade-and-urllib3.patch
 Patch1:                system-cert.patch
-Patch2:                requests-test.patch
 %if %{with python2}
 BuildRequires: python-modules >= 1:2.6
 %if %{without bundled}
 BuildRequires: python-charade
-BuildRequires: python-urllib3 >= 1.9.1
+BuildRequires: python-urllib3 >= %{urllib3ver}
 %endif
-%{?with_tests:BuildRequires:   python-pytest}
+%{?with_tests:BuildRequires:   python-pytest >= 2.3.4}
 %endif
 %if %{with python3}
 BuildRequires: python3-modules >= 1:3.2
 %if %{without bundled}
 BuildRequires: python3-charade
-BuildRequires: python3-urllib3 >= 1.9.1
+BuildRequires: python3-urllib3 >= %{urllib3ver}
 %endif
-%{?with_tests:BuildRequires:   python3-pytest}
+%{?with_tests:BuildRequires:   python3-pytest >= 2.3.4}
 %endif
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: rpmbuild(macros) >= 1.713
 Requires:      ca-certificates
 Requires:      python-modules >= 1:2.6
 %if %{without bundled}
 Requires:      python-charade
-Requires:      python-urllib3 >= 1.9.1
+Requires:      python-urllib3 >= %{urllib3ver}
 %endif
 # for python2 only to get SNI working. python3 doesn't need this
 Requires:      python-ndg-httpsclient
@@ -85,7 +85,7 @@ Requires:     ca-certificates
 Requires:      python3-modules >= 1:3.2
 %if %{without bundled}
 Requires:      python3-charade
-Requires:      python3-urllib3 >= 1.9.1
+Requires:      python3-urllib3 >= %{urllib3ver}
 %endif
 
 %description -n python3-requests
@@ -115,45 +115,34 @@ Ten pakiet zawiera moduĊ‚ dla Pythona 3.x.
 %setup -q -n %{module}-%{version}
 %{!?with_bundled:%patch0 -p1}
 %patch1 -p1
-%patch2 -p1
 
 %build
 %if %{with python2}
-%{__python} setup.py build -b py2 %{?with_tests:test}
-%{?with_tests:cp requirements.txt test_requests.py py2; cd py2; PYTHONPATH=$(pwd)/lib %{__python} test_requests.py; cd ..}
+%py_build %{?with_tests:test}
+%{?with_tests:cp requirements.txt test_requests.py build-2; cd build-2; PYTHONPATH=$(pwd)/lib %{__python} test_requests.py; cd ..}
 %endif
 
 %if %{with python3}
-%{__python3} setup.py build -b py3 %{?with_tests:test}
-%{?with_tests:cp requirements.txt test_requests.py py3; cd py3; PYTHONPATH=$(pwd)/lib %{__python3} test_requests.py; cd ..}
+%py3_build %{?with_tests:test}
+%{?with_tests:cp requirements.txt test_requests.py build-3; cd build-3; PYTHONPATH=$(pwd)/lib %{__python3} test_requests.py; cd ..}
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
-%{__python} setup.py \
-       build -b py2 \
-       install \
-       --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
 %py_postclean
 %endif
 
 %if %{with python3}
-%{__python3} setup.py  \
-       build -b py3 \
-       install \
-       --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 %endif
 
-%{__rm} -rf $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/cacert.pem
-%{!?with_bundled:%{__rm} -rf $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/packages}
+%{__rm} $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/cacert.pem
+%{!?with_bundled:%{__rm} -r $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/packages}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.033814 seconds and 4 git commands to generate.