]> git.pld-linux.org Git - packages/python-requests.git/blobdiff - python-requests.spec
- urllib 1.13
[packages/python-requests.git] / python-requests.spec
index 732936ad4ccfa799860bf7eb8bc733350f918d1b..4811453565b18959219f837f2960aa7aea0ebda4 100644 (file)
@@ -5,17 +5,17 @@
 %bcond_without python3 # CPython 3.x module
 %bcond_without bundled # bundled libraries
 #
-%define                urllib3ver      1.10.4
+%define                urllib3ver      1.13
 %define        module  requests
 Summary:       HTTP library for Python 2
 Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona 2
 Name:          python-%{module}
-Version:       2.7.0
+Version:       2.9.1
 Release:       1
 License:       Apache2
 Group:         Development/Languages/Python
 Source0:       https://pypi.python.org/packages/source/r/requests/%{module}-%{version}.tar.gz
-# Source0-md5: 29b173fd5fa572ec0764d1fd7b527260
+# Source0-md5: 0b7f480d19012ec52bab78292efd976d
 URL:           http://python-requests.org
 # find . -name '*.py' -exec sed -i -e 's#requests\.packages\.urllib3#urllib3#g' "{}" ";"
 # find . -name '*.py' -exec sed -i -e 's#\.packages\.urllib3#urllib3#g' "{}" ";"
@@ -40,7 +40,7 @@ BuildRequires:        python3-urllib3 >= %{urllib3ver}
 %{?with_tests:BuildRequires:   python3-pytest >= 2.3.4}
 %endif
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: rpmbuild(macros) >= 1.713
 Requires:      ca-certificates
 Requires:      python-modules >= 1:2.6
 %if %{without bundled}
@@ -118,37 +118,27 @@ Ten pakiet zawiera moduĊ‚ dla Pythona 3.x.
 
 %build
 %if %{with python2}
-%{__python} setup.py build -b py2 %{?with_tests:test}
-%{?with_tests:cp requirements.txt test_requests.py py2; cd py2; PYTHONPATH=$(pwd)/lib %{__python} test_requests.py; cd ..}
+%py_build %{?with_tests:test}
+%{?with_tests:cp requirements.txt test_requests.py build-2; cd build-2; PYTHONPATH=$(pwd)/lib %{__python} test_requests.py; cd ..}
 %endif
 
 %if %{with python3}
-%{__python3} setup.py build -b py3 %{?with_tests:test}
-%{?with_tests:cp requirements.txt test_requests.py py3; cd py3; PYTHONPATH=$(pwd)/lib %{__python3} test_requests.py; cd ..}
+%py3_build %{?with_tests:test}
+%{?with_tests:cp requirements.txt test_requests.py build-3; cd build-3; PYTHONPATH=$(pwd)/lib %{__python3} test_requests.py; cd ..}
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
-%{__python} setup.py \
-       build -b py2 \
-       install \
-       --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
 %py_postclean
 %endif
 
 %if %{with python3}
-%{__python3} setup.py  \
-       build -b py3 \
-       install \
-       --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 %endif
 
 %{__rm} $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/cacert.pem
This page took 0.080518 seconds and 4 git commands to generate.