]> git.pld-linux.org Git - packages/python-pytest.git/commitdiff
- updated to 3.10.1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 28 Nov 2018 20:12:15 +0000 (21:12 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 28 Nov 2018 20:12:15 +0000 (21:12 +0100)
python-pytest.spec

index 44e90e2df0404d497f1db403ba660c1847df48a6..3cba781ac9dbd9d1988e637667ad21963aff6f71 100644 (file)
 Summary:       Simple and popular testing tool for Python
 Summary(pl.UTF-8):     Proste i popularne narzędzie testujące dla Pythona
 Name:          python-%{module}
-Version:       3.6.3
-Release:       2
+Version:       3.10.1
+Release:       1
 License:       MIT
 Group:         Development/Languages/Python
 #Source0Download: https://pypi.org/simple/pytest/
 Source0:       https://files.pythonhosted.org/packages/source/p/pytest/pytest-%{version}.tar.gz
-# Source0-md5: 8ca6124a3a80f9555c50f5c09056ea02
+# Source0-md5: 9afbcf5a86d4fea46024eb65994e7e69
 Patch0:                %{name}-tests.patch
 URL:           http://pytest.org/
 %if %{with python2}
 BuildRequires: python-devel >= 1:2.7
 BuildRequires: python-modules >= 1:2.7
 BuildRequires: python-py >= %{pylib_version}
-BuildRequires: python-setuptools >= 7.0
+BuildRequires: python-setuptools >= 40.0
 BuildRequires: python-setuptools_scm
 %if %{with tests}
 BuildRequires: pydoc >= 1:2.7
@@ -32,9 +32,10 @@ BuildRequires:       python-attrs >= 17.4.0
 BuildRequires: python-funcsigs
 BuildRequires: python-hypothesis >= 3.56
 BuildRequires: python-mock
-BuildRequires: python-more_itertools
+BuildRequires: python-more_itertools >= 4.0.0
 BuildRequires: python-nose
-BuildRequires: python-pluggy >= 0.5
+BuildRequires: python-pathlib2 >= 2.2.0
+BuildRequires: python-pluggy >= 0.7
 BuildRequires: python-requests
 BuildRequires: python-six >= 1.10.0
 BuildConflicts:        python-backports.unittest_mock
@@ -47,16 +48,19 @@ BuildConflicts:     python-pytest-xdist
 BuildRequires: python3-devel >= 1:3.4
 BuildRequires: python3-modules >= 1:3.4
 BuildRequires: python3-py >= %{pylib_version}
-BuildRequires: python3-setuptools >= 7.0
+BuildRequires: python3-setuptools >= 40.0
 BuildRequires: python3-setuptools_scm
 %if %{with tests}
 BuildRequires: pydoc3 >= 1:3.4
 BuildRequires: python3-atomicwrites >= 1.0
 BuildRequires: python3-attrs >= 17.4.0
 BuildRequires: python3-hypothesis >= 3.56
-BuildRequires: python3-more_itertools
+BuildRequires: python3-more_itertools >= 4.0.0
 BuildRequires: python3-nose
-BuildRequires: python3-pluggy >= 0.5
+%if "%{py3_ver}" < "3.6"
+BuildRequires: python3-pathlib2 >= 2.2.0
+%endif
+BuildRequires: python3-pluggy >= 0.7
 BuildRequires: python3-requests
 BuildRequires: python3-six >= 1.10.0
 BuildConflicts:        python3-pytest-catchlog
@@ -119,8 +123,9 @@ Dokumentacja pakietu Pythona py.test.
 %py_build
 
 %if %{with tests}
+# test_pdb_custom_cls_with_settrace fails without preinstalled pytest
 PYTHONPATH=$(pwd)/src \
-%{__python} -m pytest testing
+%{__python} -m pytest -k 'not test_pdb and not TestTerminal' testing
 %endif
 %endif
 
@@ -128,8 +133,10 @@ PYTHONPATH=$(pwd)/src \
 %py3_build
 
 %if %{with tests}
+# test_pdb_custom_cls_with_settrace fails without preinstalled pytest
+# test_pdb_* which spawn pdb hang under some unclear conditions
 PYTHONPATH=$(pwd)/src \
-%{__python3} -m pytest testing
+%{__python3} -m pytest -v -k 'not test_pdb and not TestTerminal' testing
 %endif
 %endif
 
@@ -149,9 +156,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %{__mv} $RPM_BUILD_ROOT%{_bindir}/py.test{,-3}
 %{__mv} $RPM_BUILD_ROOT%{_bindir}/pytest{,-3}
-
-# avoid python3egg(funcsigs) dependency
-%{__sed} -i -e '/^\[:python_version *< *"3\.0"]/,/^$/ d' $RPM_BUILD_ROOT%{py3_sitescriptdir}/pytest-%{version}-py*.egg-info/requires.txt
 %endif
 
 %if %{with python2}
This page took 0.077935 seconds and 4 git commands to generate.