]> git.pld-linux.org Git - packages/python-pytest.git/blame - python-pytest.spec
- updated to 2.9.1
[packages/python-pytest.git] / python-pytest.spec
CommitLineData
bd571570
JB
1#
2# Conditional build:
3%bcond_without doc # HTML documentation build
e4983238
ER
4%bcond_without python3 # CPython 3.x module
5
8246eb60 6%define pylib_version 1.4.29
e4983238 7%define module pytest
bd571570
JB
8Summary: Simple and popular testing tool for Python
9Summary(pl.UTF-8): Proste i popularne narzędzie testujące dla Pythona
e4983238 10Name: python-%{module}
c6451484 11Version: 2.9.1
d939c52a 12Release: 1
bd571570
JB
13License: MIT
14Group: Development/Languages/Python
93a87154 15#Source0Download: https://pypi.python.org/pypi/pytest
7cf8827c 16Source0: https://pypi.python.org/packages/source/p/pytest/pytest-%{version}.tar.gz
c6451484 17# Source0-md5: 05165740ea50928e4e971378630163ec
bd571570 18URL: http://pytest.org/
93a87154 19BuildRequires: python-devel >= 1:2.6
e4983238 20BuildRequires: python-py >= %{pylib_version}
2f6fd582 21BuildRequires: python-setuptools >= 7.0
bd571570 22BuildRequires: rpm-pythonprov
2543e8f9 23BuildRequires: rpmbuild(macros) >= 1.710
e4983238 24BuildRequires: sed >= 4.0
bd571570 25%if %{with doc}
bd571570
JB
26BuildRequires: sphinx-pdg >= 1.0
27%endif
e4983238 28%if %{with python3}
93a87154
JB
29BuildRequires: python3-devel >= 1:3.3
30BuildRequires: python3-modules >= 1:3.3
e4983238 31BuildRequires: python3-py >= %{pylib_version}
2f6fd582 32BuildRequires: python3-setuptools >= 7.0
e4983238
ER
33%endif
34Requires: python-py >= %{pylib_version}
bd571570
JB
35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39py.test is a simple and popular testing tool for Python.
40
41%description -l pl.UTF-8
42py.test to proste i popularne narzędzie testujące dla Pythona.
43
e4983238
ER
44%package -n python3-pytest
45Summary: Simple powerful testing with Python
6b847094 46Summary(pl.UTF-8): Proste, ale funkcjonalne narzędzie testujące dla Pythona
e4983238
ER
47Group: Development/Languages
48Requires: python3-py >= %{pylib_version}
6b847094 49Suggests: python3-setuptools
e4983238
ER
50
51%description -n python3-pytest
52py.test provides simple, yet powerful testing for Python.
53
6b847094
JB
54%description -n python3-pytest -l pl.UTF-8
55py.test to proste, ale bardzo funkcjonalne narzędzie testujące dla
56Pythona.
57
bd571570 58%prep
e4983238
ER
59%setup -q -n %{module}-%{version}
60
bd571570 61%build
ac22139b 62%py_build
bd571570 63
e4983238 64%if %{with python3}
ac22139b 65%py3_build
e4983238
ER
66%endif
67
bd571570 68%if %{with doc}
e4983238
ER
69install -d _htmldocs/html
70for l in doc/*; do
71 PYTHONPATH=$(pwd) \
72 %{__make} -C $l html
73 # remove hidden file
74 rm $l/_build/html/.buildinfo
75 mv $l/_build/html _htmldocs/html/${l##doc/}
76done
bd571570
JB
77%endif
78
79%install
80rm -rf $RPM_BUILD_ROOT
ac22139b
JK
81
82%if %{with python3}
83%py3_install
84%endif
85
86%py_install
bd571570
JB
87
88%py_postclean
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%files
94%defattr(644,root,root,755)
c6451484 95%doc AUTHORS CHANGELOG.rst LICENSE README.rst %{?with_doc:_htmldocs/html}
bd571570
JB
96%attr(755,root,root) %{_bindir}/py.test
97%attr(755,root,root) %{_bindir}/py.test-%{py_ver}
98%{py_sitescriptdir}/pytest.py[co]
99%{py_sitescriptdir}/_pytest
100%{py_sitescriptdir}/pytest-%{version}-py*.egg-info
e4983238
ER
101
102%if %{with python3}
103%files -n python3-pytest
104%defattr(644,root,root,755)
c6451484 105%doc AUTHORS CHANGELOG.rst LICENSE README.rst %{?with_doc:_htmldocs/html}
e4983238 106%attr(755,root,root) %{_bindir}/py.test-%{py3_ver}
6b847094 107%{py3_sitescriptdir}/pytest.py
e4983238 108%{py3_sitescriptdir}/_pytest
6b847094 109%{py3_sitescriptdir}/__pycache__/pytest.*.py[co]
e4983238
ER
110%{py3_sitescriptdir}/pytest-%{version}-py*.egg-info
111%endif
This page took 0.038366 seconds and 4 git commands to generate.