]> git.pld-linux.org Git - packages/python-pytest-timeout.git/commitdiff
rebuild with tests and docs master auto/th/python-pytest-timeout-1.4.2-5
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 30 Mar 2022 12:08:26 +0000 (14:08 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 30 Mar 2022 12:08:26 +0000 (14:08 +0200)
Release 5 (by relup.sh)

python-pytest-timeout.spec

index 1ebd58e30157aa5e5e3328470e96ff6b820399bf..6fa1cc9d0333101e196feb849f87b2ee438a6de6 100644 (file)
@@ -1,6 +1,6 @@
 #
 # Conditional build:
-%bcond_without tests   # py.test tests
+%bcond_with    tests   # py.test tests [use ptys, so not on builders]
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
@@ -8,32 +8,34 @@
 Summary:       py.test plugin to abort hanging tests
 Summary(pl.UTF-8):     Wtyczka py.test do przerywania zawieszonych testów
 Name:          python-%{module}
-Version:       1.2.0
-Release:       1
+# keep 1.x here for python2/pytest<5 support
+Version:       1.4.2
+Release:       5
 License:       MIT
 Group:         Libraries/Python
-Source0:       https://pypi.python.org/packages/cc/b7/b2a61365ea6b6d2e8881360ae7ed8dad0327ad2df89f2f0be4a02304deb2/pytest-timeout-%{version}.tar.gz
-# Source0-md5: 83607d91aa163562c7ee835da57d061d
-URL:           http://bitbucket.org/pytest-dev/pytest-timeout/
+#Source0Download: https://pypi.org/simple/pytest-timeout/
+Source0:       https://files.pythonhosted.org/packages/source/p/pytest-timeout/pytest-timeout-%{version}.tar.gz
+# Source0-md5: 552cc293447b00f7a294ce7a1fb3839f
+URL:           https://github.com/pytest-dev/pytest-timeout
 %if %{with python2}
-BuildRequires: python-modules >= 1:2.6
+BuildRequires: python-modules >= 1:2.7
 BuildRequires: python-setuptools
 %if %{with tests}
 BuildRequires: python-pexpect
-BuildRequires: python-pytest >= 2.8.0
+BuildRequires: python-pytest >= 3.6.0
 %endif
 %endif
 %if %{with python3}
-BuildRequires: python3-modules >= 1:3.3
+BuildRequires: python3-modules >= 1:3.5
 BuildRequires: python3-setuptools
 %if %{with tests}
 BuildRequires: python3-pexpect
-BuildRequires: python3-pytest >= 2.8.0
+BuildRequires: python3-pytest >= 3.6.0
 %endif
 %endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
-Requires:      python-modules >= 1:2.6
+Requires:      python-modules >= 1:2.7
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -53,7 +55,7 @@ integracji lub jeśli nie wiemy, dlaczego testy się zawieszają.
 Summary:       py.test plugin to abort hanging tests
 Summary(pl.UTF-8):     Wtyczka py.test do przerywania zawieszonych testów
 Group:         Libraries/Python
-Requires:      python3-modules >= 1:3.3
+Requires:      python3-modules >= 1:3.5
 
 %description -n python3-%{module}
 This is a plugin which will terminate tests after a certain timeout.
@@ -74,13 +76,19 @@ integracji lub jeśli nie wiemy, dlaczego testy się zawieszają.
 %if %{with python2}
 %py_build
 
-%{?with_tests:PYTHONPATH=$(pwd) %{__python} -m pytest}
+%if %{with tests}
+PYTHONPATH=$(pwd) \
+%{__python} -m pytest
+%endif
 %endif
 
 %if %{with python3}
 %py3_build
 
-%{?with_tests:PYTHONPATH=$(pwd) %{__python3} -m pytest}
+%if %{with tests}
+PYTHONPATH=$(pwd) \
+%{__python3} -m pytest
+%endif
 %endif
 
 %install
@@ -88,6 +96,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
 %py_install
+
 %py_postclean
 %endif
 
@@ -101,7 +110,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc LICENSE README
+%doc LICENSE README.rst
 %{py_sitescriptdir}/pytest_timeout.py[co]
 %{py_sitescriptdir}/pytest_timeout-%{version}-py*.egg-info
 %endif
@@ -109,7 +118,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc LICENSE README
+%doc LICENSE README.rst
 %{py3_sitescriptdir}/pytest_timeout.py
 %{py3_sitescriptdir}/__pycache__/pytest_timeout.cpython-*.py[co]
 %{py3_sitescriptdir}/pytest_timeout-%{version}-py*.egg-info
This page took 0.197074 seconds and 4 git commands to generate.