]> git.pld-linux.org Git - packages/python-pytest-timeout.git/commitdiff
- updated to 1.2.0
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 12 Mar 2017 17:57:25 +0000 (18:57 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 12 Mar 2017 17:57:25 +0000 (18:57 +0100)
python-pytest-timeout.spec

index 3fd17ab95c71c3d3ebdbdaedc636418e7c3ee499..1ebd58e30157aa5e5e3328470e96ff6b820399bf 100644 (file)
@@ -1,87 +1,86 @@
 #
 # Conditional build:
 #
 # Conditional build:
-%bcond_without tests   # do not perform "make test"
+%bcond_without tests   # py.test tests
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
 %define        module  pytest-timeout
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
 %define        module  pytest-timeout
-Summary:       Pytest plugin which will terminate tests after a certain timeout
-Summary(pl.UTF-8):     Wtyczka Pytest wymuszająca zakończenie testów po przekroczeniu limitu czasu
+Summary:       py.test plugin to abort hanging tests
+Summary(pl.UTF-8):     Wtyczka py.test do przerywania zawieszonych testów
 Name:          python-%{module}
 Name:          python-%{module}
-Version:       1.0.0
-Release:       2
+Version:       1.2.0
+Release:       1
 License:       MIT
 Group:         Libraries/Python
 License:       MIT
 Group:         Libraries/Python
-Source0:       https://pypi.python.org/packages/cf/92/ab29b9baa54d47dfd50e43be35577de9af4e7ebf27d29f546ddeb6c3b6f5/pytest-timeout-%{version}.tar.gz
-# Source0-md5: f9f162bd079689980b5614673ddfdae4
+Source0:       https://pypi.python.org/packages/cc/b7/b2a61365ea6b6d2e8881360ae7ed8dad0327ad2df89f2f0be4a02304deb2/pytest-timeout-%{version}.tar.gz
+# Source0-md5: 83607d91aa163562c7ee835da57d061d
 URL:           http://bitbucket.org/pytest-dev/pytest-timeout/
 URL:           http://bitbucket.org/pytest-dev/pytest-timeout/
-BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with python2}
 %if %{with python2}
-BuildRequires: python-modules
-BuildRequires: python-pytest
+BuildRequires: python-modules >= 1:2.6
 BuildRequires: python-setuptools
 BuildRequires: python-setuptools
+%if %{with tests}
+BuildRequires: python-pexpect
+BuildRequires: python-pytest >= 2.8.0
+%endif
 %endif
 %if %{with python3}
 %endif
 %if %{with python3}
-BuildRequires: python3-modules
-BuildRequires: python3-pytest
+BuildRequires: python3-modules >= 1:3.3
 BuildRequires: python3-setuptools
 BuildRequires: python3-setuptools
+%if %{with tests}
+BuildRequires: python3-pexpect
+BuildRequires: python3-pytest >= 2.8.0
+%endif
 %endif
 %endif
-Requires:      python-modules
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.714
+Requires:      python-modules >= 1:2.6
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Pytest plugin which will terminate tests after a certain timeout When
-doing so it will show a stack dump of all threads running at the time.
+This is a plugin which will terminate tests after a certain timeout.
+When doing so it will show a stack dump of all threads running at the
+time. This is useful when running tests under a continuous integration
+server or simply if you don't know why the test suite hangs.
 
 %description -l pl.UTF-8
 
 %description -l pl.UTF-8
-Wtyczka Pytest wymuszająca zakończenie testów po przekroczeniu limitu
-czasu Przy przekroczeniu pokaże zrzut stosu wszystkich wątków
-biegnących w tym czasie
+Ta wtyczka przerywa testy po upłynięciu określonego limitu czasu. Przy
+tym pokazuje zrzut stosu wszystkich wątków działających w tej chwili.
+Jest to przydatne przy uruchamianiu testów na serwerze ciągłej
+integracji lub jeśli nie wiemy, dlaczego testy się zawieszają.
 
 %package -n python3-%{module}
 
 %package -n python3-%{module}
-Summary:       Pytest plugin which will terminate tests after a certain timeout
-Summary(pl.UTF-8):     Wtyczka Pytest wymuszająca zakończenie testów po przekroczeniu limitu czasu
+Summary:       py.test plugin to abort hanging tests
+Summary(pl.UTF-8):     Wtyczka py.test do przerywania zawieszonych testów
 Group:         Libraries/Python
 Group:         Libraries/Python
-Requires:      python3-modules
+Requires:      python3-modules >= 1:3.3
 
 %description -n python3-%{module}
 
 %description -n python3-%{module}
-Pytest plugin which will terminate tests after a certain timeout When
-doing so it will show a stack dump of all threads running at the time.
+This is a plugin which will terminate tests after a certain timeout.
+When doing so it will show a stack dump of all threads running at the
+time. This is useful when running tests under a continuous integration
+server or simply if you don't know why the test suite hangs.
 
 %description -n python3-%{module} -l pl.UTF-8
 
 %description -n python3-%{module} -l pl.UTF-8
-Wtyczka Pytest wymuszająca zakończenie testów po przekroczeniu limitu
-czasu Przy przekroczeniu pokaże zrzut stosu wszystkich wątków
-biegnących w tym czasie
-
-%package apidocs
-Summary:       %{module} API documentation
-Summary(pl.UTF-8):     Dokumentacja API %{module}
-Group:         Documentation
-
-%description apidocs
-API documentation for %{module}.
-
-%description apidocs -l pl.UTF-8
-Dokumentacja API %{module}.
+Ta wtyczka przerywa testy po upłynięciu określonego limitu czasu. Przy
+tym pokazuje zrzut stosu wszystkich wątków działających w tej chwili.
+Jest to przydatne przy uruchamianiu testów na serwerze ciągłej
+integracji lub jeśli nie wiemy, dlaczego testy się zawieszają.
 
 %prep
 %setup -q -n %{module}-%{version}
 
 %build
 %if %{with python2}
 
 %prep
 %setup -q -n %{module}-%{version}
 
 %build
 %if %{with python2}
-%py_build %{?with_tests:test}
+%py_build
+
+%{?with_tests:PYTHONPATH=$(pwd) %{__python} -m pytest}
 %endif
 
 %if %{with python3}
 %endif
 
 %if %{with python3}
-%py3_build %{?with_tests:test}
-%endif
+%py3_build
 
 
-%if %{with doc}
-cd docs
-%{__make} -j1 html
-rm -rf _build/html/_sources
+%{?with_tests:PYTHONPATH=$(pwd) %{__python3} -m pytest}
 %endif
 
 %install
 %endif
 
 %install
@@ -102,7 +101,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc README
+%doc LICENSE README
 %{py_sitescriptdir}/pytest_timeout.py[co]
 %{py_sitescriptdir}/pytest_timeout-%{version}-py*.egg-info
 %endif
 %{py_sitescriptdir}/pytest_timeout.py[co]
 %{py_sitescriptdir}/pytest_timeout-%{version}-py*.egg-info
 %endif
@@ -110,14 +109,8 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc README
+%doc LICENSE README
 %{py3_sitescriptdir}/pytest_timeout.py
 %{py3_sitescriptdir}/pytest_timeout.py
-%{py3_sitescriptdir}/__pycache__/pytest_timeout.*.pyc
+%{py3_sitescriptdir}/__pycache__/pytest_timeout.cpython-*.py[co]
 %{py3_sitescriptdir}/pytest_timeout-%{version}-py*.egg-info
 %endif
 %{py3_sitescriptdir}/pytest_timeout-%{version}-py*.egg-info
 %endif
-
-%if %{with doc}
-%files apidocs
-%defattr(644,root,root,755)
-%doc docs/_build/html/*
-%endif
This page took 0.131208 seconds and 4 git commands to generate.