]> git.pld-linux.org Git - packages/python-pytest-timeout.git/blame - python-pytest-timeout.spec
BR setuptools
[packages/python-pytest-timeout.git] / python-pytest-timeout.spec
CommitLineData
16a57b48 1#
44e10bda 2# Conditional build:
44e10bda
MK
3%bcond_without tests # do not perform "make test"
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
44e10bda
MK
7%define module pytest-timeout
8Summary: Pytest plugin which will terminate tests after a certain timeout
9Summary(pl.UTF-8): Wtyczka Pytest wymuszająca zakończenie testów po przekroczeniu limitu czasu
44e10bda
MK
10Name: python-%{module}
11Version: 1.0.0
12Release: 1
13License: MIT
14Group: Libraries/Python
15Source0: https://pypi.python.org/packages/cf/92/ab29b9baa54d47dfd50e43be35577de9af4e7ebf27d29f546ddeb6c3b6f5/pytest-timeout-%{version}.tar.gz
16# Source0-md5: f9f162bd079689980b5614673ddfdae4
17URL: http://bitbucket.org/pytest-dev/pytest-timeout/
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
21BuildRequires: python-modules
22BuildRequires: python-pytest
481c2014 23BuildRequires: python-setuptools
44e10bda
MK
24%endif
25%if %{with python3}
26BuildRequires: python3-modules
27BuildRequires: python3-pytest
481c2014 28BuildRequires: python3-setuptools
44e10bda
MK
29%endif
30Requires: python-modules
31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35Pytest plugin which will terminate tests after a certain timeout When
36doing so it will show a stack dump of all threads running at the time.
37
38%description -l pl.UTF-8
39Wtyczka Pytest wymuszająca zakończenie testów po przekroczeniu limitu
40czasu Przy przekroczeniu pokaże zrzut stosu wszystkich wątków
41biegnących w tym czasie
42
43%package -n python3-%{module}
44Summary: Pytest plugin which will terminate tests after a certain timeout
45Summary(pl.UTF-8): Wtyczka Pytest wymuszająca zakończenie testów po przekroczeniu limitu czasu
46Group: Libraries/Python
47Requires: python3-modules
48
49%description -n python3-%{module}
50Pytest plugin which will terminate tests after a certain timeout When
51doing so it will show a stack dump of all threads running at the time.
52
53%description -n python3-%{module} -l pl.UTF-8
54Wtyczka Pytest wymuszająca zakończenie testów po przekroczeniu limitu
55czasu Przy przekroczeniu pokaże zrzut stosu wszystkich wątków
56biegnących w tym czasie
57
58%package apidocs
59Summary: %{module} API documentation
60Summary(pl.UTF-8): Dokumentacja API %{module}
61Group: Documentation
62
63%description apidocs
64API documentation for %{module}.
65
66%description apidocs -l pl.UTF-8
67Dokumentacja API %{module}.
68
69%prep
70%setup -q -n %{module}-%{version}
71
72%build
73%if %{with python2}
74%py_build %{?with_tests:test}
75%endif
76
77%if %{with python3}
78%py3_build %{?with_tests:test}
79%endif
80
81%if %{with doc}
82cd docs
83%{__make} -j1 html
84rm -rf _build/html/_sources
85%endif
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90%if %{with python2}
91%py_install
92%py_postclean
93%endif
94
95%if %{with python3}
96%py3_install
97%endif
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%if %{with python2}
103%files
104%defattr(644,root,root,755)
105%doc README
16a57b48 106%{py_sitescriptdir}/pytest_timeout.py[co]
44e10bda
MK
107%{py_sitescriptdir}/pytest_timeout-%{version}-py*.egg-info
108%endif
44e10bda
MK
109
110%if %{with python3}
111%files -n python3-%{module}
112%defattr(644,root,root,755)
113%doc README
114%{py3_sitescriptdir}/pytest_timeout.py
115%{py3_sitescriptdir}/__pycache__/pytest_timeout.*.pyc
116%{py3_sitescriptdir}/pytest_timeout-%{version}-py*.egg-info
117%endif
118
119%if %{with doc}
120%files apidocs
121%defattr(644,root,root,755)
122%doc docs/_build/html/*
123%endif
This page took 0.117525 seconds and 4 git commands to generate.