]> git.pld-linux.org Git - packages/python-pyilmbase.git/blob - python-pyilmbase.spec
boost rebuild
[packages/python-pyilmbase.git] / python-pyilmbase.spec
1 Summary:        Python bindings for the IlmBase libraries
2 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek IlmBase
3 Name:           python-pyilmbase
4 Version:        2.2.1
5 Release:        5
6 License:        BSD
7 Group:          Libraries/Python
8 Source0:        http://download.savannah.gnu.org/releases/openexr/pyilmbase-%{version}.tar.gz
9 # Source0-md5:  363d99ecf7a4a03bb91ac427d86c01bd
10 Patch0:         %{name}-link.patch
11 URL:            http://www.openexr.com/
12 BuildRequires:  autoconf >= 2.50
13 BuildRequires:  automake >= 1.6.3
14 BuildRequires:  boost-python-devel
15 BuildRequires:  ilmbase-devel >= 2.2.1
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.5
18 BuildRequires:  pkgconfig
19 BuildRequires:  python-devel
20 BuildRequires:  python-numpy-devel
21 BuildRequires:  rpm-pythonprov
22 Requires:       ilmbase >= 2.2.1
23 Requires:       python-modules
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The PyIlmBase package provides python bindings for the IlmBase
28 libraries.
29
30 %description -l pl.UTF-8
31 Pakiet PyIlmBase dostarcza wiązania Pythona do bibliotek IlmBase.
32
33 %package devel
34 Summary:        Header files for IlmBase Python bindings
35 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Pyhona do bibliotek IlmBase
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       boost-python-devel
39 Requires:       ilmbase-devel >= 2.2.1
40 Requires:       libstdc++-devel
41
42 %define         specflags -std=c++11
43
44 %description devel
45 Header files for IlmBase Python bindings.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe wiązań Pyhona do bibliotek IlmBase.
49
50 %prep
51 %setup -q -n pyilmbase-%{version}
52 %patch0 -p1
53
54 %build
55 %{__libtoolize}
56 %{__aclocal} -I m4
57 %{__autoconf}
58 %{__automake}
59 %configure \
60         --with-boost-python-libname=boost_python%(echo %{py_ver} | tr -d .)
61
62 # g++ eats a lot of memory, don't run many in parallel
63 %{__make} -j1
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 # parallel build fails at libPyImath/imathmodule install
69 %{__make} -j1 install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libPy*.la \
73         $RPM_BUILD_ROOT%{py_sitedir}/*.la
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc AUTHORS COPYING ChangeLog NEWS README
81 %attr(755,root,root) %{_libdir}/libPyIex.so.*.*.*
82 %attr(755,root,root) %ghost %{_libdir}/libPyIex.so.23
83 %attr(755,root,root) %{_libdir}/libPyImath.so.*.*.*
84 %attr(755,root,root) %ghost %{_libdir}/libPyImath.so.23
85 %attr(755,root,root) %{py_sitedir}/iexmodule.so
86 %attr(755,root,root) %{py_sitedir}/imathmodule.so
87 %attr(755,root,root) %{py_sitedir}/imathnumpymodule.so
88
89 %files devel
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/libPyIex.so
92 %attr(755,root,root) %{_libdir}/libPyImath.so
93 %{_includedir}/OpenEXR/PyIex*.h
94 %{_includedir}/OpenEXR/PyIlmBaseConfig.h
95 %{_includedir}/OpenEXR/PyImath*.h
96 %{_pkgconfigdir}/PyIlmBase.pc
97 %{_aclocaldir}/pyilmbase.m4
This page took 0.069856 seconds and 3 git commands to generate.