]> git.pld-linux.org Git - packages/python-pyicu.git/blob - python-pyicu.spec
ed32698a2447bd3f395ddbc3c74be9576278afc3
[packages/python-pyicu.git] / python-pyicu.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5 #
6 Summary:        PyICU - Python 2 extension wrapping IBM's ICU C++ API
7 Summary(pl.UTF-8):      PyICU - rozszerzenie Pythona 2 obudowujące API C++ biblioteki ICU firmy IBM
8 Name:           python-pyicu
9 Version:        1.9.5
10 Release:        1
11 License:        MIT-like
12 Group:          Development/Languages/Python
13 Source0:        https://pypi.python.org/packages/a2/9f/1947f288143191b903e58633ee597cb98bc284de28dafb1231b6f8b67b99/PyICU-%{version}.tar.gz
14 # Source0-md5:  30f85b7272f15b26c110c9f3e3a9e7a0
15 URL:            http://site.icu-project.org/
16 BuildRequires:  libicu-devel >= 3.6
17 BuildRequires:  libstdc++-devel
18 %if %{with python2}
19 BuildRequires:  python-devel >= 1:2.3
20 BuildRequires:  python-modules >= 1:2.3
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-devel >= 3.2
24 BuildRequires:  python3-modules >= 3.2
25 %endif
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.714
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 PyICU is a Python extension wrapping IBM's ICU C++ API.
32
33 This package contains Python 2 module.
34
35 %description -l pl.UTF-8
36 PyICU to rozszerzenie Pythona obudowujące API C++ biblioteki ICU firmy
37 IBM.
38
39 Ten pakiet zawiera moduł Pythona 2.
40
41 %package -n python3-pyicu
42 Summary:        PyICU - Python 3 extension wrapping IBM's ICU C++ API
43 Summary(pl.UTF-8):      PyICU - rozszerzenie Pythona 3 obudowujące API C++ biblioteki ICU firmy IBM
44 Group:          Development/Languages/Python
45
46 %description -n python3-pyicu
47 PyICU is a Python extension wrapping IBM's ICU C++ API.
48
49 This package contains Python 3 module.
50
51 %description -n python3-pyicu -l pl.UTF-8
52 PyICU to rozszerzenie Pythona obudowujące API C++ biblioteki ICU firmy
53 IBM.
54
55 Ten pakiet zawiera moduł Pythona 3.
56
57 %prep
58 %setup -q -n PyICU-%{version}
59
60 %build
61 %if %{with python2}
62 %py_build
63 %endif
64
65 %if %{with python3}
66 %py3_build
67 %endif
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %if %{with python2}
73 %py_install
74 %py_postclean
75 %endif
76
77 %if %{with python3}
78 %py3_install
79 %endif
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %if %{with python2}
85 %files
86 %defattr(644,root,root,755)
87 %doc CHANGES CREDITS LICENSE README.md
88 %{py_sitedir}/PyICU.py[co]
89 %{py_sitedir}/docs.py[co]
90 %{py_sitedir}/icu.py[co]
91 %attr(755,root,root) %{py_sitedir}/_icu.so
92 %if "%{py_ver}" > "2.4"
93 %{py_sitedir}/PyICU-%{version}-py*.egg-info
94 %endif
95 %endif
96
97 %if %{with python3}
98 %files -n python3-pyicu
99 %defattr(644,root,root,755)
100 %doc CHANGES CREDITS LICENSE README.md
101 %{py3_sitedir}/PyICU.py
102 %{py3_sitedir}/docs.py
103 %{py3_sitedir}/icu.py
104 %{py3_sitedir}/__pycache__/PyICU.*.py[co]
105 %{py3_sitedir}/__pycache__/docs.*.py[co]
106 %{py3_sitedir}/__pycache__/icu.*.py[co]
107 %attr(755,root,root) %{py3_sitedir}/_icu.cpython-*.so
108 %{py3_sitedir}/PyICU-%{version}-py*.egg-info
109 %endif
This page took 0.028137 seconds and 2 git commands to generate.