]> git.pld-linux.org Git - packages/python-pyicu.git/blob - python-pyicu.spec
17cc679a0c60fbefa9afd89931b2b8975cf2124f
[packages/python-pyicu.git] / python-pyicu.spec
1 %define         module  pyicu
2 Summary:        PyICU is a python extension wrapping IBM's ICU C++ API
3 Name:           python-%{module}
4 Version:        1.0
5 Release:        1
6 License:        BSD-like
7 Group:          Development/Languages/Python
8 URL:            http://pyicu.osafoundation.org/
9 Source0:        http://pypi.python.org/packages/source/P/PyICU/PyICU-%{version}.tar.gz
10 # Source0-md5:  138d257dd11e1c438d8d7b7fec9a2bdf
11 BuildRequires:  libicu-devel >= 3.6
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  python-devel >= 1:2.3
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 PyICU is a python extension wrapping IBM's ICU C++ API.
19
20 %prep
21 %setup -q -n PyICU-%{version}
22
23 %build
24 CC="%{__cc}" \
25 CFLAGS="%{rpmcflags}" \
26 %{__python} setup.py build
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 %{__python} setup.py install \
31         --skip-build \
32         --optimize=2 \
33         --root=$RPM_BUILD_ROOT
34
35 %py_postclean
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %files
41 %defattr(644,root,root,755)
42 %doc CHANGES CREDITS LICENSE README
43 %{py_sitedir}/PyICU.py[co]
44 %{py_sitedir}/docs.py[co]
45 %{py_sitedir}/icu.py[co]
46 %attr(755,root,root) %{py_sitedir}/_icu.so
47 %if "%{py_ver}" > "2.4"
48 %{py_sitedir}/PyICU-%{version}*.egg-info
49 %endif
This page took 0.068426 seconds and 3 git commands to generate.