]> git.pld-linux.org Git - packages/python-pyicu.git/blob - python-pyicu.spec
0720911042ad77ed1a15bc2d83e4fcaf9de84e98
[packages/python-pyicu.git] / python-pyicu.spec
1 %define         module  pyicu
2 Summary:        PyICU is a python extension wrapping IBM's ICU C++ API
3 Name:           python-%{module}
4 Version:        1.1
5 Release:        2
6 License:        BSD-like
7 Group:          Development/Languages/Python
8 URL:            http://pyicu.osafoundation.org/
9 Source0:        http://pypi.python.org/packages/source/P/PyICU/PyICU-%{version}.tar.gz
10 # Source0-md5:  70cbb5b43c3e6939b74c3f1b27e47aae
11 BuildRequires:  libicu-devel >= 3.6
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  python-devel >= 1:2.3
14 BuildRequires:  python-modules
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.219
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 PyICU is a python extension wrapping IBM's ICU C++ API.
21
22 %prep
23 %setup -q -n PyICU-%{version}
24
25 %build
26 CC="%{__cc}" \
27 CFLAGS="%{rpmcflags}" \
28 %{__python} setup.py build
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 %{__python} setup.py install \
33         --skip-build \
34         --optimize=2 \
35         --root=$RPM_BUILD_ROOT
36
37 %py_postclean
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %doc CHANGES CREDITS LICENSE README
45 %{py_sitedir}/PyICU.py[co]
46 %{py_sitedir}/docs.py[co]
47 %{py_sitedir}/icu.py[co]
48 %attr(755,root,root) %{py_sitedir}/_icu.so
49 %if "%{py_ver}" > "2.4"
50 %{py_sitedir}/PyICU-%{version}*.egg-info
51 %endif
This page took 0.019185 seconds and 2 git commands to generate.