]> git.pld-linux.org Git - packages/python-pycodestyle.git/commitdiff
Revert "Revert "- updated to 2.4.0""
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 22 Oct 2019 16:32:23 +0000 (18:32 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 22 Oct 2019 16:32:23 +0000 (18:32 +0200)
This reverts commit 9b2fd2cf5d0d71bb4c95e7c3fa6a8325aec20191.

python-pycodestyle-py3.7.patch [deleted file]
python-pycodestyle.spec

diff --git a/python-pycodestyle-py3.7.patch b/python-pycodestyle-py3.7.patch
deleted file mode 100644 (file)
index 26c8abc..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
---- pycodestyle-2.3.1/pycodestyle.py.orig      2017-01-31 00:57:04.000000000 +0100
-+++ pycodestyle-2.3.1/pycodestyle.py   2018-07-22 10:20:35.053176323 +0200
-@@ -91,7 +91,7 @@
- PyCF_ONLY_AST = 1024
- SINGLETONS = frozenset(['False', 'None', 'True'])
--KEYWORDS = frozenset(keyword.kwlist + ['print']) - SINGLETONS
-+KEYWORDS = frozenset(keyword.kwlist + ['print', 'async']) - SINGLETONS
- UNARY_OPERATORS = frozenset(['>>', '**', '*', '+', '-'])
- ARITHMETIC_OP = frozenset(['**', '*', '/', '//', '+', '-'])
- WS_OPTIONAL_OPERATORS = ARITHMETIC_OP.union(['^', '&', '|', '<<', '>>', '%'])
-@@ -110,7 +110,7 @@
- RERAISE_COMMA_REGEX = re.compile(r'raise\s+\w+\s*,.*,\s*\w+\s*$')
- ERRORCODE_REGEX = re.compile(r'\b[A-Z]\d{3}\b')
- DOCSTRING_REGEX = re.compile(r'u?r?["\']')
--EXTRANEOUS_WHITESPACE_REGEX = re.compile(r'[[({] | []}),;:]')
-+EXTRANEOUS_WHITESPACE_REGEX = re.compile(r'[\[({] | [\]}),;:]')
- WHITESPACE_AFTER_COMMA_REGEX = re.compile(r'[,;:]\s*(?:  |\t)')
- COMPARE_SINGLETON_REGEX = re.compile(r'(\bNone|\bFalse|\bTrue)?\s*([=!]=)'
-                                      r'\s*(?(1)|(None|False|True))\b')
---- pycodestyle-2.3.1/testsuite/E25.py.orig    2018-07-22 10:30:36.083169457 +0200
-+++ pycodestyle-2.3.1/testsuite/E25.py 2018-07-22 10:30:41.713169396 +0200
-@@ -39,6 +39,6 @@
- async def add(a: int = 0, b: int = 0) -> int:
-     return a + b
- # Previously E251 four times
--#: E272:1:6
-+#: E271:1:6
- async  def add(a: int = 0, b: int = 0) -> int:
-     return a + b
---- pycodestyle-2.3.1/testsuite/E30.py.orig    2017-01-25 00:13:11.000000000 +0100
-+++ pycodestyle-2.3.1/testsuite/E30.py 2018-07-22 10:31:24.909835554 +0200
-@@ -157,7 +157,7 @@
- if __name__ == '__main__':
-     main()
- # Previously just E272:1:6 E272:4:6
--#: E302:4:1 E272:1:6 E272:4:6
-+#: E302:4:1 E271:1:6 E271:4:6
- async  def x():
-     pass
---- pycodestyle-2.3.1/testsuite/E70.py.orig    2017-01-25 00:13:11.000000000 +0100
-+++ pycodestyle-2.3.1/testsuite/E70.py 2018-07-22 10:31:53.633168572 +0200
-@@ -14,7 +14,7 @@
- def f(x): return 2
- #: E704:1:1
- async def f(x): return 2
--#: E704:1:1 E272:1:6
-+#: E704:1:1 E271:1:6
- async  def f(x): return 2
- #: E704:1:1 E226:1:19
- def f(x): return 2*x
index efa012bfdf21dfeaa39f381b91708d64b395b199..2bedbaaa9cc2793d76b7b372e56158d82a2f08c6 100644 (file)
@@ -1,22 +1,21 @@
 #
 # Conditional build:
-%bcond_without tests   # test target
 %bcond_without doc     # API documentation
+%bcond_without tests   # unit tests
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
 Summary:       Python style guide checker
 Summary(pl.UTF-8):     Sprawdzanie zgodności z poradnikiem stylu kodowania w Pythonie
 Name:          python-pycodestyle
-# NOTE: 2.4.0 is on DEVEL-2.4 branch; don't upgrade on master until release of flake8 ready for new pycodestyle
-Version:       2.3.1
-Release:       2
+# NOTE: before upgrading to >=2.6.0 check for flake8 release supporting new pycodestyle
+Version:       2.4.0
+Release:       1
 License:       MIT
 Group:         Libraries/Python
-#Source0Download: https://pypi.python.org/simple/pycodestyle/
+#Source0Download: https://pypi.org/simple/pycodestyle/
 Source0:       https://files.pythonhosted.org/packages/source/p/pycodestyle/pycodestyle-%{version}.tar.gz
-# Source0-md5: 240e342756af30cae0983b16303a2055
-Patch0:                %{name}-py3.7.patch
+# Source0-md5: 85bbebd2c90d2f833c1db467d4d0e9a3
 URL:           https://pycodestyle.readthedocs.io/
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
@@ -25,7 +24,7 @@ BuildRequires:        python-modules >= 1:2.6
 BuildRequires: python-setuptools
 %endif
 %if %{with python3}
-BuildRequires: python3-modules >= 1:3.2
+BuildRequires: python3-modules >= 1:3.3
 BuildRequires: python3-setuptools
 %endif
 %{?with_doc:BuildRequires:     sphinx-pdg}
@@ -46,7 +45,7 @@ wcześniej nazywał się pep8.
 Summary:       Python style guide checker
 Summary(pl.UTF-8):     Sprawdzanie zgodności z poradnikiem stylu kodowania w Pythonie
 Group:         Libraries/Python
-Requires:      python3-modules >= 1:3.2
+Requires:      python3-modules >= 1:3.3
 
 %description -n python3-pycodestyle
 pycodestyle is a tool to check your Python code against some of the
@@ -70,7 +69,6 @@ Dokumentacja API modułu pycodestyle.
 
 %prep
 %setup -q -n pycodestyle-%{version}
-%patch0 -p1
 
 %build
 %if %{with python2}
@@ -109,7 +107,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc CHANGES.txt README.rst
+%doc CHANGES.txt LICENSE README.rst
 %attr(755,root,root) %{_bindir}/pycodestyle
 %attr(755,root,root) %{_bindir}/pycodestyle-2
 %{py_sitescriptdir}/pycodestyle.py[co]
@@ -119,7 +117,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-pycodestyle
 %defattr(644,root,root,755)
-%doc CHANGES.txt README.rst
+%doc CHANGES.txt LICENSE README.rst
 %attr(755,root,root) %{_bindir}/pycodestyle-3
 %{py3_sitescriptdir}/pycodestyle.py
 %{py3_sitescriptdir}/__pycache__/pycodestyle.cpython-*.py[co]
This page took 0.157005 seconds and 4 git commands to generate.