]> git.pld-linux.org Git - packages/python-pycairo.git/blob - python-pycairo.spec
- unconditional noarch subpackages
[packages/python-pycairo.git] / python-pycairo.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5 %bcond_without  doc     # Sphinx documentation
6 %bcond_without  tests   # unit tests
7
8 %define         module  pycairo
9 Summary:        Python 2 Cairo bindings
10 Summary(pl.UTF-8):      Dowiązania Pythona 2 dla Cairo
11 Name:           python-%{module}
12 Version:        1.16.3
13 Release:        5
14 License:        LGPL v2.1 or MPL v1.1
15 Group:          Libraries/Python
16 Source0:        https://github.com/pygobject/pycairo/releases/download/v%{version}/%{module}-%{version}.tar.gz
17 # Source0-md5:  d2a115037ccd128219f43d5ed3df7926
18 Patch0:         python3.8.patch
19 URL:            http://cairographics.org/
20 BuildRequires:  cairo-devel >= 1.13.1
21 BuildRequires:  pkgconfig
22 %if %{with python2}
23 BuildRequires:  python >= 1:2.7
24 BuildRequires:  python-devel >= 1:2.7
25 # python2 only for now
26 BuildRequires:  python-xpyb-devel >= 1.3
27 %if %{with tests}
28 BuildRequires:  python-hypothesis
29 BuildRequires:  python-numpy
30 BuildRequires:  python-pytest
31 %endif
32 %endif
33 %if %{with python3}
34 BuildRequires:  python3 >= 1:3.3
35 BuildRequires:  python3-devel >= 1:3.3
36 %if %{with tests}
37 BuildRequires:  python3-hypothesis
38 BuildRequires:  python3-numpy
39 BuildRequires:  python3-pytest
40 %endif
41 %endif
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.714
44 %if %{with doc}
45 BuildRequires:  python-Sphinx
46 %endif
47 Requires:       python-libs >= 1:2.7
48 Requires:       cairo >= 1.13.1
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Python 2 Cairo bindings.
53
54 %description -l pl.UTF-8
55 Dowiązania Pythona 2 dla Cairo.
56
57 %package devel
58 Summary:        Development files for Python 2 pycairo
59 Summary(pl.UTF-8):      Pliki programistyczne pycairo dla Pythona 2
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       cairo-devel >= 1.13.1
63 Requires:       python-devel >= 1:2.7
64
65 %description devel
66 Development files for Python 2 pycairo.
67
68 %description devel -l pl.UTF-8
69 Pliki programistyczne pycairo dla Pythona 2.
70
71 %package -n python3-%{module}
72 Summary:        Python 3 Cairo bindings
73 Summary(pl.UTF-8):      Dowiązania Pythona 3 dla Cairo
74 Group:          Libraries/Python
75 Requires:       cairo >= 1.13.1
76 Requires:       python3-libs >= 1:3.3
77
78 %description -n python3-%{module}
79 Python 3 Cairo bindings.
80
81 %description -n python3-%{module} -l pl.UTF-8
82 Dowiązania Pythona 3 dla Cairo.
83
84 %package -n python3-%{module}-devel
85 Summary:        Development files for Python 3 pycairo
86 Summary(pl.UTF-8):      Pliki programistyczne pycairo dla Pythona 3
87 Group:          Development/Libraries
88 Requires:       cairo-devel >= 1.13.1
89 Requires:       python3-%{module} = %{version}-%{release}
90 Requires:       python3-devel >= 1:3.3
91
92 %description -n python3-%{module}-devel
93 Development files for Python 3 pycairo.
94
95 %description -n python3-%{module}-devel -l pl.UTF-8
96 Pliki programistyczne pycairo dla Pythona 3.
97
98 %package apidocs
99 Summary:        API documentation for Python Cairo bindings
100 Summary(pl.UTF-8):      Dokumentacja API dla wiązań Pythona do Cairo
101 Group:          Documentation
102 BuildArch:      noarch
103
104 %description apidocs
105 API documentation for Python Cairo bindings.
106
107 %description apidocs -l pl.UTF-8
108 Dokumentacja API dla wiązań Pythona do Cairo.
109
110 %package examples
111 Summary:        Example programs using Python Cairo bindings
112 Summary(pl.UTF-8):      Przykładowe programy w Pythonie używające Cairo
113 Group:          Libraries/Python
114 Obsoletes:      python3-pycairo-devel
115 BuildArch:      noarch
116
117 %description examples
118 Example programs using Python Cairo bindings.
119
120 %description examples -l pl.UTF-8
121 Przykładowe programy w Pythonie używające Cairo.
122
123 %prep
124 %setup -q -n pycairo-%{version}
125 %patch0 -p1
126
127 %build
128 %if %{with python2}
129 %py_build %{?with_tests:test} \
130         --enable-xpyb
131 %endif
132
133 %if %{with python3}
134 %py3_build %{?with_tests:test}
135 %endif
136
137 %if %{with doc}
138 %{__make} -C docs
139 %endif
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT%{_examplesdir}
144
145 %if %{with python2}
146 %py_install
147
148 %py_postclean
149 %endif
150
151 %if %{with python3}
152 %py3_install
153 %endif
154
155 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %if %{with python2}
161 %files
162 %defattr(644,root,root,755)
163 %doc COPYING NEWS README.rst
164 %dir %{py_sitedir}/cairo
165 %attr(755,root,root) %{py_sitedir}/cairo/_cairo.so
166 %{py_sitedir}/cairo/__init__.py[co]
167 %{py_sitedir}/cairo/__init__.pyi
168 %{py_sitedir}/cairo/include
169 %{py_sitedir}/pycairo-%{version}-py*.egg-info
170
171 %files devel
172 %defattr(644,root,root,755)
173 %dir %{_includedir}/pycairo
174 %{_includedir}/pycairo/pycairo.h
175 %{_pkgconfigdir}/pycairo.pc
176 %endif
177
178 %if %{with python3}
179 %files -n python3-%{module}
180 %defattr(644,root,root,755)
181 %doc COPYING NEWS README.rst
182 %dir %{py3_sitedir}/cairo
183 %attr(755,root,root) %{py3_sitedir}/cairo/_cairo.cpython-*.so
184 %{py3_sitedir}/cairo/__init__.py
185 %{py3_sitedir}/cairo/__init__.pyi
186 %{py3_sitedir}/cairo/__pycache__
187 %{py3_sitedir}/cairo/include
188 %{py3_sitedir}/pycairo-%{version}-py*.egg-info
189
190 %files -n python3-%{module}-devel
191 %defattr(644,root,root,755)
192 %dir %{_includedir}/pycairo
193 %{_includedir}/pycairo/py3cairo.h
194 %{_pkgconfigdir}/py3cairo.pc
195 %endif
196
197 %if %{with doc}
198 %files apidocs
199 %defattr(644,root,root,755)
200 %doc docs/_build/{_images,_static,reference,*.html,*.js}
201 %endif
202
203 %files examples
204 %defattr(644,root,root,755)
205 %{_examplesdir}/%{name}-%{version}
This page took 0.085353 seconds and 3 git commands to generate.