]> git.pld-linux.org Git - packages/python-py.git/blame - python-py.spec
- release 2 (by relup.sh)
[packages/python-py.git] / python-py.spec
CommitLineData
2f514ebb 1#
628c8e46
JB
2# Conditional build:
3%bcond_without doc # HTML documentation build
ca45e258 4%bcond_without python2 # CPython 2.x module
8e9dea4c
ER
5%bcond_without python3 # CPython 3.x module
6
2f514ebb 7%define module py
628c8e46
JB
8Summary: Library with cross-python path, ini-parsing, io, code, log facilities
9Summary(pl.UTF-8): Biblioteka wspierająca obsługę ścieżek, ini, we/wy, kodowania i logowania w wielu Pythonach
2f514ebb 10Name: python-%{module}
5edc3003 11Version: 1.4.32
8d503f1f 12Release: 2
628c8e46 13License: MIT
2f514ebb 14Group: Development/Languages/Python
5edc3003
JB
15#Source0Download: https://pypi.python.org/simple/py
16Source0: https://files.pythonhosted.org/packages/source/p/py/py-%{version}.tar.gz
17# Source0-md5: 68ee0b5867282595d0b410a7f3c03ab3
8e9dea4c
ER
18Source1: http://docs.python.org/objects.inv?/python-objects.inv
19# Source1-md5: 3d3c0b594b2e91d559418c107d973633
628c8e46 20Patch0: %{name}-offline.patch
5d86414d 21URL: https://pypi.python.org/pypi/py
ca45e258 22%if %{with python2}
89e918b3 23BuildRequires: python-devel >= 1:2.5
5d86414d 24BuildRequires: python-setuptools >= 7.0
ca45e258
JB
25%endif
26%if %{with python3}
27BuildRequires: python3-devel >= 1:3.2
28BuildRequires: python3-modules >= 1:3.2
5d86414d 29BuildRequires: python3-setuptools >= 7.0
ca45e258 30%endif
4b858531 31BuildRequires: rpm-pythonprov
2e3dd66c 32BuildRequires: rpmbuild(macros) >= 1.710
628c8e46 33%{?with_doc:BuildRequires: sphinx-pdg >= 1.0}
87d7dbd0 34%{?with_doc:BuildRequires: python-devel-tools}
2f514ebb 35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
628c8e46
JB
38The py lib is a Python development support library featuring the
39following tools and modules:
8e9dea4c
ER
40 - py.path: uniform local and svn path objects
41 - py.apipkg: explicit API control and lazy-importing
42 - py.iniconfig: easy parsing of .ini files
628c8e46 43 - py.code: dynamic code generation and introspection
2f514ebb 44
4b858531 45%description -l pl.UTF-8
628c8e46
JB
46Biblioteka py to biblioteka wpierająca tworzenie oprogramowania w
47Pythonie. Zawiera następujące narzędzia i moduły:
48 - py.path - jednolite obiekty ścieżek lokalnych i svn
49 - py.apipkg - bezpośrednia kontrola API i leniwego importowania
50 - py.iniconfig - łatwa analiza plików .ini
51 - py.code - dynamiczne generowanie kodu i introspekcji
4b858531 52
8e9dea4c
ER
53%package -n python3-py
54Summary: Library with cross-python path, ini-parsing, io, code, log facilities
e50d971d 55Summary(pl.UTF-8): Biblioteka wspierająca obsługę ścieżek, ini, we/wy, kodowania i logowania w wielu Pythonach
8e9dea4c 56Group: Development/Languages/Python
8e9dea4c
ER
57
58%description -n python3-py
59The py lib is a Python development support library featuring the
60following tools and modules:
61- py.path: uniform local and svn path objects
62- py.apipkg: explicit API control and lazy-importing
63- py.iniconfig: easy parsing of .ini files
64- py.code: dynamic code generation and introspection
e50d971d
JB
65
66%description -n python3-py -l pl.UTF-8
67Biblioteka py to biblioteka wpierająca tworzenie oprogramowania w
68Pythonie. Zawiera następujące narzędzia i moduły:
69 - py.path - jednolite obiekty ścieżek lokalnych i svn
70 - py.apipkg - bezpośrednia kontrola API i leniwego importowania
71 - py.iniconfig - łatwa analiza plików .ini
72 - py.code - dynamiczne generowanie kodu i introspekcji
8e9dea4c 73
5edc3003
JB
74%package apidocs
75Summary: Documentation for Python py library
76Summary(pl.UTF-8): Dokumentacja do biblioteki Pythona py
77Group: Documentation
78
79%description apidocs
80Documentation for Python py library.
81
82%description apidocs -l pl.UTF-8
83Dokumentacja do biblioteki Pythona py.
84
2f514ebb 85%prep
86%setup -q -n %{module}-%{version}
628c8e46
JB
87%patch0 -p1
88
89cp -p %{SOURCE1} doc
2f514ebb 90
91%build
ca45e258 92%if %{with python2}
16339572 93%py_build
ca45e258 94%endif
2f514ebb 95
8e9dea4c 96%if %{with python3}
16339572 97%py3_build
8e9dea4c
ER
98%endif
99
628c8e46
JB
100%if %{with doc}
101PYTHONPATH=$(pwd) \
102%{__make} -C doc html
103%endif
104
2f514ebb 105%install
106rm -rf $RPM_BUILD_ROOT
ca45e258
JB
107
108%if %{with python2}
438626b1 109%py_install
2f514ebb 110
111%py_postclean
ca45e258 112%endif
2f514ebb 113
8e9dea4c 114%if %{with python3}
16339572 115%py3_install
8e9dea4c
ER
116%endif
117
2f514ebb 118%clean
119rm -rf $RPM_BUILD_ROOT
120
ca45e258 121%if %{with python2}
2f514ebb 122%files
123%defattr(644,root,root,755)
5edc3003 124%doc AUTHORS CHANGELOG LICENSE README.rst
8e9dea4c
ER
125%{py_sitescriptdir}/%{module}
126%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
ca45e258 127%endif
8e9dea4c
ER
128
129%if %{with python3}
130%files -n python3-py
131%defattr(644,root,root,755)
5edc3003 132%doc AUTHORS CHANGELOG LICENSE README.rst
8e9dea4c
ER
133%{py3_sitescriptdir}/%{module}
134%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
135%endif
5edc3003
JB
136
137%if %{with doc}
138%files apidocs
139%defattr(644,root,root,755)
140%doc doc/_build/html/{_modules,_static,announce,*.html,*.js}
141%endif
This page took 0.108073 seconds and 4 git commands to generate.