]> git.pld-linux.org Git - packages/python-neovim.git/commitdiff
new, version 0.1.9
authorElan Ruusamäe <glen@delfi.ee>
Sat, 17 Sep 2016 21:14:03 +0000 (00:14 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 17 Sep 2016 21:14:57 +0000 (00:14 +0300)
based on copr package by dperson/neovim

https://copr-be.cloud.fedoraproject.org/results/dperson/neovim/fedora-rawhide-x86_64/00389773-python-neovim/python-neovim-0.1.9-3.fc25.src.rpm

python-neovim.spec [new file with mode: 0644]

diff --git a/python-neovim.spec b/python-neovim.spec
new file mode 100644 (file)
index 0000000..572bffb
--- /dev/null
@@ -0,0 +1,84 @@
+#
+# Conditional build:
+%bcond_without python2 # CPython 2.x module
+%bcond_without python3 # CPython 3.x module
+
+%define                module          neovim
+%define                egg_name        neovim
+Summary:       Python client to neovim
+Name:          python-%{module}
+Version:       0.1.9
+Release:       1
+License:       Apache v2.0
+Group:         Libraries/Python
+Source0:       https://github.com/neovim/python-client/archive/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: a79bca20b8e4876e059a4190e68e881b
+URL:           https://github.com/neovim/python-client
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.714
+%if %{with python2}
+BuildRequires: python-modules
+BuildRequires: python-setuptools
+%endif
+%if %{with python3}
+BuildRequires: python3-modules
+BuildRequires: python3-setuptools
+%endif
+Requires:      python-greenlet
+Requires:      python-msgpack
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Implements support for Python plugins in nvim
+
+%package -n python3-neovim
+Summary:       Python client to neovim
+Group:         Libraries/Python
+Requires:      python3-greenlet
+Requires:      python3-msgpack
+
+%description -n python3-neovim
+Implements support for Python plugins in nvim
+
+%prep
+%setup -q -n python-client-%{version}
+
+%build
+%if %{with python2}
+%py_build
+%endif
+
+%if %{with python3}
+%py3_build
+%endif
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%if %{with python2}
+%py_install
+%py_postclean
+%endif
+
+%if %{with python3}
+%py3_install
+%endif
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%if %{with python3}
+%files
+%defattr(644,root,root,755)
+%doc README.md
+%{py_sitescriptdir}/%{module}
+%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
+%endif
+
+%if %{with python3}
+%files -n python3-neovim
+%defattr(644,root,root,755)
+%doc README.md
+%{py3_sitescriptdir}/%{module}
+%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
+%endif
This page took 0.150567 seconds and 4 git commands to generate.