]> git.pld-linux.org Git - packages/python-lxml.git/commitdiff
- ver. 2.3
authorwrobell <wrobell@pld-linux.org>
Sun, 22 May 2011 01:42:24 +0000 (01:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    python-lxml.spec -> 1.28
    python3.patch -> 1.2

python-lxml.spec
python3.patch [deleted file]

index 53e98ebed509ae86865bdea5a28a66490af38a33..45e2c394e9e903202f58baaf67b64798f25f985d 100644 (file)
@@ -8,13 +8,12 @@
 Summary:       A Pythonic binding for the libxml2 and libxslt libraries
 Summary(pl.UTF-8):     Pythonowe wiązanie do bibliotek libxml2 i libxslt
 Name:          python-%{module}
 Summary:       A Pythonic binding for the libxml2 and libxslt libraries
 Summary(pl.UTF-8):     Pythonowe wiązanie do bibliotek libxml2 i libxslt
 Name:          python-%{module}
-Version:       2.2.8
-Release:       2
+Version:       2.3
+Release:       1
 License:       BSD
 Group:         Libraries/Python
 Source0:       http://codespeak.net/lxml/%{module}-%{version}.tgz
 License:       BSD
 Group:         Libraries/Python
 Source0:       http://codespeak.net/lxml/%{module}-%{version}.tgz
-# Source0-md5: d6c612d63a84d79440912a1b29d3b981
-Patch0:                python3.patch
+# Source0-md5: a245a015fd59b63e220005f263e1682a
 URL:           http://codespeak.net/lxml/
 BuildRequires: libxml2-devel
 BuildRequires: libxslt-devel
 URL:           http://codespeak.net/lxml/
 BuildRequires: libxml2-devel
 BuildRequires: libxslt-devel
@@ -60,7 +59,6 @@ API and internal documentation for lxml library.
 
 %prep
 %setup -q -n %{module}-%{version}
 
 %prep
 %setup -q -n %{module}-%{version}
-%patch0 -p1
 
 %build
 %if %{with python2}
 
 %build
 %if %{with python2}
@@ -87,8 +85,6 @@ rm -rf $RPM_BUILD_ROOT
        install \
        --root=$RPM_BUILD_ROOT \
        --optimize=2
        install \
        --root=$RPM_BUILD_ROOT \
        --optimize=2
-
-%py3_postclean
 %endif
 
 # cleanup for packaging
 %endif
 
 # cleanup for packaging
@@ -110,6 +106,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc docs/* CHANGES.txt CREDITS.txt TODO.txt
 %dir %{py_sitedir}/lxml
 %{py_sitedir}/lxml/*.py[co]
 %doc docs/* CHANGES.txt CREDITS.txt TODO.txt
 %dir %{py_sitedir}/lxml
 %{py_sitedir}/lxml/*.py[co]
+%{py_sitedir}/lxml/isoschematron
 %dir %{py_sitedir}/lxml/html
 %{py_sitedir}/lxml/html/*.py[co]
 %attr(755,root,root) %{py_sitedir}/lxml/etree.so
 %dir %{py_sitedir}/lxml/html
 %{py_sitedir}/lxml/html/*.py[co]
 %attr(755,root,root) %{py_sitedir}/lxml/etree.so
@@ -122,11 +119,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc docs/* CHANGES.txt CREDITS.txt TODO.txt
 %dir %{py3_sitedir}/lxml
 %defattr(644,root,root,755)
 %doc docs/* CHANGES.txt CREDITS.txt TODO.txt
 %dir %{py3_sitedir}/lxml
-%{py3_sitedir}/lxml/*.py[co]
-%dir %{py3_sitedir}/lxml/html
-%{py3_sitedir}/lxml/html/*.py[co]
-%attr(755,root,root) %{py3_sitedir}/lxml/etree.so
-%attr(755,root,root) %{py3_sitedir}/lxml/objectify.so
+%attr(755,root,root) %{py3_sitedir}/lxml/*.so
+%{py3_sitedir}/lxml/__pycache__
+%{py3_sitedir}/lxml/*.py
+%{py3_sitedir}/lxml/isoschematron
+%{py3_sitedir}/lxml/html
 %{py3_sitedir}/lxml-*.egg-info
 %endif
 
 %{py3_sitedir}/lxml-*.egg-info
 %endif
 
diff --git a/python3.patch b/python3.patch
deleted file mode 100644 (file)
index f8de0ae..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
---- lxml-2.2.6/src/lxml/html/_html5builder.py.wiget    2009-09-11 10:55:58.000000000 +0200
-+++ lxml-2.2.6/src/lxml/html/_html5builder.py  2010-03-27 16:04:28.693916731 +0100
-@@ -7,6 +7,11 @@ html5lib style guide.
- from html5lib.treebuilders import _base, etree as etree_builders
- from lxml import html, etree
-+try:
-+    empty_string = unicode()
-+except NameError:
-+    empty_string = str()
-+
- class DocumentType(object):
-@@ -77,7 +82,7 @@ class TreeBuilder(_base.TreeBuilder):
-                                                   self.doctype.systemId))
-             buf.append('>')
-         buf.append('<html></html>')
--        root = html.fromstring(u''.join(buf))
-+        root = html.fromstring(empty_string.join(buf))
-         # Append the initial comments:
-         for comment in self.initialComments:
---- lxml-2.2.6/src/lxml/html/_diffcommand.py.wiget     2009-09-11 10:55:58.000000000 +0200
-+++ lxml-2.2.6/src/lxml/html/_diffcommand.py   2010-03-27 16:02:10.727258598 +0100
-@@ -34,7 +34,7 @@ def main(args=None):
-     if options.annotation:
-         return annotate(options, args)
-     if len(args) != 2:
--        print 'Error: you must give two files'
-+        print('Error: you must give two files')
-         parser.print_help()
-         sys.exit(1)
-     file1, file2 = args
-@@ -82,6 +82,6 @@ def split_body(html):
-     return pre, html, post
- def annotate(options, args):
--    print "Not yet implemented"
-+    print("Not yet implemented")
-     sys.exit(1)
-     
This page took 0.063503 seconds and 4 git commands to generate.