]> git.pld-linux.org Git - packages/python-lxml.git/commitdiff
- updated to 4.9.3; force cython regeneration to fix python2 crashes master auto/th/python-lxml-4.9.3-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 23 Sep 2023 19:34:28 +0000 (21:34 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 23 Sep 2023 19:34:28 +0000 (21:34 +0200)
lxml-Skip-failing-test-test_html_prefix_nsmap.patch [new file with mode: 0644]
python-lxml.spec

diff --git a/lxml-Skip-failing-test-test_html_prefix_nsmap.patch b/lxml-Skip-failing-test-test_html_prefix_nsmap.patch
new file mode 100644 (file)
index 0000000..6271dcb
--- /dev/null
@@ -0,0 +1,34 @@
+From 91729cf581f764c3321f644206568f18d0fc92f4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tom=C3=A1=C5=A1=20Hrn=C4=8Diar?= <thrnciar@redhat.com>
+Date: Thu, 18 May 2023 08:00:48 +0200
+Subject: [PATCH] Skip failing test test_html_prefix_nsmap
+
+Upstream issue: https://bugs.launchpad.net/lxml/+bug/2016939
+---
+ src/lxml/tests/test_etree.py | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/lxml/tests/test_etree.py b/src/lxml/tests/test_etree.py
+index 0339796..1994a7f 100644
+--- a/src/lxml/tests/test_etree.py
++++ b/src/lxml/tests/test_etree.py
+@@ -27,6 +27,8 @@ from .common_imports import SillyFileLike, LargeFileLikeUnicode, doctest, make_d
+ from .common_imports import canonicalize, _str, _bytes
+ from .common_imports import SimpleFSPath
++from unittest import skip
++
+ print("""
+ TESTED VERSION: %s""" % etree.__version__ + """
+     Python:           %r""" % (sys.version_info,) + """
+@@ -3067,6 +3069,7 @@ class ETreeOnlyTestCase(HelperTestCase):
+         self.assertEqual(re, e.nsmap)
+         self.assertEqual(r,  s.nsmap)
++    @skip("broken with libxml2 2.10.4+")
+     def test_html_prefix_nsmap(self):
+         etree = self.etree
+         el = etree.HTML('<hha:page-description>aa</hha:page-description>').find('.//page-description')
+-- 
+2.40.1
+
index b3e16c75427776a82996b395ce3d79f684037f4e..1662336ae22dc6ce8891dfa2bac83046103441e7 100644 (file)
@@ -9,31 +9,31 @@
 Summary:       Python 2 binding for the libxml2 and libxslt libraries
 Summary(pl.UTF-8):     Wiązanie Pythona 2 do bibliotek libxml2 i libxslt
 Name:          python-%{module}
-Version:       4.8.0
-Release:       4
+Version:       4.9.3
+Release:       1
 License:       BSD
 Group:         Libraries/Python
-# until 4.6.1
-#Source0:      https://lxml.de/files/%{module}-%{version}.tgz
 #Source0Download: https://pypi.org/simple/lxml/
 Source0:       https://files.pythonhosted.org/packages/source/l/lxml/%{module}-%{version}.tar.gz
-# Source0-md5: ddb9f25a41ca5fb4f7d174a9d74bfa46
+# Source0-md5: 7298fdca14b10e7b71547ed02b894b25
+Patch0:                lxml-Skip-failing-test-test_html_prefix_nsmap.patch
 URL:           https://lxml.de/
 BuildRequires: libxml2-devel >= 1:2.9.2
 BuildRequires: libxslt-devel >= 1.1.28
 BuildRequires: pkgconfig
 %if %{with python2}
-BuildRequires: python-Cython >= 0.29.7
+BuildRequires: python-Cython >= 0.29.36-2
 BuildRequires: python-devel >= 1:2.7
 BuildRequires: python-modules >= 1:2.7
 BuildRequires: python-setuptools
 %endif
 %if %{with python3}
-BuildRequires: python3-Cython >= 0.29.7
+BuildRequires: python3-Cython >= 0.29.36-2
 BuildRequires: python3-devel >= 1:3.5
 BuildRequires: python3-modules >= 1:3.5
 BuildRequires: python3-setuptools
 %endif
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.752
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -69,6 +69,10 @@ Dokumentacja API modułu lxml.
 
 %prep
 %setup -q -n %{module}-%{version}
+%patch0 -p1
+
+# force cython regeneration
+%{__rm} src/lxml/{_elementpath.c,builder.c,etree.c,etree.h,etree_api.h,lxml.etree.h,lxml.etree_api.h,objectify.c,sax.c}
 
 %build
 %if %{with python2}
@@ -127,7 +131,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc CHANGES.txt CREDITS.txt LICENSE.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,elementtree}.txt
 %dir %{py_sitedir}/lxml
+%{py_sitedir}/lxml/*.pxi
 %{py_sitedir}/lxml/*.py[co]
+%{py_sitedir}/lxml/etree.pyx
+%{py_sitedir}/lxml/objectify.pyx
 %{py_sitedir}/lxml/etree*.h
 %{py_sitedir}/lxml/lxml.etree*.h
 %{py_sitedir}/lxml/includes
@@ -154,8 +161,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{py3_sitedir}/lxml/etree.cpython-*.so
 %attr(755,root,root) %{py3_sitedir}/lxml/objectify.cpython-*.so
 %attr(755,root,root) %{py3_sitedir}/lxml/sax.cpython-*.so
+%{py3_sitedir}/lxml/*.pxi
 %{py3_sitedir}/lxml/*.py
 %{py3_sitedir}/lxml/__pycache__
+%{py3_sitedir}/lxml/etree.pyx
+%{py3_sitedir}/lxml/objectify.pyx
 %{py3_sitedir}/lxml/etree*.h
 %{py3_sitedir}/lxml/lxml.etree*.h
 %{py3_sitedir}/lxml/includes
This page took 0.289402 seconds and 4 git commands to generate.