]> git.pld-linux.org Git - packages/python-lxml.git/blobdiff - python-lxml.spec
Version 2.3.5-1.
[packages/python-lxml.git] / python-lxml.spec
index c59bd506bb32269937ae5b22c8211118fef966b7..db7932d73c0100356d2c2e5fe82cfa2062fa5ec3 100644 (file)
@@ -1,19 +1,20 @@
 #
-%bcond_without python3
-%bcond_without python2
+# Conditional build:
+%bcond_without apidocs         # do not build and package API docs
+%bcond_without python3         # Python 3 package
+%bcond_without python2         # Python 2 package
+
 %define                module  lxml
-#
 Summary:       A Pythonic binding for the libxml2 and libxslt libraries
 Summary(pl.UTF-8):     Pythonowe wiązanie do bibliotek libxml2 i libxslt
 Name:          python-%{module}
-Version:       2.2.6
-Release:       4
+Version:       2.3.5
+Release:       1
 License:       BSD
 Group:         Libraries/Python
-Source0:       http://codespeak.net/lxml/%{module}-%{version}.tgz
-# Source0-md5: b1f700fb22d7ee9b977ee3eceb65b20c
-Patch0:                python3.patch
-URL:           http://codespeak.net/lxml/
+Source0:       http://lxml.de/files/%{module}-%{version}.tgz
+# Source0-md5: d03fb3b9139df7f182afffe72f412c87
+URL:           http://lxml.de/
 BuildRequires: libxml2-devel
 BuildRequires: libxslt-devel
 %if %{with python2}
@@ -48,9 +49,16 @@ lxml is a Pythonic binding for the libxml2 and libxslt libraries.
 %description -n python3-%{module} -l pl.UTF-8
 lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
 
+%package apidocs
+Summary:       lxml API documentation
+Summary(pl.UTF-8):     Dokumentacja API biblioteki lxml
+Group:         Documentation
+
+%description apidocs
+API and internal documentation for lxml library.
+
 %prep
 %setup -q -n %{module}-%{version}
-%patch0 -p1
 
 %build
 %if %{with python2}
@@ -77,19 +85,28 @@ rm -rf $RPM_BUILD_ROOT
        install \
        --root=$RPM_BUILD_ROOT \
        --optimize=2
-
-%py3_postclean
 %endif
 
+# cleanup for packaging
+rm -rf docs
+cp -a doc docs
+# apidocs packaged separately
+rm -rf docs/html
+# build docs not useful at runtime
+rm docs/build.txt
+# common licenses
+rm docs/licenses/{BSD,GPL}.txt
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc doc/* CHANGES.txt CREDITS.txt TODO.txt
+%doc docs/* CHANGES.txt CREDITS.txt TODO.txt
 %dir %{py_sitedir}/lxml
 %{py_sitedir}/lxml/*.py[co]
+%{py_sitedir}/lxml/isoschematron
 %dir %{py_sitedir}/lxml/html
 %{py_sitedir}/lxml/html/*.py[co]
 %attr(755,root,root) %{py_sitedir}/lxml/etree.so
@@ -100,12 +117,18 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc doc/* CHANGES.txt CREDITS.txt TODO.txt
+%doc docs/* CHANGES.txt CREDITS.txt TODO.txt
 %dir %{py3_sitedir}/lxml
-%{py3_sitedir}/lxml/*.py[co]
-%dir %{py3_sitedir}/lxml/html
-%{py3_sitedir}/lxml/html/*.py[co]
-%attr(755,root,root) %{py3_sitedir}/lxml/etree.so
-%attr(755,root,root) %{py3_sitedir}/lxml/objectify.so
+%attr(755,root,root) %{py3_sitedir}/lxml/*.so
+%{py3_sitedir}/lxml/*.py
+%{py3_sitedir}/lxml/__pycache__
+%{py3_sitedir}/lxml/isoschematron
+%{py3_sitedir}/lxml/html
 %{py3_sitedir}/lxml-*.egg-info
 %endif
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%doc doc/html/*
+%endif
This page took 0.078895 seconds and 4 git commands to generate.