]> git.pld-linux.org Git - packages/python-lxml.git/blobdiff - python-lxml.spec
- updated to 4.2.3
[packages/python-lxml.git] / python-lxml.spec
index d91d7f449e0803e51b5ced13358cd8b30beb9199..aea5c820f2cfa2a043c7c21386ecd5918852a83d 100644 (file)
@@ -1,23 +1,36 @@
 #
+# Conditional build:
+%bcond_without apidocs         # API documentation
+%bcond_without python2         # Python 2 package
+%bcond_without python3         # Python 3 package
+%bcond_with    tests           # unit tests (don't work without lxml not installed?)
+
 %define                module  lxml
-#
-Summary:       A Pythonic binding for the libxml2 and libxslt libraries
-Summary(pl.UTF-8):   Pythonowe wiązanie do bibliotek libxml2 i libxslt
+Summary:       Python 2 binding for the libxml2 and libxslt libraries
+Summary(pl.UTF-8):     Wiązanie Pythona 2 do bibliotek libxml2 i libxslt
 Name:          python-%{module}
-Version:       0.8
-Release:       2
+Version:       4.2.3
+Release:       1
 License:       BSD
-Group:         Development/Languages/Python
-Source0:       http://codespeak.net/lxml/%{module}-%{version}.tgz
-# Source0-md5: b156da08fea2af7b34774d5f9c4fa206
-Patch0:                %{name}-path.patch
-URL:           http://codespeak.net/lxml/
-BuildRequires: libxml2-devel
-BuildRequires: libxslt-devel
-BuildRequires: python-Pyrex >= 0.9.4.2
-BuildRequires: python-devel
-BuildRequires: rpmbuild(macros) >= 1.219
-BuildRequires: unzip
+Group:         Libraries/Python
+Source0:       https://lxml.de/files/%{module}-%{version}.tgz
+# Source0-md5: 40331e46f6aa49fd0e7043d82e58a879
+URL:           https://lxml.de/
+BuildRequires: libxml2-devel >= 1:2.9.2
+BuildRequires: libxslt-devel >= 1.1.28
+%if %{with python2}
+BuildRequires: python-devel >= 1:2.6
+BuildRequires: python-modules >= 1:2.6
+BuildRequires: python-setuptools
+%endif
+%if %{with python3}
+BuildRequires: python3-Cython >= 0.17
+BuildRequires: python3-devel >= 1:3.3
+BuildRequires: python3-modules >= 1:3.3
+BuildRequires: python3-setuptools
+%endif
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.710
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -26,31 +39,115 @@ lxml is a Pythonic binding for the libxml2 and libxslt libraries.
 %description -l pl.UTF-8
 lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
 
+%package -n python3-%{module}
+Summary:       Python 3 binding for the libxml2 and libxslt libraries
+Summary(pl.UTF-8):     Wiązanie Pythona 3 do bibliotek libxml2 i libxslt
+Group:         Libraries/Python
+
+%description -n python3-%{module}
+lxml is a Pythonic binding for the libxml2 and libxslt libraries.
+
+%description -n python3-%{module} -l pl.UTF-8
+lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
+
+%package apidocs
+Summary:       lxml API documentation
+Summary(pl.UTF-8):     Dokumentacja API modułu lxml
+Group:         Documentation
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description apidocs
+lxml API documentation.
+
+%description apidocs -l pl.UT8-8
+Dokumentacja API modułu lxml.
+
 %prep
 %setup -q -n %{module}-%{version}
-%patch0 -p1
 
 %build
-python setup.py build
+%if %{with python2}
+%py_build
+
+%if %{with tests}
+PYTHONPATH=$(pwd)/$(echo build-2/lib.linux-*) \
+%{__python} test.py
+%endif
+%endif
+
+%if %{with python3}
+%py3_build
+
+%if %{with tests}
+PYTHONPATH=$(pwd)/$(echo build-3/lib.linux-*) \
+%{__python3} test.py
+%endif
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-python setup.py install \
-       --root=$RPM_BUILD_ROOT \
-       --optimize=2
+%if %{with python2}
+%py_install
 
 %py_postclean
+%endif
+
+%if %{with python3}
+%py3_install
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc doc/* CHANGES.txt CREDITS.txt TODO.txt
+%doc CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,ZopePublicLicense,elementtree}.txt
 %dir %{py_sitedir}/lxml
 %{py_sitedir}/lxml/*.py[co]
-%attr(755,root,root) %{py_sitedir}/lxml/*.so
-%dir %{py_sitedir}/lxml/tests
-%{py_sitedir}/lxml/tests/*.py[co]
-%{py_sitedir}/lxml/tests/*.xml
+%{py_sitedir}/lxml/etree*.h
+%{py_sitedir}/lxml/lxml.etree*.h
+%{py_sitedir}/lxml/includes
+%{py_sitedir}/lxml/isoschematron
+%attr(755,root,root) %{py_sitedir}/lxml/_elementpath.so
+%attr(755,root,root) %{py_sitedir}/lxml/builder.so
+%attr(755,root,root) %{py_sitedir}/lxml/etree.so
+%attr(755,root,root) %{py_sitedir}/lxml/objectify.so
+%dir %{py_sitedir}/lxml/html
+%{py_sitedir}/lxml/html/*.py[co]
+%attr(755,root,root) %{py_sitedir}/lxml/html/clean.so
+%attr(755,root,root) %{py_sitedir}/lxml/html/diff.so
+%{py_sitedir}/lxml-%{version}-py*.egg-info
+%endif
+
+%if %{with python3}
+%files -n python3-%{module}
+%defattr(644,root,root,755)
+%doc CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,ZopePublicLicense,elementtree}.txt
+%dir %{py3_sitedir}/lxml
+%attr(755,root,root) %{py3_sitedir}/lxml/_elementpath.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/lxml/builder.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/lxml/etree.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/lxml/objectify.cpython-*.so
+%{py3_sitedir}/lxml/*.py
+%{py3_sitedir}/lxml/__pycache__
+%{py3_sitedir}/lxml/etree*.h
+%{py3_sitedir}/lxml/lxml.etree*.h
+%{py3_sitedir}/lxml/includes
+%{py3_sitedir}/lxml/isoschematron
+%dir %{py3_sitedir}/lxml/html
+%{py3_sitedir}/lxml/html/*.py
+%{py3_sitedir}/lxml/html/__pycache__
+%attr(755,root,root) %{py3_sitedir}/lxml/html/clean.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/lxml/html/diff.cpython-*.so
+%{py3_sitedir}/lxml-%{version}-py*.egg-info
+%endif
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%doc doc/html/*
+%endif
This page took 0.046908 seconds and 4 git commands to generate.