]> git.pld-linux.org Git - packages/python-lxml.git/blobdiff - python-lxml.spec
- updated to 4.2.3
[packages/python-lxml.git] / python-lxml.spec
index 148b0b476e11b248ea09bdfd0473f0782689740f..aea5c820f2cfa2a043c7c21386ecd5918852a83d 100644 (file)
@@ -1,33 +1,36 @@
 #
 # Conditional build:
-%bcond_without apidocs         # do not build and package API docs
+%bcond_without apidocs         # API documentation
 %bcond_without python2         # Python 2 package
 %bcond_without python3         # Python 3 package
+%bcond_with    tests           # unit tests (don't work without lxml not installed?)
 
 %define                module  lxml
 Summary:       Python 2 binding for the libxml2 and libxslt libraries
 Summary(pl.UTF-8):     Wiązanie Pythona 2 do bibliotek libxml2 i libxslt
 Name:          python-%{module}
-Version:       3.4.4
-Release:       2
+Version:       4.2.3
+Release:       1
 License:       BSD
 Group:         Libraries/Python
-Source0:       http://lxml.de/files/%{module}-%{version}.tgz
-# Source0-md5: a9a65972afc173ec7a39c585f4eea69c
-URL:           http://lxml.de/
-BuildRequires: libxml2-devel >= 1:2.7.8
-BuildRequires: libxslt-devel >= 1.1.26
+Source0:       https://lxml.de/files/%{module}-%{version}.tgz
+# Source0-md5: 40331e46f6aa49fd0e7043d82e58a879
+URL:           https://lxml.de/
+BuildRequires: libxml2-devel >= 1:2.9.2
+BuildRequires: libxslt-devel >= 1.1.28
 %if %{with python2}
 BuildRequires: python-devel >= 1:2.6
 BuildRequires: python-modules >= 1:2.6
+BuildRequires: python-setuptools
 %endif
 %if %{with python3}
-BuildRequires: python3-Cython > 0.17
-BuildRequires: python3-devel >= 1:3.2
-BuildRequires: python3-modules >= 1:3.2
+BuildRequires: python3-Cython >= 0.17
+BuildRequires: python3-devel >= 1:3.3
+BuildRequires: python3-modules >= 1:3.3
+BuildRequires: python3-setuptools
 %endif
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: rpmbuild(macros) >= 1.710
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -66,74 +69,81 @@ Dokumentacja API modułu lxml.
 
 %build
 %if %{with python2}
-%{__python} setup.py build
+%py_build
+
+%if %{with tests}
+PYTHONPATH=$(pwd)/$(echo build-2/lib.linux-*) \
+%{__python} test.py
+%endif
 %endif
+
 %if %{with python3}
-%{__python3} setup.py build
+%py3_build
+
+%if %{with tests}
+PYTHONPATH=$(pwd)/$(echo build-3/lib.linux-*) \
+%{__python3} test.py
+%endif
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
-%{__python} setup.py \
-       install \
-       --root=$RPM_BUILD_ROOT \
-       --optimize=2
+%py_install
 
 %py_postclean
 %endif
 
 %if %{with python3}
-%{__python3} setup.py \
-       install \
-       --root=$RPM_BUILD_ROOT \
-       --optimize=2
+%py3_install
 %endif
 
-# cleanup for packaging
-rm -rf docs
-cp -a doc docs
-# apidocs packaged separately
-rm -rf docs/html
-# build docs not useful at runtime
-rm docs/build.txt
-# common licenses
-rm docs/licenses/{BSD,GPL}.txt
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc docs/* CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt
+%doc CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,ZopePublicLicense,elementtree}.txt
 %dir %{py_sitedir}/lxml
 %{py_sitedir}/lxml/*.py[co]
+%{py_sitedir}/lxml/etree*.h
 %{py_sitedir}/lxml/lxml.etree*.h
 %{py_sitedir}/lxml/includes
 %{py_sitedir}/lxml/isoschematron
-%dir %{py_sitedir}/lxml/html
-%{py_sitedir}/lxml/html/*.py[co]
+%attr(755,root,root) %{py_sitedir}/lxml/_elementpath.so
+%attr(755,root,root) %{py_sitedir}/lxml/builder.so
 %attr(755,root,root) %{py_sitedir}/lxml/etree.so
 %attr(755,root,root) %{py_sitedir}/lxml/objectify.so
-%{py_sitedir}/lxml-*.egg-info
+%dir %{py_sitedir}/lxml/html
+%{py_sitedir}/lxml/html/*.py[co]
+%attr(755,root,root) %{py_sitedir}/lxml/html/clean.so
+%attr(755,root,root) %{py_sitedir}/lxml/html/diff.so
+%{py_sitedir}/lxml-%{version}-py*.egg-info
 %endif
 
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc docs/* CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt
+%doc CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,ZopePublicLicense,elementtree}.txt
 %dir %{py3_sitedir}/lxml
+%attr(755,root,root) %{py3_sitedir}/lxml/_elementpath.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/lxml/builder.cpython-*.so
 %attr(755,root,root) %{py3_sitedir}/lxml/etree.cpython-*.so
 %attr(755,root,root) %{py3_sitedir}/lxml/objectify.cpython-*.so
 %{py3_sitedir}/lxml/*.py
 %{py3_sitedir}/lxml/__pycache__
+%{py3_sitedir}/lxml/etree*.h
 %{py3_sitedir}/lxml/lxml.etree*.h
 %{py3_sitedir}/lxml/includes
 %{py3_sitedir}/lxml/isoschematron
-%{py3_sitedir}/lxml/html
-%{py3_sitedir}/lxml-*.egg-info
+%dir %{py3_sitedir}/lxml/html
+%{py3_sitedir}/lxml/html/*.py
+%{py3_sitedir}/lxml/html/__pycache__
+%attr(755,root,root) %{py3_sitedir}/lxml/html/clean.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/lxml/html/diff.cpython-*.so
+%{py3_sitedir}/lxml-%{version}-py*.egg-info
 %endif
 
 %if %{with apidocs}
This page took 0.093691 seconds and 4 git commands to generate.