]> git.pld-linux.org Git - packages/python-lxml.git/blobdiff - python-lxml.spec
- up to 3.3.6
[packages/python-lxml.git] / python-lxml.spec
index e7f4fb2fbc9168031fe7f20cf7b0b883e5a22a65..60cbe5b32e22cd112fa50dcd902015dc22d4e1fa 100644 (file)
@@ -1,21 +1,33 @@
 #
+# Conditional build:
+%bcond_without apidocs         # do not build and package API docs
+%bcond_without python2         # Python 2 package
+%bcond_without python3         # Python 3 package
+
 %define                module  lxml
-#
-Summary:       A Pythonic binding for the libxml2 and libxslt libraries
-Summary(pl.UTF-8):     Pythonowe wiązanie do bibliotek libxml2 i libxslt
+Summary:       Python 2 binding for the libxml2 and libxslt libraries
+Summary(pl.UTF-8):     Wiązanie Pythona 2 do bibliotek libxml2 i libxslt
 Name:          python-%{module}
-Version:       2.1.5
+Version:       3.3.6
 Release:       1
 License:       BSD
 Group:         Libraries/Python
-Source0:       http://codespeak.net/lxml/%{module}-%{version}.tgz
-# Source0-md5: 22567ccc6ab8ec8c90c335c810cabe11
-URL:           http://codespeak.net/lxml/
-BuildRequires: libxml2-devel
-BuildRequires: libxslt-devel
-BuildRequires: python-devel
+Source0:       http://lxml.de/files/%{module}-%{version}.tgz
+# Source0-md5: a804b36864c483fe7abdd7f493a0c379
+URL:           http://lxml.de/
+BuildRequires: libxml2-devel >= 1:2.7.8
+BuildRequires: libxslt-devel >= 1.1.26
+%if %{with python2}
+BuildRequires: python-devel >= 1:2.4
+BuildRequires: python-modules
+%endif
+%if %{with python3}
+BuildRequires: python3-Cython > 0.17
+BuildRequires: python3-devel
+BuildRequires: python3-modules
+%endif
+BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.219
-BuildRequires: unzip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -24,31 +36,108 @@ lxml is a Pythonic binding for the libxml2 and libxslt libraries.
 %description -l pl.UTF-8
 lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
 
+%package -n python3-%{module}
+Summary:       Python 3 binding for the libxml2 and libxslt libraries
+Summary(pl.UTF-8):     Wiązanie Pythona 3 do bibliotek libxml2 i libxslt
+Group:         Libraries/Python
+
+%description -n python3-%{module}
+lxml is a Pythonic binding for the libxml2 and libxslt libraries.
+
+%description -n python3-%{module} -l pl.UTF-8
+lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
+
+%package apidocs
+Summary:       lxml API documentation
+Summary(pl.UTF-8):     Dokumentacja API modułu lxml
+Group:         Documentation
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description apidocs
+lxml API documentation.
+
+%description apidocs -l pl.UT8-8
+Dokumentacja API modułu lxml.
+
 %prep
 %setup -q -n %{module}-%{version}
 
 %build
-python setup.py build
+%if %{with python2}
+%{__python} setup.py build
+%endif
+%if %{with python3}
+%{__python3} setup.py build
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-python setup.py install \
+%if %{with python2}
+%{__python} setup.py \
+       install \
        --root=$RPM_BUILD_ROOT \
        --optimize=2
 
 %py_postclean
+%endif
+
+%if %{with python3}
+%{__python3} setup.py \
+       install \
+       --root=$RPM_BUILD_ROOT \
+       --optimize=2
+%endif
+
+# cleanup for packaging
+rm -rf docs
+cp -a doc docs
+# apidocs packaged separately
+rm -rf docs/html
+# build docs not useful at runtime
+rm docs/build.txt
+# common licenses
+rm docs/licenses/{BSD,GPL}.txt
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc doc/* CHANGES.txt CREDITS.txt TODO.txt
+%doc docs/* CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt
 %dir %{py_sitedir}/lxml
 %{py_sitedir}/lxml/*.py[co]
+%{py_sitedir}/lxml/lxml.etree*.h
+%{py_sitedir}/lxml/includes
+%{py_sitedir}/lxml/isoschematron
 %dir %{py_sitedir}/lxml/html
 %{py_sitedir}/lxml/html/*.py[co]
 %attr(755,root,root) %{py_sitedir}/lxml/etree.so
 %attr(755,root,root) %{py_sitedir}/lxml/objectify.so
 %{py_sitedir}/lxml-*.egg-info
+%endif
+
+%if %{with python3}
+%files -n python3-%{module}
+%defattr(644,root,root,755)
+%doc docs/* CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt
+%dir %{py3_sitedir}/lxml
+%attr(755,root,root) %{py3_sitedir}/lxml/etree.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/lxml/objectify.cpython-*.so
+%{py3_sitedir}/lxml/*.py
+%{py3_sitedir}/lxml/__pycache__
+%{py3_sitedir}/lxml/lxml.etree*.h
+%{py3_sitedir}/lxml/includes
+%{py3_sitedir}/lxml/isoschematron
+%{py3_sitedir}/lxml/html
+%{py3_sitedir}/lxml-*.egg-info
+%endif
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%doc doc/html/*
+%endif
This page took 0.068044 seconds and 4 git commands to generate.