]> git.pld-linux.org Git - packages/python-lxml.git/blobdiff - python-lxml.spec
- updated to 4.9.3; force cython regeneration to fix python2 crashes
[packages/python-lxml.git] / python-lxml.spec
index e1576cb81c0a09954a22e9b3fc0d97688b20546e..1662336ae22dc6ce8891dfa2bac83046103441e7 100644 (file)
@@ -3,34 +3,39 @@
 %bcond_without apidocs         # API documentation
 %bcond_without python2         # Python 2 package
 %bcond_without python3         # Python 3 package
-%bcond_with    tests           # unit tests (don't work without lxml not installed?)
+%bcond_without tests           # unit tests
 
 %define                module  lxml
 Summary:       Python 2 binding for the libxml2 and libxslt libraries
 Summary(pl.UTF-8):     Wiązanie Pythona 2 do bibliotek libxml2 i libxslt
 Name:          python-%{module}
-Version:       4.2.5
-Release:       2
+Version:       4.9.3
+Release:       1
 License:       BSD
 Group:         Libraries/Python
-Source0:       https://lxml.de/files/%{module}-%{version}.tgz
-# Source0-md5: ce042575c4459c4994f68b9a862a72a4
+#Source0Download: https://pypi.org/simple/lxml/
+Source0:       https://files.pythonhosted.org/packages/source/l/lxml/%{module}-%{version}.tar.gz
+# Source0-md5: 7298fdca14b10e7b71547ed02b894b25
+Patch0:                lxml-Skip-failing-test-test_html_prefix_nsmap.patch
 URL:           https://lxml.de/
 BuildRequires: libxml2-devel >= 1:2.9.2
 BuildRequires: libxslt-devel >= 1.1.28
+BuildRequires: pkgconfig
 %if %{with python2}
-BuildRequires: python-devel >= 1:2.6
-BuildRequires: python-modules >= 1:2.6
+BuildRequires: python-Cython >= 0.29.36-2
+BuildRequires: python-devel >= 1:2.7
+BuildRequires: python-modules >= 1:2.7
 BuildRequires: python-setuptools
 %endif
 %if %{with python3}
-BuildRequires: python3-Cython >= 0.17
-BuildRequires: python3-devel >= 1:3.3
-BuildRequires: python3-modules >= 1:3.3
+BuildRequires: python3-Cython >= 0.29.36-2
+BuildRequires: python3-devel >= 1:3.5
+BuildRequires: python3-modules >= 1:3.5
 BuildRequires: python3-setuptools
 %endif
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.710
+BuildRequires: rpmbuild(macros) >= 1.752
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -54,9 +59,7 @@ lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
 Summary:       lxml API documentation
 Summary(pl.UTF-8):     Dokumentacja API modułu lxml
 Group:         Documentation
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description apidocs
 lxml API documentation.
@@ -66,14 +69,24 @@ Dokumentacja API modułu lxml.
 
 %prep
 %setup -q -n %{module}-%{version}
+%patch0 -p1
+
+# force cython regeneration
+%{__rm} src/lxml/{_elementpath.c,builder.c,etree.c,etree.h,etree_api.h,lxml.etree.h,lxml.etree_api.h,objectify.c,sax.c}
 
 %build
 %if %{with python2}
 %py_build
 
 %if %{with tests}
-PYTHONPATH=$(pwd)/$(echo build-2/lib.linux-*) \
-%{__python} test.py
+install -d testdir-2/src/lxml
+cd testdir-2/src/lxml
+ln -snf ../../../build-2/lib.linux-*/lxml/* ../../../src/lxml/tests .
+cd ../..
+ln -snf ../doc ../samples ../test.py .
+LC_ALL=C.UTF-8 \
+%{__python} test.py -v
+cd ..
 %endif
 %endif
 
@@ -81,9 +94,20 @@ PYTHONPATH=$(pwd)/$(echo build-2/lib.linux-*) \
 %py3_build
 
 %if %{with tests}
-PYTHONPATH=$(pwd)/$(echo build-3/lib.linux-*) \
-%{__python3} test.py
+install -d testdir-3/src/lxml
+cd testdir-3/src/lxml
+ln -snf ../../../build-3/lib.linux-*/lxml/* ../../../src/lxml/tests .
+cd ../..
+ln -snf ../doc ../samples ../test.py .
+%{__python3} test.py -v
+cd ..
+%endif
 %endif
+
+%if %{with apidocs}
+# as of 4.4.2, python3 is not supported in mkhtml.py
+PYTHONPATH=$(echo $(pwd)/build-2/lib.linux-*) \
+%{__python} doc/mkhtml.py doc/html $(pwd) %{version}
 %endif
 
 %install
@@ -105,9 +129,12 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,ZopePublicLicense,elementtree}.txt
+%doc CHANGES.txt CREDITS.txt LICENSE.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,elementtree}.txt
 %dir %{py_sitedir}/lxml
+%{py_sitedir}/lxml/*.pxi
 %{py_sitedir}/lxml/*.py[co]
+%{py_sitedir}/lxml/etree.pyx
+%{py_sitedir}/lxml/objectify.pyx
 %{py_sitedir}/lxml/etree*.h
 %{py_sitedir}/lxml/lxml.etree*.h
 %{py_sitedir}/lxml/includes
@@ -116,6 +143,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{py_sitedir}/lxml/builder.so
 %attr(755,root,root) %{py_sitedir}/lxml/etree.so
 %attr(755,root,root) %{py_sitedir}/lxml/objectify.so
+%attr(755,root,root) %{py_sitedir}/lxml/sax.so
 %dir %{py_sitedir}/lxml/html
 %{py_sitedir}/lxml/html/*.py[co]
 %attr(755,root,root) %{py_sitedir}/lxml/html/clean.so
@@ -126,14 +154,18 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,ZopePublicLicense,elementtree}.txt
+%doc CHANGES.txt CREDITS.txt LICENSE.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,elementtree}.txt
 %dir %{py3_sitedir}/lxml
 %attr(755,root,root) %{py3_sitedir}/lxml/_elementpath.cpython-*.so
 %attr(755,root,root) %{py3_sitedir}/lxml/builder.cpython-*.so
 %attr(755,root,root) %{py3_sitedir}/lxml/etree.cpython-*.so
 %attr(755,root,root) %{py3_sitedir}/lxml/objectify.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/lxml/sax.cpython-*.so
+%{py3_sitedir}/lxml/*.pxi
 %{py3_sitedir}/lxml/*.py
 %{py3_sitedir}/lxml/__pycache__
+%{py3_sitedir}/lxml/etree.pyx
+%{py3_sitedir}/lxml/objectify.pyx
 %{py3_sitedir}/lxml/etree*.h
 %{py3_sitedir}/lxml/lxml.etree*.h
 %{py3_sitedir}/lxml/includes
This page took 0.037977 seconds and 4 git commands to generate.