]> git.pld-linux.org Git - packages/python-lxml.git/blobdiff - python-lxml.spec
- updated to 4.9.1
[packages/python-lxml.git] / python-lxml.spec
index aea5c820f2cfa2a043c7c21386ecd5918852a83d..41cd1cbe61ccb934fc3a424421143986266ec422 100644 (file)
@@ -3,34 +3,37 @@
 %bcond_without apidocs         # API documentation
 %bcond_without python2         # Python 2 package
 %bcond_without python3         # Python 3 package
-%bcond_with    tests           # unit tests (don't work without lxml not installed?)
+%bcond_without tests           # unit tests
 
 %define                module  lxml
 Summary:       Python 2 binding for the libxml2 and libxslt libraries
 Summary(pl.UTF-8):     Wiązanie Pythona 2 do bibliotek libxml2 i libxslt
 Name:          python-%{module}
-Version:       4.2.3
+Version:       4.9.1
 Release:       1
 License:       BSD
 Group:         Libraries/Python
-Source0:       https://lxml.de/files/%{module}-%{version}.tgz
-# Source0-md5: 40331e46f6aa49fd0e7043d82e58a879
+#Source0Download: https://pypi.org/simple/lxml/
+Source0:       https://files.pythonhosted.org/packages/source/l/lxml/%{module}-%{version}.tar.gz
+# Source0-md5: e27240a7319d80d0c1e5390ca31eb1d8
 URL:           https://lxml.de/
 BuildRequires: libxml2-devel >= 1:2.9.2
 BuildRequires: libxslt-devel >= 1.1.28
+BuildRequires: pkgconfig
 %if %{with python2}
-BuildRequires: python-devel >= 1:2.6
-BuildRequires: python-modules >= 1:2.6
+BuildRequires: python-Cython >= 0.29.30
+BuildRequires: python-devel >= 1:2.7
+BuildRequires: python-modules >= 1:2.7
 BuildRequires: python-setuptools
 %endif
 %if %{with python3}
-BuildRequires: python3-Cython >= 0.17
-BuildRequires: python3-devel >= 1:3.3
-BuildRequires: python3-modules >= 1:3.3
+BuildRequires: python3-Cython >= 0.29.30
+BuildRequires: python3-devel >= 1:3.5
+BuildRequires: python3-modules >= 1:3.5
 BuildRequires: python3-setuptools
 %endif
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.710
+BuildRequires: rpmbuild(macros) >= 1.752
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -54,9 +57,7 @@ lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
 Summary:       lxml API documentation
 Summary(pl.UTF-8):     Dokumentacja API modułu lxml
 Group:         Documentation
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description apidocs
 lxml API documentation.
@@ -72,8 +73,14 @@ Dokumentacja API modułu lxml.
 %py_build
 
 %if %{with tests}
-PYTHONPATH=$(pwd)/$(echo build-2/lib.linux-*) \
-%{__python} test.py
+install -d testdir-2/src/lxml
+cd testdir-2/src/lxml
+ln -snf ../../../build-2/lib.linux-*/lxml/* ../../../src/lxml/tests .
+cd ../..
+ln -snf ../doc ../samples ../test.py .
+LC_ALL=C.UTF-8 \
+%{__python} test.py -v
+cd ..
 %endif
 %endif
 
@@ -81,9 +88,20 @@ PYTHONPATH=$(pwd)/$(echo build-2/lib.linux-*) \
 %py3_build
 
 %if %{with tests}
-PYTHONPATH=$(pwd)/$(echo build-3/lib.linux-*) \
-%{__python3} test.py
+install -d testdir-3/src/lxml
+cd testdir-3/src/lxml
+ln -snf ../../../build-3/lib.linux-*/lxml/* ../../../src/lxml/tests .
+cd ../..
+ln -snf ../doc ../samples ../test.py .
+%{__python3} test.py -v
+cd ..
+%endif
 %endif
+
+%if %{with apidocs}
+# as of 4.4.2, python3 is not supported in mkhtml.py
+PYTHONPATH=$(echo $(pwd)/build-2/lib.linux-*) \
+%{__python} doc/mkhtml.py doc/html $(pwd) %{version}
 %endif
 
 %install
@@ -105,7 +123,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,ZopePublicLicense,elementtree}.txt
+%doc CHANGES.txt CREDITS.txt LICENSE.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,elementtree}.txt
 %dir %{py_sitedir}/lxml
 %{py_sitedir}/lxml/*.py[co]
 %{py_sitedir}/lxml/etree*.h
@@ -116,6 +134,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{py_sitedir}/lxml/builder.so
 %attr(755,root,root) %{py_sitedir}/lxml/etree.so
 %attr(755,root,root) %{py_sitedir}/lxml/objectify.so
+%attr(755,root,root) %{py_sitedir}/lxml/sax.so
 %dir %{py_sitedir}/lxml/html
 %{py_sitedir}/lxml/html/*.py[co]
 %attr(755,root,root) %{py_sitedir}/lxml/html/clean.so
@@ -126,12 +145,13 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,ZopePublicLicense,elementtree}.txt
+%doc CHANGES.txt CREDITS.txt LICENSE.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,elementtree}.txt
 %dir %{py3_sitedir}/lxml
 %attr(755,root,root) %{py3_sitedir}/lxml/_elementpath.cpython-*.so
 %attr(755,root,root) %{py3_sitedir}/lxml/builder.cpython-*.so
 %attr(755,root,root) %{py3_sitedir}/lxml/etree.cpython-*.so
 %attr(755,root,root) %{py3_sitedir}/lxml/objectify.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/lxml/sax.cpython-*.so
 %{py3_sitedir}/lxml/*.py
 %{py3_sitedir}/lxml/__pycache__
 %{py3_sitedir}/lxml/etree*.h
This page took 0.07193 seconds and 4 git commands to generate.