]> git.pld-linux.org Git - packages/python-lxml.git/blobdiff - python-lxml.spec
- up to 3.4.0
[packages/python-lxml.git] / python-lxml.spec
index 3160c19a11cce4dd54b3f90ef620f24102020a6b..1ddb54d31f72f9173991354e4aa36347063b52a8 100644 (file)
@@ -1,27 +1,28 @@
 #
-%bcond_without python3
-%bcond_without python2
+# Conditional build:
+%bcond_without apidocs         # do not build and package API docs
+%bcond_without python2         # Python 2 package
+%bcond_without python3         # Python 3 package
+
 %define                module  lxml
-#
-Summary:       A Pythonic binding for the libxml2 and libxslt libraries
-Summary(pl.UTF-8):     Pythonowe wiązanie do bibliotek libxml2 i libxslt
+Summary:       Python 2 binding for the libxml2 and libxslt libraries
+Summary(pl.UTF-8):     Wiązanie Pythona 2 do bibliotek libxml2 i libxslt
 Name:          python-%{module}
-Version:       2.2.7
+Version:       3.4.0
 Release:       1
 License:       BSD
 Group:         Libraries/Python
-Source0:       http://codespeak.net/lxml/%{module}-%{version}.tgz
-# Source0-md5: c1da56b823fdc00804938d2b788dbfd0
-Patch0:                python3.patch
-URL:           http://codespeak.net/lxml/
-BuildRequires: libxml2-devel
-BuildRequires: libxslt-devel
+Source0:       http://lxml.de/files/%{module}-%{version}.tgz
+# Source0-md5: bc90cc4e4ee04e1f8290ae0f70e34eea
+URL:           http://lxml.de/
+BuildRequires: libxml2-devel >= 1:2.7.8
+BuildRequires: libxslt-devel >= 1.1.26
 %if %{with python2}
-BuildRequires: python-devel
+BuildRequires: python-devel >= 1:2.4
 BuildRequires: python-modules
 %endif
 %if %{with python3}
-BuildRequires: python3-Cython
+BuildRequires: python3-Cython > 0.17
 BuildRequires: python3-devel
 BuildRequires: python3-modules
 %endif
@@ -35,11 +36,9 @@ lxml is a Pythonic binding for the libxml2 and libxslt libraries.
 %description -l pl.UTF-8
 lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
 
-%package -n    python3-%{module}
-Summary:       A Pythonic binding for the libxml2 and libxslt libraries
-Summary(pl.UTF-8):     Pythonowe wiązanie do bibliotek libxml2 i libxslt
-Version:       %{version}
-Release:       %{release}
+%package -n python3-%{module}
+Summary:       Python 3 binding for the libxml2 and libxslt libraries
+Summary(pl.UTF-8):     Wiązanie Pythona 3 do bibliotek libxml2 i libxslt
 Group:         Libraries/Python
 
 %description -n python3-%{module}
@@ -48,9 +47,22 @@ lxml is a Pythonic binding for the libxml2 and libxslt libraries.
 %description -n python3-%{module} -l pl.UTF-8
 lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
 
+%package apidocs
+Summary:       lxml API documentation
+Summary(pl.UTF-8):     Dokumentacja API modułu lxml
+Group:         Documentation
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description apidocs
+lxml API documentation.
+
+%description apidocs -l pl.UT8-8
+Dokumentacja API modułu lxml.
+
 %prep
 %setup -q -n %{module}-%{version}
-%patch0 -p1
 
 %build
 %if %{with python2}
@@ -77,19 +89,30 @@ rm -rf $RPM_BUILD_ROOT
        install \
        --root=$RPM_BUILD_ROOT \
        --optimize=2
-
-%py3_postclean
 %endif
 
+# cleanup for packaging
+rm -rf docs
+cp -a doc docs
+# apidocs packaged separately
+rm -rf docs/html
+# build docs not useful at runtime
+rm docs/build.txt
+# common licenses
+rm docs/licenses/{BSD,GPL}.txt
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc doc/* CHANGES.txt CREDITS.txt TODO.txt
+%doc docs/* CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt
 %dir %{py_sitedir}/lxml
 %{py_sitedir}/lxml/*.py[co]
+%{py_sitedir}/lxml/lxml.etree*.h
+%{py_sitedir}/lxml/includes
+%{py_sitedir}/lxml/isoschematron
 %dir %{py_sitedir}/lxml/html
 %{py_sitedir}/lxml/html/*.py[co]
 %attr(755,root,root) %{py_sitedir}/lxml/etree.so
@@ -100,12 +123,21 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc doc/* CHANGES.txt CREDITS.txt TODO.txt
+%doc docs/* CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt
 %dir %{py3_sitedir}/lxml
-%{py3_sitedir}/lxml/*.py[co]
-%dir %{py3_sitedir}/lxml/html
-%{py3_sitedir}/lxml/html/*.py[co]
-%attr(755,root,root) %{py3_sitedir}/lxml/etree.so
-%attr(755,root,root) %{py3_sitedir}/lxml/objectify.so
+%attr(755,root,root) %{py3_sitedir}/lxml/etree.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/lxml/objectify.cpython-*.so
+%{py3_sitedir}/lxml/*.py
+%{py3_sitedir}/lxml/__pycache__
+%{py3_sitedir}/lxml/lxml.etree*.h
+%{py3_sitedir}/lxml/includes
+%{py3_sitedir}/lxml/isoschematron
+%{py3_sitedir}/lxml/html
 %{py3_sitedir}/lxml-*.egg-info
 %endif
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%doc doc/html/*
+%endif
This page took 0.02979 seconds and 4 git commands to generate.