]> git.pld-linux.org Git - packages/python-lxml.git/blob - python-lxml.spec
- and final version
[packages/python-lxml.git] / python-lxml.spec
1 #
2 %define         module  lxml
3 #
4 Summary:        A Pythonic binding for the libxml2 and libxslt libraries
5 Name:           python-%{module}
6 Version:        0.8
7 Release:        1
8 License:        BSD
9 Group:          Development/Languages/Python
10 Source0:        http://codespeak.net/lxml/%{module}-%{version}.tgz
11 # Source0-md5:  b156da08fea2af7b34774d5f9c4fa206
12 Patch0:         %{name}-path.patch
13 URL:            http://codespeak.net/lxml/
14 BuildRequires:  libxml2-devel
15 BuildRequires:  libxslt-devel
16 BuildRequires:  python-Pyrex
17 BuildRequires:  python-devel
18 BuildRequires:  rpmbuild(macros) >= 1.219
19 BuildRequires:  unzip
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 lxml is a Pythonic binding for the libxml2 and libxslt libraries.
24
25 %prep
26 %setup -q -n %{module}-%{version}
27 %patch0 -p1
28
29 %build
30 python setup.py build
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35 python setup.py install \
36         --root=$RPM_BUILD_ROOT \
37         --optimize=2
38
39 %py_postclean
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc doc/* CHANGES.txt CREDITS.txt TODO.txt
47 %dir %{py_sitedir}/lxml
48 %{py_sitedir}/lxml/*.py[co]
49 %attr(755,root,root) %{py_sitedir}/lxml/*.so
50 %dir %{py_sitedir}/lxml/tests
51 %{py_sitedir}/lxml/tests/*.py[co]
52 %{py_sitedir}/lxml/tests/*.xml
This page took 0.055341 seconds and 4 git commands to generate.