]> git.pld-linux.org Git - packages/python-lxml.git/blob - python-lxml.spec
e4f485611ef6c3e47265f3fe4720f9d7cdaca430
[packages/python-lxml.git] / python-lxml.spec
1 #
2 %define         module  lxml
3 #
4 Summary:        A Pythonic binding for the libxml2 and libxslt libraries
5 Name:           python-%{module}
6 Version:        0.8
7 Release:        0.1
8 License:        BSD
9 Group:          Development/Languages/Python
10 Source0:        http://codespeak.net/lxml/%{module}-%{version}.tgz
11 # Source0-md5:  b156da08fea2af7b34774d5f9c4fa206
12 URL:            http://codespeak.net/lxml/
13 BuildRequires:  python
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 BuildRequires:  unzip
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 lxml is a Pythonic binding for the libxml2 and libxslt libraries.
20
21 %prep
22 %setup -q -n %{module}-%{version}
23
24 %build
25 python setup.py build
26
27 %install
28 rm -rf $RPM_BUILD_ROOT
29 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
30 install -d $RPM_BUILD_ROOT%{py_sitescriptdir}/ElementTree-%{version}-py%{py_ver}.egg-info
31
32 python setup.py install \
33         --root=$RPM_BUILD_ROOT \
34         --optimize=2
35
36 %py_postclean
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(644,root,root,755)
43 %doc doc/* CHANGES.txt CREDITS.txt TODO.txt
44 %{py_sitescriptdir}/%{module}
45 %{py_sitescriptdir}/ElementTree*
This page took 0.027337 seconds and 2 git commands to generate.