]> git.pld-linux.org Git - packages/python-lxml.git/blob - python-lxml.spec
876643ea3f0292819c659de0c9d774a871ee9d0b
[packages/python-lxml.git] / python-lxml.spec
1 #
2 %define         module  lxml
3 #
4 Summary:        A Pythonic binding for the libxml2 and libxslt libraries
5 Summary(pl.UTF-8):      Pythonowe wiązanie do bibliotek libxml2 i libxslt
6 Name:           python-%{module}
7 Version:        2.2.4
8 Release:        1
9 License:        BSD
10 Group:          Libraries/Python
11 Source0:        http://codespeak.net/lxml/%{module}-%{version}.tgz
12 # Source0-md5:  077841e74ee728e7746b65d8483274be
13 URL:            http://codespeak.net/lxml/
14 BuildRequires:  libxml2-devel
15 BuildRequires:  libxslt-devel
16 BuildRequires:  python-devel
17 BuildRequires:  python-modules
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.219
20 BuildRequires:  unzip
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 lxml is a Pythonic binding for the libxml2 and libxslt libraries.
25
26 %description -l pl.UTF-8
27 lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
28
29 %prep
30 %setup -q -n %{module}-%{version}
31
32 %build
33 python setup.py build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37
38 python setup.py install \
39         --root=$RPM_BUILD_ROOT \
40         --optimize=2
41
42 %py_postclean
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc doc/* CHANGES.txt CREDITS.txt TODO.txt
50 %dir %{py_sitedir}/lxml
51 %{py_sitedir}/lxml/*.py[co]
52 %dir %{py_sitedir}/lxml/html
53 %{py_sitedir}/lxml/html/*.py[co]
54 %attr(755,root,root) %{py_sitedir}/lxml/etree.so
55 %attr(755,root,root) %{py_sitedir}/lxml/objectify.so
56 %{py_sitedir}/lxml-*.egg-info
This page took 0.019133 seconds and 2 git commands to generate.