]> git.pld-linux.org Git - packages/python-lxml.git/blob - python-lxml.spec
5801c98d98dc0cfcf68950fe32e3cf781ce975cf
[packages/python-lxml.git] / python-lxml.spec
1 #
2 %define         module  lxml
3 #
4 Summary:        A Pythonic binding for the libxml2 and libxslt libraries
5 Summary(pl.UTF-8):      Pythonowe wiązanie do bibliotek libxml2 i libxslt
6 Name:           python-%{module}
7 Version:        0.8
8 Release:        2
9 License:        BSD
10 Group:          Development/Languages/Python
11 Source0:        http://codespeak.net/lxml/%{module}-%{version}.tgz
12 # Source0-md5:  b156da08fea2af7b34774d5f9c4fa206
13 Patch0:         %{name}-path.patch
14 URL:            http://codespeak.net/lxml/
15 BuildRequires:  libxml2-devel
16 BuildRequires:  libxslt-devel
17 BuildRequires:  python-Pyrex >= 0.9.4.2
18 BuildRequires:  python-devel
19 BuildRequires:  rpmbuild(macros) >= 1.219
20 BuildRequires:  unzip
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 lxml is a Pythonic binding for the libxml2 and libxslt libraries.
25
26 %description -l pl.UTF-8
27 lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
28
29 %prep
30 %setup -q -n %{module}-%{version}
31 %patch0 -p1
32
33 %build
34 python setup.py build
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 python setup.py install \
40         --root=$RPM_BUILD_ROOT \
41         --optimize=2
42
43 %py_postclean
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc doc/* CHANGES.txt CREDITS.txt TODO.txt
51 %dir %{py_sitedir}/lxml
52 %{py_sitedir}/lxml/*.py[co]
53 %attr(755,root,root) %{py_sitedir}/lxml/*.so
54 %dir %{py_sitedir}/lxml/tests
55 %{py_sitedir}/lxml/tests/*.py[co]
56 %{py_sitedir}/lxml/tests/*.xml
This page took 0.021821 seconds and 3 git commands to generate.