]> git.pld-linux.org Git - packages/python-lxml.git/blob - python-lxml.spec
- updated to 4.9.1
[packages/python-lxml.git] / python-lxml.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  python2         # Python 2 package
5 %bcond_without  python3         # Python 3 package
6 %bcond_without  tests           # unit tests
7
8 %define         module  lxml
9 Summary:        Python 2 binding for the libxml2 and libxslt libraries
10 Summary(pl.UTF-8):      Wiązanie Pythona 2 do bibliotek libxml2 i libxslt
11 Name:           python-%{module}
12 Version:        4.9.1
13 Release:        1
14 License:        BSD
15 Group:          Libraries/Python
16 #Source0Download: https://pypi.org/simple/lxml/
17 Source0:        https://files.pythonhosted.org/packages/source/l/lxml/%{module}-%{version}.tar.gz
18 # Source0-md5:  e27240a7319d80d0c1e5390ca31eb1d8
19 URL:            https://lxml.de/
20 BuildRequires:  libxml2-devel >= 1:2.9.2
21 BuildRequires:  libxslt-devel >= 1.1.28
22 BuildRequires:  pkgconfig
23 %if %{with python2}
24 BuildRequires:  python-Cython >= 0.29.30
25 BuildRequires:  python-devel >= 1:2.7
26 BuildRequires:  python-modules >= 1:2.7
27 BuildRequires:  python-setuptools
28 %endif
29 %if %{with python3}
30 BuildRequires:  python3-Cython >= 0.29.30
31 BuildRequires:  python3-devel >= 1:3.5
32 BuildRequires:  python3-modules >= 1:3.5
33 BuildRequires:  python3-setuptools
34 %endif
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.752
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 lxml is a Pythonic binding for the libxml2 and libxslt libraries.
41
42 %description -l pl.UTF-8
43 lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
44
45 %package -n python3-%{module}
46 Summary:        Python 3 binding for the libxml2 and libxslt libraries
47 Summary(pl.UTF-8):      Wiązanie Pythona 3 do bibliotek libxml2 i libxslt
48 Group:          Libraries/Python
49
50 %description -n python3-%{module}
51 lxml is a Pythonic binding for the libxml2 and libxslt libraries.
52
53 %description -n python3-%{module} -l pl.UTF-8
54 lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
55
56 %package apidocs
57 Summary:        lxml API documentation
58 Summary(pl.UTF-8):      Dokumentacja API modułu lxml
59 Group:          Documentation
60 BuildArch:      noarch
61
62 %description apidocs
63 lxml API documentation.
64
65 %description apidocs -l pl.UT8-8
66 Dokumentacja API modułu lxml.
67
68 %prep
69 %setup -q -n %{module}-%{version}
70
71 %build
72 %if %{with python2}
73 %py_build
74
75 %if %{with tests}
76 install -d testdir-2/src/lxml
77 cd testdir-2/src/lxml
78 ln -snf ../../../build-2/lib.linux-*/lxml/* ../../../src/lxml/tests .
79 cd ../..
80 ln -snf ../doc ../samples ../test.py .
81 LC_ALL=C.UTF-8 \
82 %{__python} test.py -v
83 cd ..
84 %endif
85 %endif
86
87 %if %{with python3}
88 %py3_build
89
90 %if %{with tests}
91 install -d testdir-3/src/lxml
92 cd testdir-3/src/lxml
93 ln -snf ../../../build-3/lib.linux-*/lxml/* ../../../src/lxml/tests .
94 cd ../..
95 ln -snf ../doc ../samples ../test.py .
96 %{__python3} test.py -v
97 cd ..
98 %endif
99 %endif
100
101 %if %{with apidocs}
102 # as of 4.4.2, python3 is not supported in mkhtml.py
103 PYTHONPATH=$(echo $(pwd)/build-2/lib.linux-*) \
104 %{__python} doc/mkhtml.py doc/html $(pwd) %{version}
105 %endif
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %if %{with python2}
111 %py_install
112
113 %py_postclean
114 %endif
115
116 %if %{with python3}
117 %py3_install
118 %endif
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %if %{with python2}
124 %files
125 %defattr(644,root,root,755)
126 %doc CHANGES.txt CREDITS.txt LICENSE.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,elementtree}.txt
127 %dir %{py_sitedir}/lxml
128 %{py_sitedir}/lxml/*.py[co]
129 %{py_sitedir}/lxml/etree*.h
130 %{py_sitedir}/lxml/lxml.etree*.h
131 %{py_sitedir}/lxml/includes
132 %{py_sitedir}/lxml/isoschematron
133 %attr(755,root,root) %{py_sitedir}/lxml/_elementpath.so
134 %attr(755,root,root) %{py_sitedir}/lxml/builder.so
135 %attr(755,root,root) %{py_sitedir}/lxml/etree.so
136 %attr(755,root,root) %{py_sitedir}/lxml/objectify.so
137 %attr(755,root,root) %{py_sitedir}/lxml/sax.so
138 %dir %{py_sitedir}/lxml/html
139 %{py_sitedir}/lxml/html/*.py[co]
140 %attr(755,root,root) %{py_sitedir}/lxml/html/clean.so
141 %attr(755,root,root) %{py_sitedir}/lxml/html/diff.so
142 %{py_sitedir}/lxml-%{version}-py*.egg-info
143 %endif
144
145 %if %{with python3}
146 %files -n python3-%{module}
147 %defattr(644,root,root,755)
148 %doc CHANGES.txt CREDITS.txt LICENSE.txt LICENSES.txt README.rst TODO.txt doc/licenses/{BSD,elementtree}.txt
149 %dir %{py3_sitedir}/lxml
150 %attr(755,root,root) %{py3_sitedir}/lxml/_elementpath.cpython-*.so
151 %attr(755,root,root) %{py3_sitedir}/lxml/builder.cpython-*.so
152 %attr(755,root,root) %{py3_sitedir}/lxml/etree.cpython-*.so
153 %attr(755,root,root) %{py3_sitedir}/lxml/objectify.cpython-*.so
154 %attr(755,root,root) %{py3_sitedir}/lxml/sax.cpython-*.so
155 %{py3_sitedir}/lxml/*.py
156 %{py3_sitedir}/lxml/__pycache__
157 %{py3_sitedir}/lxml/etree*.h
158 %{py3_sitedir}/lxml/lxml.etree*.h
159 %{py3_sitedir}/lxml/includes
160 %{py3_sitedir}/lxml/isoschematron
161 %dir %{py3_sitedir}/lxml/html
162 %{py3_sitedir}/lxml/html/*.py
163 %{py3_sitedir}/lxml/html/__pycache__
164 %attr(755,root,root) %{py3_sitedir}/lxml/html/clean.cpython-*.so
165 %attr(755,root,root) %{py3_sitedir}/lxml/html/diff.cpython-*.so
166 %{py3_sitedir}/lxml-%{version}-py*.egg-info
167 %endif
168
169 %if %{with apidocs}
170 %files apidocs
171 %defattr(644,root,root,755)
172 %doc doc/html/*
173 %endif
This page took 0.079943 seconds and 3 git commands to generate.