]> git.pld-linux.org Git - packages/python-lxml.git/blob - python-lxml.spec
- ver. 2.1.5
[packages/python-lxml.git] / python-lxml.spec
1 #
2 %define         module  lxml
3 #
4 Summary:        A Pythonic binding for the libxml2 and libxslt libraries
5 Summary(pl.UTF-8):      Pythonowe wiązanie do bibliotek libxml2 i libxslt
6 Name:           python-%{module}
7 Version:        2.1.5
8 Release:        1
9 License:        BSD
10 Group:          Development/Languages/Python
11 Source0:        http://codespeak.net/lxml/%{module}-%{version}.tgz
12 # Source0-md5:  22567ccc6ab8ec8c90c335c810cabe11
13 URL:            http://codespeak.net/lxml/
14 BuildRequires:  libxml2-devel
15 BuildRequires:  libxslt-devel
16 BuildRequires:  python-devel
17 BuildRequires:  rpmbuild(macros) >= 1.219
18 BuildRequires:  unzip
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 lxml is a Pythonic binding for the libxml2 and libxslt libraries.
23
24 %description -l pl.UTF-8
25 lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
26
27 %prep
28 %setup -q -n %{module}-%{version}
29
30 %build
31 python setup.py build
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35
36 python setup.py install \
37         --root=$RPM_BUILD_ROOT \
38         --optimize=2
39
40 %py_postclean
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc doc/* CHANGES.txt CREDITS.txt TODO.txt
48 %dir %{py_sitedir}/lxml
49 %{py_sitedir}/lxml/*.py[co]
50 %dir %{py_sitedir}/lxml/html
51 %{py_sitedir}/lxml/html/*.py[co]
52 %attr(755,root,root) %{py_sitedir}/lxml/etree.so
53 %attr(755,root,root) %{py_sitedir}/lxml/objectify.so
54 %{py_sitedir}/lxml-*.egg-info
This page took 0.032612 seconds and 3 git commands to generate.