]> git.pld-linux.org Git - packages/python-lxml.git/blame_incremental - python-lxml.spec
noarch apidocs
[packages/python-lxml.git] / python-lxml.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4%bcond_without python2 # Python 2 package
5%bcond_without python3 # Python 3 package
6
7%define module lxml
8Summary: Python 2 binding for the libxml2 and libxslt libraries
9Summary(pl.UTF-8): Wiązanie Pythona 2 do bibliotek libxml2 i libxslt
10Name: python-%{module}
11Version: 3.3.3
12Release: 2
13License: BSD
14Group: Libraries/Python
15Source0: http://lxml.de/files/%{module}-%{version}.tgz
16# Source0-md5: f2675837b4358a5ecab5fd9a783fd0e5
17URL: http://lxml.de/
18BuildRequires: libxml2-devel >= 1:2.7.8
19BuildRequires: libxslt-devel >= 1.1.26
20%if %{with python2}
21BuildRequires: python-devel >= 1:2.4
22BuildRequires: python-modules
23%endif
24%if %{with python3}
25BuildRequires: python3-Cython > 0.17
26BuildRequires: python3-devel
27BuildRequires: python3-modules
28%endif
29BuildRequires: rpm-pythonprov
30BuildRequires: rpmbuild(macros) >= 1.219
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34lxml is a Pythonic binding for the libxml2 and libxslt libraries.
35
36%description -l pl.UTF-8
37lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
38
39%package -n python3-%{module}
40Summary: Python 3 binding for the libxml2 and libxslt libraries
41Summary(pl.UTF-8): Wiązanie Pythona 3 do bibliotek libxml2 i libxslt
42Group: Libraries/Python
43
44%description -n python3-%{module}
45lxml is a Pythonic binding for the libxml2 and libxslt libraries.
46
47%description -n python3-%{module} -l pl.UTF-8
48lxml to pythonowe wiązanie do bibliotek libxml2 i libxslt.
49
50%package apidocs
51Summary: lxml API documentation
52Summary(pl.UTF-8): Dokumentacja API modułu lxml
53Group: Documentation
54%if "%{_rpmversion}" >= "5"
55BuildArch: noarch
56%endif
57
58%description apidocs
59lxml API documentation.
60
61%description apidocs -l pl.UT8-8
62Dokumentacja API modułu lxml.
63
64%prep
65%setup -q -n %{module}-%{version}
66
67%build
68%if %{with python2}
69%{__python} setup.py build
70%endif
71%if %{with python3}
72%{__python3} setup.py build
73%endif
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78%if %{with python2}
79%{__python} setup.py \
80 install \
81 --root=$RPM_BUILD_ROOT \
82 --optimize=2
83
84%py_postclean
85%endif
86
87%if %{with python3}
88%{__python3} setup.py \
89 install \
90 --root=$RPM_BUILD_ROOT \
91 --optimize=2
92%endif
93
94# cleanup for packaging
95rm -rf docs
96cp -a doc docs
97# apidocs packaged separately
98rm -rf docs/html
99# build docs not useful at runtime
100rm docs/build.txt
101# common licenses
102rm docs/licenses/{BSD,GPL}.txt
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%if %{with python2}
108%files
109%defattr(644,root,root,755)
110%doc docs/* CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt
111%dir %{py_sitedir}/lxml
112%{py_sitedir}/lxml/*.py[co]
113%{py_sitedir}/lxml/lxml.etree*.h
114%{py_sitedir}/lxml/includes
115%{py_sitedir}/lxml/isoschematron
116%dir %{py_sitedir}/lxml/html
117%{py_sitedir}/lxml/html/*.py[co]
118%attr(755,root,root) %{py_sitedir}/lxml/etree.so
119%attr(755,root,root) %{py_sitedir}/lxml/objectify.so
120%{py_sitedir}/lxml-*.egg-info
121%endif
122
123%if %{with python3}
124%files -n python3-%{module}
125%defattr(644,root,root,755)
126%doc docs/* CHANGES.txt CREDITS.txt LICENSES.txt README.rst TODO.txt
127%dir %{py3_sitedir}/lxml
128%attr(755,root,root) %{py3_sitedir}/lxml/etree.cpython-*.so
129%attr(755,root,root) %{py3_sitedir}/lxml/objectify.cpython-*.so
130%{py3_sitedir}/lxml/*.py
131%{py3_sitedir}/lxml/__pycache__
132%{py3_sitedir}/lxml/lxml.etree*.h
133%{py3_sitedir}/lxml/includes
134%{py3_sitedir}/lxml/isoschematron
135%{py3_sitedir}/lxml/html
136%{py3_sitedir}/lxml-*.egg-info
137%endif
138
139%if %{with apidocs}
140%files apidocs
141%defattr(644,root,root,755)
142%doc doc/html/*
143%endif
This page took 0.07397 seconds and 4 git commands to generate.