]> git.pld-linux.org Git - packages/python-lxml.git/blame_incremental - python-lxml.spec
- and final version
[packages/python-lxml.git] / python-lxml.spec
... / ...
CommitLineData
1#
2%define module lxml
3#
4Summary: A Pythonic binding for the libxml2 and libxslt libraries
5Name: python-%{module}
6Version: 0.8
7Release: 1
8License: BSD
9Group: Development/Languages/Python
10Source0: http://codespeak.net/lxml/%{module}-%{version}.tgz
11# Source0-md5: b156da08fea2af7b34774d5f9c4fa206
12Patch0: %{name}-path.patch
13URL: http://codespeak.net/lxml/
14BuildRequires: libxml2-devel
15BuildRequires: libxslt-devel
16BuildRequires: python-Pyrex
17BuildRequires: python-devel
18BuildRequires: rpmbuild(macros) >= 1.219
19BuildRequires: unzip
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23lxml is a Pythonic binding for the libxml2 and libxslt libraries.
24
25%prep
26%setup -q -n %{module}-%{version}
27%patch0 -p1
28
29%build
30python setup.py build
31
32%install
33rm -rf $RPM_BUILD_ROOT
34
35python setup.py install \
36 --root=$RPM_BUILD_ROOT \
37 --optimize=2
38
39%py_postclean
40
41%clean
42rm -rf $RPM_BUILD_ROOT
43
44%files
45%defattr(644,root,root,755)
46%doc doc/* CHANGES.txt CREDITS.txt TODO.txt
47%dir %{py_sitedir}/lxml
48%{py_sitedir}/lxml/*.py[co]
49%attr(755,root,root) %{py_sitedir}/lxml/*.so
50%dir %{py_sitedir}/lxml/tests
51%{py_sitedir}/lxml/tests/*.py[co]
52%{py_sitedir}/lxml/tests/*.xml
This page took 0.026454 seconds and 4 git commands to generate.