]> git.pld-linux.org Git - packages/python-lxml.git/blame - python-lxml.spec
- build paths
[packages/python-lxml.git] / python-lxml.spec
CommitLineData
7321ac76
AM
1#
2%define module lxml
3#
4Summary: A Pythonic binding for the libxml2 and libxslt libraries
5Name: python-%{module}
6Version: 0.8
7Release: 0.1
8License: BSD
9Group: Development/Languages/Python
10Source0: http://codespeak.net/lxml/%{module}-%{version}.tgz
11# Source0-md5: b156da08fea2af7b34774d5f9c4fa206
12URL: http://codespeak.net/lxml/
13BuildRequires: python
14BuildRequires: rpmbuild(macros) >= 1.219
15BuildRequires: unzip
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%description
19lxml is a Pythonic binding for the libxml2 and libxslt libraries.
20
21%prep
22%setup -q -n %{module}-%{version}
23
24%build
25python setup.py build
26
27%install
28rm -rf $RPM_BUILD_ROOT
29install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
30install -d $RPM_BUILD_ROOT%{py_sitescriptdir}/ElementTree-%{version}-py%{py_ver}.egg-info
31
32python setup.py install \
33 --root=$RPM_BUILD_ROOT \
34 --optimize=2
35
36%py_postclean
37
38%clean
39rm -rf $RPM_BUILD_ROOT
40
41%files
42%defattr(644,root,root,755)
43%doc doc/* CHANGES.txt CREDITS.txt TODO.txt
44%{py_sitescriptdir}/%{module}
45%{py_sitescriptdir}/ElementTree*
This page took 0.049922 seconds and 4 git commands to generate.