]> git.pld-linux.org Git - packages/python-linux-procfs.git/blame - python-linux-procfs.spec
- remove py2 binary to fix build inconsistencies
[packages/python-linux-procfs.git] / python-linux-procfs.spec
CommitLineData
41e94907
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Linux /proc abstraction classes for Python 2
7Summary(pl.UTF-8): Klasy abstrakcji linuksowego /proc dla Pythona 2
8Name: python-linux-procfs
a73ee581 9Version: 0.6
7e13eda1 10Release: 3
41e94907
JB
11License: GPL v2
12Group: Libraries/Python
13Source0: https://www.kernel.org/pub/software/libs/python/python-linux-procfs/%{name}-%{version}.tar.xz
a73ee581 14# Source0-md5: 039761a2abc01d92429b9df4636344b0
41e94907
JB
15URL: https://rt.wiki.kernel.org/index.php/Tuna
16BuildRequires: python-modules >= 2
17BuildRequires: rpm-pythonprov
73546f65 18BuildRequires: rpmbuild(macros) >= 1.714
41e94907
JB
19%if %{with python3}
20BuildRequires: python3-modules >= 1:3.2
21%endif
22BuildRequires: tar >= 1:1.22
23BuildRequires: xz
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28Python 2 abstractions to extract information from the Linux kernel
29/proc files.
30
31%description -l pl.UTF-8
32Abstrakcje Pythona 2 do wydobywania informacji z plików /proc jądra
33Linuksa.
34
35%package -n python3-linux-procfs
36Summary: Linux /proc abstraction classes for Python 3
37Summary(pl.UTF-8): Klasy abstrakcji linuksowego /proc dla Pythona 3
38Group: Libraries/Python
39
40%description -n python3-linux-procfs
41Python 3 abstractions to extract information from the Linux kernel
42/proc files.
43
44%description -n python3-linux-procfs -l pl.UTF-8
45Abstrakcje Pythona 3 do wydobywania informacji z plików /proc jądra
46Linuksa.
47
48%prep
49%setup -q
50
51%build
52%if %{with python2}
8a7c0aa5 53%py_build
41e94907
JB
54%endif
55
56%if %{with python3}
8a7c0aa5 57%py3_build
41e94907
JB
58%endif
59
60%install
61rm -rf $RPM_BUILD_ROOT
41e94907
JB
62
63%if %{with python2}
8a7c0aa5 64%py_install
41e94907
JB
65
66%py_postclean
67%endif
68
69%if %{with python3}
7e13eda1
JR
70# Make sure python2 script is removed
71%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/pflags
8a7c0aa5 72%py3_install
41e94907
JB
73%endif
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%if %{with python2}
79%files
80%defattr(644,root,root,755)
1f45ad27
JB
81%if %{without python3}
82%attr(755,root,root) %{_bindir}/pflags
83%endif
41e94907
JB
84%{py_sitescriptdir}/procfs
85%if "%{py_ver}" > "2.4"
1f45ad27 86%{py_sitescriptdir}/python_linux_procfs-%{version}-py*.egg-info
41e94907
JB
87%endif
88%endif
89
90%if %{with python3}
91%files -n python3-linux-procfs
92%defattr(644,root,root,755)
a73ee581 93%attr(755,root,root) %{_bindir}/pflags
41e94907 94%{py3_sitescriptdir}/procfs
1f45ad27 95%{py3_sitescriptdir}/python_linux_procfs-%{version}-py*.egg-info
41e94907 96%endif
This page took 0.358528 seconds and 4 git commands to generate.