]> git.pld-linux.org Git - packages/python-line_profiler.git/blob - python-line_profiler.spec
Release 11 (by relup.sh)
[packages/python-line_profiler.git] / python-line_profiler.spec
1 #
2 # Conditional build:
3 %bcond_with     doc             # don't build doc (not provided by package)
4 %bcond_without  tests   # do not perform "make test"
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module  line_profiler
9 Summary:        module for doing line-by-line profiling of functions
10 Summary(pl.UTF-8):      Moduł do optymalizacji linia po linii kodu funkcji
11 # Name must match the python module/package name (as in 'import' statement)
12 Name:           python-%{module}
13 Version:        2.1
14 Release:        11
15 License:        BSD
16 Group:          Libraries/Python
17 Source0:        https://github.com/rkern/line_profiler/archive/%{version}.tar.gz
18 # Source0-md5:  bd1cb2ba21af02339beab7ddc3a69c66
19 URL:            https://github.com/rkern/line_profiler
20 BuildRequires:  rpmbuild(macros) >= 1.710
21 BuildRequires:  rpm-pythonprov
22 %if %{with python2}
23 BuildRequires:  python-Cython
24 BuildRequires:  python-devel
25 BuildRequires:  python-distribute
26 BuildRequires:  python-ipython
27 BuildRequires:  python-prompt_toolkit
28 %endif
29 %if %{with python3}
30 BuildRequires:  python3-Cython
31 BuildRequires:  python3-devel
32 BuildRequires:  python3-ipython
33 BuildRequires:  python3-modules
34 BuildRequires:  python3-prompt_toolkit
35 %endif
36 Requires:       python-modules
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 line_profiler will profile the time individual lines of code take to
41 execute. The profiler is implemented in C via Cython in order to
42 reduce the overhead of profiling
43
44 %description -l pl.UTF-8
45 line_profile wskazuje czas wykonywania poszczególnych linii kodu. Jest
46 zaimplementowany w C poprzez Cythona tak aby zredukować narzut
47 profilowania.
48
49 %package -n python3-%{module}
50 Summary:        -
51 Summary(pl.UTF-8):      -
52 Group:          Libraries/Python
53 Requires:       python3-modules
54
55 %description -n python3-%{module}
56 line_profiler will profile the time individual lines of code take to
57 execute. The profiler is implemented in C via Cython in order to
58 reduce the overhead of profiling
59
60 %description -n python3-%{module} -l pl.UTF-8
61 line_profile wskazuje czas wykonywania poszczególnych linii kodu. Jest
62 zaimplementowany w C poprzez Cythona tak aby zredukować narzut
63 profilowania.
64
65 %package apidocs
66 Summary:        %{module} API documentation
67 Summary(pl.UTF-8):      Dokumentacja API %{module}
68 Group:          Documentation
69
70 %description apidocs
71 API documentation for %{module}.
72
73 %description apidocs -l pl.UTF-8
74 Dokumentacja API %{module}.
75
76 %prep
77 %setup -q -n %{module}-%{version}
78
79 %build
80 %if %{with python2}
81 CC="%{__cc}" \
82 CFLAGS="%{rpmcppflags} %{rpmcflags} -DHAVE_GETTIMEOFDAY" \
83 %py_build %{?with_tests:test}
84 %endif
85
86 %if %{with python3}
87 CC="%{__cc}" \
88 CFLAGS="%{rpmcppflags} %{rpmcflags} -DHAVE_GETTIMEOFDAY" \
89 %py3_build %{?with_tests:test}
90 %endif
91
92 %if %{with doc}
93 cd docs
94 %{__make} -j1 html
95 rm -rf _build/html/_sources
96 %endif
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %py_install
103
104 %py_postclean
105 %endif
106
107 %if %{with python3}
108 %py3_install
109 %endif
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %if %{with python2}
115 %files
116 %defattr(644,root,root,755)
117 %doc LICENSE.txt README.rst
118 %{py_sitedir}/kernprof.py[co]
119 %{py_sitedir}/line_profiler.py[co]
120 %attr(755,root,root) %{py_sitedir}/_line_profiler.so
121 %if "%{py_ver}" > "2.4"
122 %{py_sitedir}/%{module}-%{version}-py*.egg-info
123 %endif
124 %endif
125
126 %if %{with python3}
127 %files -n python3-%{module}
128 %defattr(644,root,root,755)
129 %doc LICENSE.txt README.rst
130 %{py3_sitedir}/kernprof.py
131 %{py3_sitedir}/line_profiler.py
132 %{py3_sitedir}/__pycache__
133 %attr(755,root,root) %{py3_sitedir}/_line_profiler.cpython-*.so
134 %attr(755,root,root) %{_bindir}/kernprof
135 %{py3_sitedir}/%{module}-%{version}-py*.egg-info
136 %endif
137
138 %if %{with doc}
139 %files apidocs
140 %defattr(644,root,root,755)
141 %doc docs/_build/html/*
142 %endif
This page took 0.048271 seconds and 3 git commands to generate.