]> git.pld-linux.org Git - packages/python-line_profiler.git/blob - python-line_profiler.spec
rebuild with separate debuginfo build-ids
[packages/python-line_profiler.git] / python-line_profiler.spec
1 #
2 # Conditional build:
3 %bcond_with     doc             # don't build doc (not provided by package)
4 %bcond_without  tests   # do not perform "make test"
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module  line_profiler
9 Summary:        module for doing line-by-line profiling of functions
10 Summary(pl.UTF-8):      Moduł do optymalizacji linia po linii kodu funkcji
11 # Name must match the python module/package name (as in 'import' statement)
12 Name:           python-%{module}
13 Version:        2.1
14 Release:        5
15 License:        BSD
16 Group:          Libraries/Python
17 Source0:        https://github.com/rkern/line_profiler/archive/%{version}.tar.gz
18 # Source0-md5:  bd1cb2ba21af02339beab7ddc3a69c66
19 URL:            https://github.com/rkern/line_profiler
20 BuildRequires:  rpmbuild(macros) >= 1.710
21 BuildRequires:  rpm-pythonprov
22 %if %{with python2}
23 BuildRequires:  python-Cython
24 BuildRequires:  python-devel
25 BuildRequires:  python-distribute
26 BuildRequires:  python-ipython
27 %endif
28 %if %{with python3}
29 BuildRequires:  python3-Cython
30 BuildRequires:  python3-devel
31 BuildRequires:  python3-distribute
32 BuildRequires:  python3-ipython
33 BuildRequires:  python3-modules
34 %endif
35 Requires:       python-modules
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 line_profiler will profile the time individual lines of code take to
40 execute. The profiler is implemented in C via Cython in order to
41 reduce the overhead of profiling
42
43 %description -l pl.UTF-8
44 line_profile wskazuje czas wykonywania poszczególnych linii kodu. Jest
45 zaimplementowany w C poprzez Cythona tak aby zredukować narzut
46 profilowania.
47
48 %package -n python3-%{module}
49 Summary:        -
50 Summary(pl.UTF-8):      -
51 Group:          Libraries/Python
52 Requires:       python3-modules
53
54 %description -n python3-%{module}
55 line_profiler will profile the time individual lines of code take to
56 execute. The profiler is implemented in C via Cython in order to
57 reduce the overhead of profiling
58
59 %description -n python3-%{module} -l pl.UTF-8
60 line_profile wskazuje czas wykonywania poszczególnych linii kodu. Jest
61 zaimplementowany w C poprzez Cythona tak aby zredukować narzut
62 profilowania.
63
64 %package apidocs
65 Summary:        %{module} API documentation
66 Summary(pl.UTF-8):      Dokumentacja API %{module}
67 Group:          Documentation
68
69 %description apidocs
70 API documentation for %{module}.
71
72 %description apidocs -l pl.UTF-8
73 Dokumentacja API %{module}.
74
75 %prep
76 %setup -q -n %{module}-%{version}
77
78 %build
79 %if %{with python2}
80 CC="%{__cc}" \
81 CFLAGS="%{rpmcppflags} %{rpmcflags} -DHAVE_GETTIMEOFDAY" \
82 %py_build %{?with_tests:test}
83 %endif
84
85 %if %{with python3}
86 CC="%{__cc}" \
87 CFLAGS="%{rpmcppflags} %{rpmcflags} -DHAVE_GETTIMEOFDAY" \
88 %py3_build %{?with_tests:test}
89 %endif
90
91 %if %{with doc}
92 cd docs
93 %{__make} -j1 html
94 rm -rf _build/html/_sources
95 %endif
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %if %{with python2}
101 %py_install
102
103 %py_postclean
104 %endif
105
106 %if %{with python3}
107 %py3_install
108 %endif
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %if %{with python2}
114 %files
115 %defattr(644,root,root,755)
116 %doc LICENSE.txt README.rst
117 %{py_sitedir}/kernprof.py[co]
118 %{py_sitedir}/line_profiler.py[co]
119 %attr(755,root,root) %{py_sitedir}/_line_profiler.so
120 %if "%{py_ver}" > "2.4"
121 %{py_sitedir}/%{module}-%{version}-py*.egg-info
122 %endif
123 %endif
124
125 %if %{with python3}
126 %files -n python3-%{module}
127 %defattr(644,root,root,755)
128 %doc LICENSE.txt README.rst
129 %{py3_sitedir}/kernprof.py
130 %{py3_sitedir}/line_profiler.py
131 %{py3_sitedir}/__pycache__
132 %attr(755,root,root) %{py3_sitedir}/_line_profiler.cpython-*.so
133 %attr(755,root,root) %{_bindir}/kernprof
134 %{py3_sitedir}/%{module}-%{version}-py*.egg-info
135 %endif
136
137 %if %{with doc}
138 %files apidocs
139 %defattr(644,root,root,755)
140 %doc docs/_build/html/*
141 %endif
This page took 0.039218 seconds and 3 git commands to generate.