]> git.pld-linux.org Git - packages/python-line_profiler.git/blame_incremental - python-line_profiler.spec
- release 4 (by relup.sh)
[packages/python-line_profiler.git] / python-line_profiler.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with doc # don't build doc (not provided by package)
4%bcond_without tests # do not perform "make test"
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8%define module line_profiler
9Summary: module for doing line-by-line profiling of functions
10Summary(pl.UTF-8): Moduł do optymalizacji linia po linii kodu funkcji
11# Name must match the python module/package name (as in 'import' statement)
12Name: python-%{module}
13Version: 1.0
14Release: 4
15License: BSD
16Group: Libraries/Python
17Source0: https://pypi.python.org/packages/source/l/%{module}/%{module}-%{version}.tar.gz
18# Source0-md5: 2f8352acfedf83f701a564583db5e14d
19URL: https://github.com/rkern/line_profiler
20BuildRequires: rpm-pythonprov
21%if %{with python2}
22BuildRequires: python-devel
23BuildRequires: python-distribute
24%endif
25%if %{with python3}
26BuildRequires: python3-devel
27BuildRequires: python3-distribute
28BuildRequires: python3-modules
29%endif
30Requires: python-modules
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34line_profiler will profile the time individual lines of code take to
35execute. The profiler is implemented in C via Cython in order to
36reduce the overhead of profiling
37
38%description -l pl.UTF-8
39line_profile wskazuje czas wykonywania poszczególnych linii kodu. Jest
40zaimplementowany w C poprzez Cythona tak aby zredukować narzut
41profilowania.
42
43%package -n python3-%{module}
44Summary: -
45Summary(pl.UTF-8): -
46Group: Libraries/Python
47Requires: python3-modules
48
49%description -n python3-%{module}
50line_profiler will profile the time individual lines of code take to
51execute. The profiler is implemented in C via Cython in order to
52reduce the overhead of profiling
53
54%description -n python3-%{module} -l pl.UTF-8
55line_profile wskazuje czas wykonywania poszczególnych linii kodu. Jest
56zaimplementowany w C poprzez Cythona tak aby zredukować narzut
57profilowania.
58
59%package apidocs
60Summary: %{module} API documentation
61Summary(pl.UTF-8): Dokumentacja API %{module}
62Group: Documentation
63
64%description apidocs
65API documentation for %{module}.
66
67%description apidocs -l pl.UTF-8
68Dokumentacja API %{module}.
69
70%prep
71%setup -q -n %{module}-%{version}
72
73%build
74%if %{with python2}
75CC="%{__cc}" \
76CFLAGS="%{rpmcppflags} %{rpmcflags}" \
77%{__python} setup.py build --build-base build-2 %{?with_tests:test}
78%endif
79
80%if %{with python3}
81CC="%{__cc}" \
82CFLAGS="%{rpmcppflags} %{rpmcflags}" \
83%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
84%endif
85
86%if %{with doc}
87cd docs
88%{__make} -j1 html
89rm -rf _build/html/_sources
90%endif
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95%if %{with python2}
96%{__python} setup.py \
97 build --build-base build-2 \
98 install --skip-build \
99 --optimize=2 \
100 --root=$RPM_BUILD_ROOT
101
102%py_postclean
103%endif
104
105%if %{with python3}
106%{__python3} setup.py \
107 build --build-base build-3 \
108 install --skip-build \
109 --optimize=2 \
110 --root=$RPM_BUILD_ROOT
111%endif
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%if %{with python2}
117%files
118%defattr(644,root,root,755)
119%doc LICENSE.txt README.rst
120%{py_sitedir}/kernprof.py[co]
121%{py_sitedir}/line_profiler.py[co]
122%attr(755,root,root) %{py_sitedir}/_line_profiler.so
123%if "%{py_ver}" > "2.4"
124%{py_sitedir}/%{module}-%{version}-py*.egg-info
125%endif
126%endif
127
128%if %{with python3}
129%files -n python3-%{module}
130%defattr(644,root,root,755)
131%doc LICENSE.txt README.rst
132%{py3_sitedir}/kernprof.py
133%{py3_sitedir}/line_profiler.py
134%{py3_sitedir}/__pycache__
135%attr(755,root,root) %{py3_sitedir}/_line_profiler.cpython-*m.so
136%attr(755,root,root) %{_bindir}/kernprof
137%{py3_sitedir}/%{module}-%{version}-py*.egg-info
138%endif
139
140%if %{with doc}
141%files apidocs
142%defattr(644,root,root,755)
143%doc docs/_build/html/*
144%endif
This page took 0.072745 seconds and 4 git commands to generate.